Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian Development (http://www.linux-archive.org/debian-development/)
-   -   Amarok build-dep failure (http://www.linux-archive.org/debian-development/43344-amarok-build-dep-failure.html)

Ritesh Raj Sarraf 01-21-2008 05:23 PM

Amarok build-dep failure
 
Hi Modestas,

Since your name was in the Maintainer field for Amarok, I though of asking
you.

Currently, I don't see amarok having all its build dependencies satisfied.

rrs@learner:~$ apt-get build-dep amarok
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Build-dependencies for amarok could not be satisfied.

Is this a bug ?

Ritesh
--
Ritesh Raj Sarraf
RESEARCHUT - http://www.researchut.com
"Necessity is the mother of invention."

Neil Williams 01-21-2008 06:19 PM

Amarok build-dep failure
 
On Mon, 21 Jan 2008 23:53:07 +0530
Ritesh Raj Sarraf <rrs@researchut.com> wrote:

> Currently, I don't see amarok having all its build dependencies satisfied.

This isn't the fault of amarok - it simply means that the list of build dependencies cannot be installed on your system due to conflicts or pinned packages or problems with other dependencies. Your best bet is to try to install each of the build dependencies manually using the list in debian/control.

> E: Build-dependencies for amarok could not be satisfied.
>
> Is this a bug ?

It might be a wishlist/minor bug in apt to request a clearer error message but I don't see that it is a bug in amarok.

--

Neil Williams
=============
http://www.data-freedom.org/
http://www.nosoftwarepatents.com/
http://www.linux.codehelp.co.uk/

Modestas Vainius 01-21-2008 07:56 PM

Amarok build-dep failure
 
Hi,

2008 m. January 21 d., Monday, Ritesh Raj Sarraf rašė:
> rrs@learner:~$ apt-get build-dep amarok
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> E: Build-dependencies for amarok could not be satisfied.
>
> Is this a bug ?
No, pbuilder/cowbuilder is able to satisfy build dependencies. I think it's
rather that build dependences cannot be satisfied _in your environment_. You
do have bits of KDE4 installed, don't you? You can run:

# apt-cache showsrc amarok | grep Build-Depends | sed -e 's/[(]
[^)]+[)]//g' -e 's/,//g' | awk -F: '{print $2}' | xargs apt-get install

to see what's wrong.

--
Modestas Vainius <modestas@vainius.eu>


All times are GMT. The time now is 08:03 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.