Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian Development (http://www.linux-archive.org/debian-development/)
-   -   schroot not automatically bind-mounting /home (http://www.linux-archive.org/debian-development/320823-schroot-not-automatically-bind-mounting-home.html)

Kevin Coyner 02-04-2010 06:14 PM

schroot not automatically bind-mounting /home
 
I've recently installed debootstrap and schroot on a squeeze setup so
that I can build packages in sid.

I've got it more or less working except for being able to get /home/
to automatically bind-mount my real /home.

When I run schroot, I get:

kosuke$ schroot --debug=critical
W: Failed to change to directory ‘/home/kevin’: No such file or directory
W: Falling back to directory ‘/’
I have no name!@kosuke:/$

So I can get a working sid chroot, but I don't get my original /home.

Since I have the machine running an encrypted LVM setup, I wondered
whether that was causing problems. So in the file
/etc/schroot/mount-defaults I changed the line:

/home /home none rw,bind 0 0

to:

/dev/mapper/thinkpad--t400-home /home ext3 rw,bind 0 0

to correspond with how my /home is normally mounted. But that didn't work.

Would appreciate any guidance if anyone has encountered this before.

Many thanks,
Kevin


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org


All times are GMT. The time now is 08:53 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.