FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Development

 
 
LinkBack Thread Tools
 
Old 11-11-2009, 11:24 AM
Hendrik Sattler
 
Default Minimal kernel version raised to 2.6.27

Zitat von Julien Cristau <jcristau@debian.org>:


On Wed, Nov 11, 2009 at 02:14:00 -0600, Adam Majer wrote:


On Wed, Nov 11, 2009 at 07:56:16AM +0100, Bastian Blank wrote:
> On Tue, Nov 10, 2009 at 06:08:08PM +0100, Marco d'Itri wrote:
> > Due to changes in udev 147, squeeze will not support kernels earlier
> > than 2.6.27.
>
> What are these changes?


http://git.kernel.org/?p=linux/hotplug/udev.git;a=commit;h=26347a4c5538008318188118872490 128f43fcd3


But still using pipe() instead of pipe2()? Was that commit incomplete?

HS



--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 11-11-2009, 01:21 PM
 
Default Minimal kernel version raised to 2.6.27

On Nov 10, Marco d'Itri <md@Linux.IT> wrote:

> Due to changes in udev 147, squeeze will not support kernels earlier
> than 2.6.27.
I uploaded a 147-2 package which reverts the O_CLOEXEC change and allows
2.6.26, let's see if it works.

--
ciao,
Marco
 
Old 11-11-2009, 02:45 PM
Goswin von Brederlow
 
Default Minimal kernel version raised to 2.6.27

md@Linux.IT (Marco d'Itri) writes:

> On Nov 10, Marco d'Itri <md@Linux.IT> wrote:
>
>> Due to changes in udev 147, squeeze will not support kernels earlier
>> than 2.6.27.
> I uploaded a 147-2 package which reverts the O_CLOEXEC change and allows
> 2.6.26, let's see if it works.
>
> --
> ciao,
> Marco

According to "man 2 open":

O_CLOEXEC (Since Linux 2.6.23)

So why does using this flag require 2.6.27? Who is wrong here?

MfG
Goswin


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 11-11-2009, 02:51 PM
 
Default Minimal kernel version raised to 2.6.27

On Nov 11, Goswin von Brederlow <goswin-v-b@web.de> wrote:

> O_CLOEXEC (Since Linux 2.6.23)
>
> So why does using this flag require 2.6.27? Who is wrong here?
I understand that it is needed for inotify_init1(2).

--
ciao,
Marco
 
Old 11-11-2009, 02:53 PM
Julien Cristau
 
Default Minimal kernel version raised to 2.6.27

On Wed, Nov 11, 2009 at 16:45:58 +0100, Goswin von Brederlow wrote:

> According to "man 2 open":
>
> O_CLOEXEC (Since Linux 2.6.23)
>
> So why does using this flag require 2.6.27? Who is wrong here?
>
If you'd actually bothered to look at the changes in question, you would
have noticed that there's more syscalls than just open(2).
inotify_init1() was added in 2.6.27, e.g. Not that I'd expect you to do
your homework.

Cheers,
Julien


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 11-11-2009, 03:02 PM
Bastian Blank
 
Default Minimal kernel version raised to 2.6.27

On Wed, Nov 11, 2009 at 04:51:49PM +0100, Marco d'Itri wrote:
> On Nov 11, Goswin von Brederlow <goswin-v-b@web.de> wrote:
>
> > O_CLOEXEC (Since Linux 2.6.23)
> > So why does using this flag require 2.6.27? Who is wrong here?
> I understand that it is needed for inotify_init1(2).

That makes more send. The syscall was introduced, not the flag.

Bastian

--
Worlds are conquered, galaxies destroyed -- but a woman is always a woman.
-- Kirk, "The Conscience of the King", stardate 2818.9


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 11-11-2009, 03:41 PM
Goswin von Brederlow
 
Default Minimal kernel version raised to 2.6.27

Julien Cristau <jcristau@debian.org> writes:

> On Wed, Nov 11, 2009 at 16:45:58 +0100, Goswin von Brederlow wrote:
>
>> According to "man 2 open":
>>
>> O_CLOEXEC (Since Linux 2.6.23)
>>
>> So why does using this flag require 2.6.27? Who is wrong here?
>>
> If you'd actually bothered to look at the changes in question, you would
> have noticed that there's more syscalls than just open(2).
> inotify_init1() was added in 2.6.27, e.g. Not that I'd expect you to do
> your homework.
>
> Cheers,
> Julien

Homework: Find out how

I uploaded a 147-2 package which reverts the O_CLOEXEC change and
allows 2.6.26, let's see if it works.

translates to

I stop using inotify_init1().


Thank you for presenting information in the most agressive way.

MfG
Goswin


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 11-11-2009, 04:28 PM
Cyril Brulebois
 
Default Minimal kernel version raised to 2.6.27

Goswin von Brederlow <goswin-v-b@web.de> (11/11/2009):
> Homework: Find out how
>
> I uploaded a 147-2 package which reverts the O_CLOEXEC change and
> allows 2.6.26, let's see if it works.
>
> translates to
>
> I stop using inotify_init1().

Easy:
| --- a/udev/udev-watch.c
| +++ b/udev/udev-watch.c
| @@ -38,8 +38,10 @@ static int inotify_fd = -1;
| */
| int udev_watch_init(struct udev *udev)
| {
| - inotify_fd = inotify_init1(IN_CLOEXEC);
| - if (inotify_fd < 0)
| + inotify_fd = inotify_init();
| + if (inotify_fd >= 0)
| + util_set_fd_cloexec(inotify_fd);
| + else
| err(udev, "inotify_init failed: %m
");
| return inotify_fd;
| }

It *might* be that *CLOEXEC are concerned.

Next time, try to RTFD? Oh wait, that was Julien's point already.

> Thank you for presenting information in the most agressive way.

While still being kind of… dead right.

Mraw,
KiBi.
 
Old 11-12-2009, 07:24 AM
"Frank Lin PIAT"
 
Default Minimal kernel version raised to 2.6.27

Marco d'Itri wrote:
> On Nov 10, Marco d'Itri <md@Linux.IT> wrote:
>
>> Due to changes in udev 147, squeeze will not support kernels earlier
>> than 2.6.27.
> I uploaded a 147-2 package which reverts the O_CLOEXEC change and allows
> 2.6.26, let's see if it works.

Big thanks for working on this issue. I hope it's gonna work.
(I can test it today)

Franklin


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 01-14-2010, 10:51 AM
Fathi Boudra
 
Default Minimal kernel version raised to 2.6.27

Hi,

I would like to come back to the distribution upgrade issue since udev
package cannot be installed if the kernel doesn't support
CONFIG_SYSFS_DEPRECATED (like Lenny kernel 2.6.26).

Recently, I have updated a machine from Lenny to Squeeze and apt-get
dist-upgrade failed as expected.
The kernel 2.6.30 didn't finish installation. To fix the issue and
continue my dist-upgrade, I used apt-get -f install and finally had my
kernel installed. To continue the update, I restarted the machine, and
launched again apt-get dist-upgrade.

We are far from a smooth upgrade, is it acceptable from a user point of view .

Cheers,

Fathi


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 06:47 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org