Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian Development (http://www.linux-archive.org/debian-development/)
-   -   Minimum kernel requirement for Squeeze (http://www.linux-archive.org/debian-development/266496-minimum-kernel-requirement-squeeze.html)

Roger Leigh 03-19-2009 08:59 PM

Minimum kernel requirement for Squeeze
 
Hi folks,

With respect to #494001, I would like to determine the minimum
version of the linux kernel we will

a) support and
b) be physically capable of running

for Squeeze.

It has been asserted that squeeze will not work with kernels
< 2.6.26 by jcristau on IRC, but I haven't yet found any
rationale as to why this is the case (e.g. specific glibc
incompatibility).

If anyone could provide any specific details on this, that
would be great.


Thanks,
Roger

--
.'`. Roger Leigh
: :' : Debian GNU/Linux http://people.debian.org/~rleigh/
`. `' Printing on GNU/Linux? http://gutenprint.sourceforge.net/
`- GPG Public Key: 0x25BFB848 Please GPG sign your mail.


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

03-19-2009 11:25 PM

Minimum kernel requirement for Squeeze
 
On Mar 19, Roger Leigh <rleigh@codelibre.net> wrote:

> With respect to #494001, I would like to determine the minimum
> version of the linux kernel we will
For the new udev package[1] I am trying *very* hard to keep it working
even with 2.6.18 kernels long enough to be able to finish the upgrade,
but I can tell you that 2.6.22 is currently required to support
important features like persistent device names and this will only get
"worse" with time so next year I may end out requiring 2.6.26 anyway.

Also expect problems from a modern udev and lenny kernels, because they
have CONFIG_SYSFS_DEPRECATED defined.

I agree that there should be no version check in the init scripts, just
symlink mtab and almost everything will work fine.

BTW, the comment about using inotify on /etc/mtab is pure crack: the
orthodox way to be notified of file systems changes is to use inotify on
/proc/mounts.

[1] http://www.bofh.it/~md/debian/ please test it and report your
experience! Probably it's not toxic.

--
ciao,
Marco

Aurelien Jarno 03-22-2009 02:00 PM

Minimum kernel requirement for Squeeze
 
On Thu, Mar 19, 2009 at 09:59:06PM +0000, Roger Leigh wrote:
> Hi folks,
>
> With respect to #494001, I would like to determine the minimum
> version of the linux kernel we will
>
> a) support and
> b) be physically capable of running
>
> for Squeeze.
>
> It has been asserted that squeeze will not work with kernels
> < 2.6.26 by jcristau on IRC, but I haven't yet found any
> rationale as to why this is the case (e.g. specific glibc
> incompatibility).

glibc from squeeze will support kernels from etch, that is >= 2.6.18. I
don't know for other parts. Keep in mind that some build daemons still
have an etch kernel, while having squeeze and a sid chroots.

--
Aurelien Jarno GPG: 1024D/F1BCDB73
aurelien@aurel32.net http://www.aurel32.net


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org


All times are GMT. The time now is 08:17 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.