FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Development

 
 
LinkBack Thread Tools
 
Old 03-16-2009, 10:57 PM
Michelle Konzack
 
Default libcairo has two different versions in Lenny?

Fellow Developers,

last Friday I have downloaded the fist Debian install DVD fro Lenny and
for some mintes trie to install a new Workstation and gotten this:

----[ STDIN ]-----------------------------------------------------------
[root@michelle1:~ ] apt-get install fvwm
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
fvwm: Depends: libgtk2.0-0 (>= 2.12.0) but it is not going to be installed
Depends: librsvg2-2 (>= 2.18.1) but it is not going to be installed
E: Broken packages

[root@michelle1:~ ] apt-cache policy fvwm libgtk2.0-0 librsvg2-2
fvwm:
Installed: (none)
Candidate: 1:2.5.26-1
Version table:
1:2.5.26-1 0
900 ftp://ftp2.de.debian.org lenny/main Packages
libgtk2.0-0:
Installed: (none)
Candidate: 2.12.11-4
Version table:
2.12.11-4 0
920 cdrom://Lenny_DVD_1 lenny/main Packages
900 ftp://ftp2.de.debian.org lenny/main Packages
librsvg2-2:
Installed: (none)
Candidate: 2.22.2-2lenny1
Version table:
2.22.2-2lenny1 0
920 cdrom://Lenny_DVD_1 lenny/main Packages
900 ftp://ftp2.de.debian.org lenny/main Packages

[root@michelle1:~ ] apt-get install fvwm libgtk2.0-0 librsvg2-2 libcairo2 libpango1.0-0
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libgtk2.0-0: Depends: libcairo2 (>= 1.6.4-6.1) but 1.4.10-1+lenny2 is to be installed
libpango1.0-0: Depends: libcairo2 (>= 1.6.4-6.1) but 1.4.10-1+lenny2 is to be installed
E: Broken packages

[root@michelle1:~ ] apt-cache policy fvwm libgtk2.0-0 librsvg2-2 libcairo2 libpango1.0-0
fvwm:
Installed: (none)
Candidate: 1:2.5.26-1
Version table:
1:2.5.26-1 0
900 ftp://ftp2.de.debian.org lenny/main Packages
libgtk2.0-0:
Installed: (none)
Candidate: 2.12.11-4
Version table:
2.12.11-4 0
920 cdrom://Lenny_DVD_1 lenny/main Packages
900 ftp://ftp2.de.debian.org lenny/main Packages
librsvg2-2:
Installed: (none)
Candidate: 2.22.2-2lenny1
Version table:
2.22.2-2lenny1 0
920 cdrom://Lenny_DVD_1 lenny/main Packages
900 ftp://ftp2.de.debian.org lenny/main Packages
libcairo2:
Installed: (none)
Candidate: 1.4.10-1+lenny2
Version table:
1.6.4-7 0
920 cdrom://Lenny_DVD_1 lenny/main Packages
900 ftp://ftp2.de.debian.org lenny/main Packages
1.4.10-1+lenny2 0
980 http://security.debian.org lenny/updates/main Packages
libpango1.0-0:
Installed: (none)
Candidate: 1.20.5-3
Version table:
1.20.5-3 0
920 cdrom://Lenny_DVD_1 lenny/main Packages
900 ftp://ftp2.de.debian.org lenny/main Packages

------------------------------------------------------------------------

Can someone explain, WHY the SECURITY mirror has an outdated version of
libcairo2 and blocking the installation (I have manualy installed the
libcairo2, but it is annoying and should be corrected as fast as
possibel)


Thanks, Greetings and nice Day/Evening
Michelle Konzack
Systemadministrator
24V Electronic Engineer
Tamay Dogan Network
Debian GNU/Linux Consultant

--
Linux-User #280138 with the Linux Counter, http://counter.li.org/
##################### Debian GNU/Linux Consultant #####################
<http://www.tamay-dogan.net/> Michelle Konzack
<http://www.can4linux.org/> Apt. 917
<http://www.flexray4linux.org/> 50, rue de Soultz
Jabber linux4michelle@jabber.ccc.de 67100 Strasbourg/France
IRC #Debian (irc.icq.com) Tel. DE: +49 177 9351947
ICQ #328449886 Tel. FR: +33 6 61925193
 
Old 03-20-2009, 06:47 PM
Neil McGovern
 
Default libcairo has two different versions in Lenny?

On Tue, Mar 17, 2009 at 12:57:25AM +0100, Michelle Konzack wrote:
> 920 cdrom://Lenny_DVD_1 lenny/main Packages
> 900 ftp://ftp2.de.debian.org lenny/main Packages
> 980 http://security.debian.org lenny/updates/main Packages
[...]
> Can someone explain, WHY the SECURITY mirror has an outdated version of
> libcairo2 and blocking the installation (I have manualy installed the
> libcairo2, but it is annoying and should be corrected as fast as
> possibel)
>

You appear to have pinned things. As this is a list for Debian
Development, rather than basic user support, I would suggest you ask in
debian-users@lists.debian.org. FUs set.

> Debian GNU/Linux Consultant

That's worrying.

Neil
--
<Yoe> is _that_ gunnar?
<weasel> yes
<Yoe> what happened to his tires?
<towersbe> He's shrunk. I think his wife washed him at too high a temperature.


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 03-21-2009, 12:19 AM
Carsten Hey
 
Default libcairo has two different versions in Lenny?

On Fri, Mar 20, 2009 at 07:47:41PM +0000, Neil McGovern wrote:
> On Tue, Mar 17, 2009 at 12:57:25AM +0100, Michelle Konzack wrote:
> > 920 cdrom://Lenny_DVD_1 lenny/main Packages
> > 900 ftp://ftp2.de.debian.org lenny/main Packages
> > 980 http://security.debian.org lenny/updates/main Packages
> [...]
> > Can someone explain, WHY the SECURITY mirror has an outdated version of
> > libcairo2 and blocking the installation (I have manualy installed the
> > libcairo2, but it is annoying and should be corrected as fast as
> > possibel)
> >
>
> You appear to have pinned things. As this is a list for Debian
> Development, rather than basic user support, I would suggest you ask in
> debian-users@lists.debian.org. FUs set.

This was an upload to testing-security which hit stable-security during
the release. Such things are the reason why pinning stable-security
with a higher priority than stable is not a good idea.


Carsten


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 03-21-2009, 01:40 AM
Michelle Konzack
 
Default libcairo has two different versions in Lenny?

Am 2009-03-21 02:19:38, schrieb Carsten Hey:
> This was an upload to testing-security which hit stable-security during
> the release. Such things are the reason why pinning stable-security
> with a higher priority than stable is not a good idea.

Which mean, the libcairo2 in security/lenny
has to be removed by ftpmaster.

Thanks, Greetings and nice Day/Evening
Michelle Konzack
Systemadministrator
24V Electronic Engineer
Tamay Dogan Network
Debian GNU/Linux Consultant

--
Linux-User #280138 with the Linux Counter, http://counter.li.org/
##################### Debian GNU/Linux Consultant #####################
<http://www.tamay-dogan.net/> Michelle Konzack
<http://www.can4linux.org/> Apt. 917
<http://www.flexray4linux.org/> 50, rue de Soultz
Jabber linux4michelle@jabber.ccc.de 67100 Strasbourg/France
IRC #Debian (irc.icq.com) Tel. DE: +49 177 9351947
ICQ #328449886 Tel. FR: +33 6 61925193
 

Thread Tools




All times are GMT. The time now is 01:56 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org