Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Debian Development (http://www.linux-archive.org/debian-development/)
-   -   toolame: remove from unstable, update in stable (http://www.linux-archive.org/debian-development/261933-toolame-remove-unstable-update-stable.html)

Fabian Greffrath 03-12-2009 12:07 PM

toolame: remove from unstable, update in stable
 
Dear -release,
[CC'ing pkg-multimedia-maintainers as the current toolame maintainers,
pkg-mythtv-maintainers as the current twolame maintainers and
debian-devel for general discussion ;) ]

I am going to request the removal of the toolame package from unstable
and testing in the short term. toolame hasn't seen a release in six
years, it is dead upstream, it has bugs and is superseded by its
successor twolame (yes, there's a t_o_olame and a t_w_olame). People
should really be using twolame instead, as it has an active upstream,
has its bugs fixed and provides a shared library that is already used
by projects such as gstreamer and audacity.

However, I think the toolame package in stable may stay both for the
convenience of our users and because it's not *that* bad after all. I
have prepared a package targeted at Lenny that fixes two portability
bugs and some minor lintian warnings. It can be found at mentors.d.n
[1], the debdiff is attached to this mail. Please tell me if or under
which restrictions it is OK to upload it to stable or s-p-u.

My general question regarding the removal of toolame is: Should we
provide a transition and if yes... how? I consider the following
methods to deal with this issue:

1. Remove the toolame package from unstable and testing. End of story.
2. Provide an empty toolame package that depends on twolame.
3a. Provide a wrapper in the toolame package that calls the twolame
binary with the same command line options (or some translations
respectively). toolame and twolame are command line compatible except
for some very exotic flags.

3b. The twolame source creates a toolame package that contains the
above mentioned wrapper script.
4. Make the twolame package provide toolame, so that at least the few
recommends on the toolame package can be satisfied.

5. What else can you imagine/recommend...?

Thank you very much for your suggestions.

Cheers,
Fabian


[1] http://mentors.debian.net/debian/pool/main/t/toolame/toolame_02l-7.dsc

--
Dipl.-Phys. Fabian Greffrath

Ruhr-Universität Bochum
Lehrstuhl für Energieanlagen und Energieprozesstechnik (LEAT)
Universitätsstr. 150, IB 3/134
D-44780 Bochum

Telefon: +49 (0)234 / 32-26334
Fax: +49 (0)234 / 32-14227
E-Mail: greffrath@leat.ruhr-uni-bochum.de

Luk Claes 03-15-2009 10:19 AM

toolame: remove from unstable, update in stable
 
Fabian Greffrath wrote:

> However, I think the toolame package in stable may stay both for the
> convenience of our users and because it's not *that* bad after all. I
> have prepared a package targeted at Lenny that fixes two portability
> bugs and some minor lintian warnings. It can be found at mentors.d.n
> [1], the debdiff is attached to this mail. Please tell me if or under
> which restrictions it is OK to upload it to stable or s-p-u.

It's ok, please mention the portability bugs on [0] and upload.

> My general question regarding the removal of toolame is: Should we
> provide a transition and if yes... how? I consider the following methods
> to deal with this issue:

> 2. Provide an empty toolame package that depends on twolame.

Preferably in the twolame source package.

Cheers

Luk

[0] http://wiki.debian.org/DebianReleases/PointReleases/5.0.1


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Mark Purcell 03-15-2009 10:35 AM

toolame: remove from unstable, update in stable
 
On Sunday 15 March 2009 22:19:14 Luk Claes wrote:
> > 2. Provide an empty toolame package that depends on twolame.
>
> Preferably in the twolame source package.

As the current twolame maintainer.

I would be happy with this approach.

Mark

Fabian Greffrath 03-16-2009 07:08 AM

toolame: remove from unstable, update in stable
 
Luk Claes schrieb:

It's ok, please mention the portability bugs on [0] and upload.


Unfortunately IANADD, so I cannot modify the wiki page on my own. The
closed bugs are #504308 and #506193. Maybe someone can do me the favor
and add them on the wiki page once the package has been uploaded.


To which dist should I upload, stable or stable-proposed-updates?
Which version number should I choose?


Mark Purcell schrieb:
> As the current twolame maintainer.
> I would be happy with this approach.

Great, thank you very much!

Fabian

--
Dipl.-Phys. Fabian Greffrath

Ruhr-Universität Bochum
Lehrstuhl für Energieanlagen und Energieprozesstechnik (LEAT)
Universitätsstr. 150, IB 3/134
D-44780 Bochum

Telefon: +49 (0)234 / 32-26334
Fax: +49 (0)234 / 32-14227
E-Mail: greffrath@leat.ruhr-uni-bochum.de


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Cyril Brulebois 03-16-2009 05:07 PM

toolame: remove from unstable, update in stable
 
Fabian Greffrath <greffrath@leat.rub.de> (16/03/2009):
> Unfortunately IANADD, so I cannot modify the wiki page on my own.

Yes, you can!

Mraw,
KiBi.

Fabian Greffrath 03-17-2009 11:05 AM

toolame: remove from unstable, update in stable
 
Cyril Brulebois schrieb:

Yes, you can!


And yes, i did! ;)


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org


All times are GMT. The time now is 06:44 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.