FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Development

 
 
LinkBack Thread Tools
 
Old 03-06-2009, 03:18 AM
Paul Wise
 
Default Prefix level in Quilt patches (was: Support of new source packages in squeeze)

On Fri, Mar 6, 2009 at 10:12 AM, Ben Finney <ben+debian@benfinney.id.au> wrote:

> How can I reliably inform the Debian packaging tools that my quilt
> patches are in ‘patch -p0’ format?

You don't want to use -p0 otherwise you'll get bugs from buxy about
not supporting dpkg source package v3. I'm using this to generate my
patches:

$ grep REFRESH ~/.quiltrc
QUILT_REFRESH_ARGS="-pab --no-timestamps --no-index"

If you actually want -p0 for some weird reason, make sure the series
file has that option in it:

$ locate debian/patches/series | xargs grep -- -p0
...
/home/pabs/devel/debian/games/gravitation/debian/patches/series:abs_path.patch
-p0
/home/pabs/devel/debian/games/passage/debian/patches/series:abs_path.patch -p0
/home/pabs/devel/debian/games/passage/debian/patches/series:amd64_fix.patch -p0
...

--
bye,
pabs

http://wiki.debian.org/PaulWise


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 10:16 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org