FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Development

 
 
LinkBack Thread Tools
 
Old 12-08-2008, 11:16 PM
Rene Engelhard
 
Default Accepted suitesparse 3.2.0-1 (source all i386)

Hi,

Christophe Prud'homme wrote:
> suitesparse (3.2.0-1) unstable; urgency=low
^^^^^^^^

WTF?

> Accepted:
> libsuitesparse-3.2.0_3.2.0-1_i386.deb
> to pool/main/s/suitesparse/libsuitesparse-3.2.0_3.2.0-1_i386.deb
> libsuitesparse-dbg_3.2.0-1_i386.deb
> to pool/main/s/suitesparse/libsuitesparse-dbg_3.2.0-1_i386.deb
> libsuitesparse-dev_3.2.0-1_i386.deb
> to pool/main/s/suitesparse/libsuitesparse-dev_3.2.0-1_i386.deb
> libsuitesparse-doc_3.2.0-1_all.deb
> to pool/main/s/suitesparse/libsuitesparse-doc_3.2.0-1_all.deb
> suitesparse_3.2.0-1.diff.gz
> to pool/main/s/suitesparse/suitesparse_3.2.0-1.diff.gz
> suitesparse_3.2.0-1.dsc
> to pool/main/s/suitesparse/suitesparse_3.2.0-1.dsc
> suitesparse_3.2.0.orig.tar.gz
> to pool/main/s/suitesparse/suitesparse_3.2.0.orig.tar.gz

Nice. Uploading a NEW PACKAGE NAME version of suitesparse, breaking all
of the following reverse-deps:

rene@mini:~$ grep-available -FDepends libsuitesparse-3.1.0 -sPackage
Package: libsuitesparse-dev
Package: illuminator-demo
Package: libluminate7
Package: python-scipy
Package: libpetsc2.3.3
Package: openoffice.org-calc
Package: lp-solve
Package: octave3.0
Package: octave3.1
Package: python-sparse
Package: freemat
Package: libsuitesparse-dbg

(and openoffice.org-core in turn depends on lp-solve).

When those now get rebuilt in sid against the new suitesparse (and they need to
because they will become uninstallable when libsuitesparse-3.1.0 semi-automatically
get removed) they can't be fixed via sid anymore.

Did you EVER hear of the freeze?
Upload such stuff to experimental.

Anyway, we discussed that quickly on #debian-relese.
Reverted. Will NMU with epoch uploading 3.1.0 again.

Grüße/Regards,

René
--
.'`. René Engelhard -- Debian GNU/Linux Developer
: :' : http://www.debian.org | http://people.debian.org/~rene/
`. `' rene@debian.org | GnuPG-Key ID: 248AEB73
`- Fingerprint: 41FA F208 28D4 7CA5 19BB 7AD9 F859 90B0 248A EB73


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 06:35 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org