FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Development

 
 
LinkBack Thread Tools
 
Old 07-20-2008, 10:41 AM
Frank Küster
 
Default glib inconsistencies in testing

Hi,

since a couple of days ago, I keep getting this message on a lenny
system during the configure phase of (seemingly) arbitrary packages:

Setting up samba-common (2:3.0.31-1) ...
*** This build of Glib was compiled with glib 2.16.4, but is currently running with 2.16.3, which is too old. We'll continue, but expect problems!

findpkg -b -r -v libglib2.0-0

***************** unstable *****************

Package: libglib2.0-0
Version: 2.16.4-2
Package: libglib2.0-0-dbg
Version: 2.16.4-2

***************** testing *****************

Package: libglib2.0-0
Version: 2.16.3-2
Package: libglib2.0-0-dbg
Version: 2.16.3-2

It seems like some package which is frequently used in postinsts
declares insufficiently strict dependencies on libglib. Before I start
playing around with postinst scripts, is this issue known and reported?

Regards, Frank


--
Frank Küster
Debian Developer (teTeX/TeXLive)


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 07-20-2008, 03:34 PM
Steve Langasek
 
Default glib inconsistencies in testing

On Sun, Jul 20, 2008 at 12:41:34PM +0200, Frank Küster wrote:

> since a couple of days ago, I keep getting this message on a lenny
> system during the configure phase of (seemingly) arbitrary packages:

> Setting up samba-common (2:3.0.31-1) ...
> *** This build of Glib was compiled with glib 2.16.4, but is currently
> running with 2.16.3, which is too old. We'll continue, but expect
> problems!

If you're seeing this from samba-common, the culprit will have to be
debconf (-> libglib-perl).

> It seems like some package which is frequently used in postinsts
> declares insufficiently strict dependencies on libglib. Before I start
> playing around with postinst scripts, is this issue known and reported?

Actually, the bug is that libglib-perl is second-guessing glib's package
dependencies and spitting out warnings that it shouldn't.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
slangasek@ubuntu.com vorlon@debian.org


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 07-20-2008, 03:57 PM
Frank Küster
 
Default glib inconsistencies in testing

Steve Langasek <vorlon@debian.org> wrote:

> Actually, the bug is that libglib-perl is second-guessing glib's package
> dependencies and spitting out warnings that it shouldn't.

And it's already reported?

Thanks, Frank

--
Frank Küster
Debian Developer (teTeX/TeXLive)


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 07-20-2008, 06:49 PM
Steve Langasek
 
Default glib inconsistencies in testing

On Sun, Jul 20, 2008 at 05:57:26PM +0200, Frank Küster wrote:
> Steve Langasek <vorlon@debian.org> wrote:

> > Actually, the bug is that libglib-perl is second-guessing glib's package
> > dependencies and spitting out warnings that it shouldn't.

> And it's already reported?

Well, I don't see it on <http://bugs.debian.org/src:libglib-perl>, so I
guess it hasn't been reported, no. Perhaps you would like to do so, since
you're seeing the bug in question?

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
slangasek@ubuntu.com vorlon@debian.org


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 07-21-2008, 10:47 AM
Loïc Minier
 
Default glib inconsistencies in testing

On Sun, Jul 20, 2008, Frank Küster wrote:
> *** This build of Glib was compiled with glib 2.16.4, but is currently running with 2.16.3, which is too old. We'll continue, but expect problems!

If it does make any difference, then you should be bumping the
build-dep to >= 2.16.4. glib's symbol files will use this build-dep
version as a minimum dep version for shlibdeps.

But I guess it doesn't make any difference and is just a hardwired
upstream test.

--
Loïc Minier


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 07:54 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org