FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Development

 
 
LinkBack Thread Tools
 
Old 07-17-2008, 09:20 AM
Andreas Tille
 
Default Bug#491156: ITP: postgresql-8.3-plr -- Procedural language interface between PostgreSQL 8.3 and R

Package: wnpp
Severity: wishlist
Owner: Andreas Tille <tillea@rki.de>

* Package name : postgresql-8.3-plr
Version : 8.3.0.6
Upstream Author : Joe Conway <mail@joeconway.com>
* URL : http://www.joeconway.com/plr/
* License : GPL
Programming Lang: C
Description : Procedural language interface between PostgreSQL 8.3 and R
R is a language and environment for statistical computing and graphics,
providing a wide variety of statistical and graphical techniques (linear and
nonlinear modelling, statistical tests, time series analysis, classification,
clustering, and so on).
.
PostgreSQL is an open source SQL database server.
.
This package provides a procedural language interface to R from
PostgreSQL 8.3. Procedural languages are used to write functions
which can be called in database queries.

This package was removed from Debian (see #228074, which can not be
reopened because it is archived). The reason that it is RC buggy) is
void because #461995 took me 1 Minute to fix (well, you can blame me
for not having this done before the removal - the package was just not
on my focus). The other reason "few users" is probably right considering
popcon, but this as the only reason to remove a package is not enough.
I think upgradebility from Etch to Lenny is a much higher value.
So I ask for reintroducing this package quickly.

I prepared lintian clean packages of the latest version.

Kind regards

Andreas.

-- System Information:
Debian Release: lenny/sid
APT prefers testing
APT policy: (501, 'testing'), (50, 'unstable'), (5, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 2.6.22-3-686 (SMP w/1 CPU core)
Locale: LANG=de_DE@euro, LC_CTYPE=de_DE@euro (charmap=ISO-8859-15)
Shell: /bin/sh linked to /bin/bash



--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 07-17-2008, 10:24 AM
Thomas Viehmann
 
Default Bug#491156: ITP: postgresql-8.3-plr -- Procedural language interface between PostgreSQL 8.3 and R

Hi Andreas,

Andreas Tille wrote:
> This package was removed from Debian (see #228074, which can not be
> reopened because it is archived). The reason that it is RC buggy) is
> void because #461995 took me 1 Minute to fix (well, you can blame me
> for not having this done before the removal - the package was just not
> on my focus). The other reason "few users" is probably right considering
> popcon, but this as the only reason to remove a package is not enough.
> I think upgradebility from Etch to Lenny is a much higher value.
> So I ask for reintroducing this package quickly.

The package was removed after noone was interested in maintaining it for
four(!) years. Unless you plan to diligently maintain it, please do not
reintroduce it into Debian. Contrary to what could be the perception
when looking at some packaging efforts, Debian is not an encyclopedia of
every bit of source that has ever been available on the net.
If plr is unmaintained, it should not be released with lenny.

Kind regards

T.
--
Thomas Viehmann, http://thomas.viehmann.net/


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 07-17-2008, 11:54 AM
Andreas Tille
 
Default Bug#491156: ITP: postgresql-8.3-plr -- Procedural language interface between PostgreSQL 8.3 and R

On Thu, 17 Jul 2008, Thomas Viehmann wrote:


The package was removed after noone was interested in maintaining it for
four(!) years.


Huh?


plr (1:8.2.0.7-2) unstable; urgency=low

* Orphan package (see #228074).

-- Martin Pitt <mpitt@debian.org> Sun, 30 Dec 2007 20:38:42 +0100


That's about 6 month and not four years.


Unless you plan to diligently maintain it, please do not
reintroduce it into Debian.


I plan to maintain it good enouth to trust it in a server application
I wrote. In case you might have some doubt here is the changelog of
my work:


plr (1:8.3.0.6-1) unstable; urgency=low

* New upstream version
* New maintainer (package was removed from Debian and is subject
to reinclude)
* Added watch file
* Use quilt to apply patch
* Standards-Version: 3.8.0 (Added README.Sources because of using quilt)
* Provides: postgresql-plr
* debian/install: Make sure that any new version of the library gets
moved to the right destination
Closes: #461995

-- Andreas Tille <tille@debian.org> Wed, 16 Jul 2008 16:17:11 +0200


Feel free to inspect the bugs that are attached to my maintainer address
if you want to make up your mind if I care for my packages.


Contrary to what could be the perception
when looking at some packaging efforts, Debian is not an encyclopedia of
every bit of source that has ever been available on the net.
If plr is unmaintained, it should not be released with lenny.


I fail to see the relevance of this paragraph related to the plr issue.

Kind regards

Andreas.

--
http://fam-tille.de


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 07-17-2008, 12:12 PM
"Adam D. Barratt"
 
Default Bug#491156: ITP: postgresql-8.3-plr -- Procedural language interface between PostgreSQL 8.3 and R

Andreas Tille wrote:

On Thu, 17 Jul 2008, Thomas Viehmann wrote:


The package was removed after noone was interested in maintaining it
for four(!) years.


Huh?

[...]

* Orphan package (see #228074).

-- Martin Pitt <mpitt@debian.org> Sun, 30 Dec 2007 20:38:42 +0100


That's about 6 month and not four years.


#228074 is an RFA for the package, filed in January 2004 and with no sign of
any interest.


Adam



--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 07-17-2008, 12:31 PM
Andreas Tille
 
Default Bug#491156: ITP: postgresql-8.3-plr -- Procedural language interface between PostgreSQL 8.3 and R

On Thu, 17 Jul 2008, Adam D. Barratt wrote:

#228074 is an RFA for the package, filed in January 2004 and with no sign of
any interest.


Well, we might start nitpicking about the past whether an RFAed package
that is actively updated by its mainteiner is "interest in maintenance"
or not. I'd prefer to decide whether we want it back now or not.

Kind regards

Andreas.

--
http://fam-tille.de


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 12:47 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org