FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Debian > Debian Development

 
 
LinkBack Thread Tools
 
Old 07-03-2008, 06:04 PM
Andreas Metzler
 
Default upgrade problems switching from conflictiong to depending packages

Hello,

I found this when trying to solve #369386. There seems to be a problem
when trying to go from two conflicting packages to a dummy package and
the prefered one:

Before:
Package: lynx
Version: 2.8.6-2.1
Conflicts: lynx-cur

Package: lynx-cur
Version: 2.8.7dev9-1
Conflicts: lynx

After:
Package: lynx
# dummy packge
Version: 2.8.7dev9-1.1
Depends: lynx-cur (>= 2.8.7dev9-1.1)

Package: lynx-cur
Version: 2.8.7dev9-1.1
Conflicts: lynx (<< 2.8.7dev9-1.1)

If you start with lynx installed and lynx-cur uninstalled but not
purged and run a dist-upgrade, the following happens:

1. apt runs dpkg -u lynx_newversion.deb
2. apt runs dpkg -u lynx-cur_newversion.deb
---------------
This fails with:
dpkg: regarding .../lynx-cur_2.8.7dev9-1.1_i386.deb containing lynx-cur:
lynx-cur conflicts with lynx
lynx (version 2.8.7dev9-1.1) is present and unpacked but not configured.
dpkg: error processing /tmp/lynx-apt/./lynx-cur_2.8.7dev9-1.1_i386.deb (--unpack):
---------------

The reason is simple to see, dpkg's status file now contains this:
Package: lynx
Depends: lynx-cur (>= 2.8.7dev9-1.1)
Version: 2.8.7dev9-1.1
Status: install ok unpacked

Package: lynx-cur
Version: 2.8.7dev9-1
Conflicts: lynx
Status: install ok config-files

Dpkg now seems to use this dependency/conflict info instead of the one
in the new package version. I *think* this is a bug in dpkg. The status
we are in dependency-wise before running 2. is perfectly fine,
conflicts to not hit for uninstalled (config-files) packages. The
status we would have after installing the new version of lynx-cur
would be fine too, since the new conflict is versioned.

Anyway what should I do?
* Is this a bug in dpkg?
* What is the workaround? I actually think my dependencies are correct and don't think there is lot I *could* to change.

The behavior is easy to reproduce:
apt-get install lynx-cur=2.8.7dev9-1 ; apt-get install lynx=2.8.6-2.1
dist-upgrade to the packages on http://www.bebt.de/debian/lynx-cur/

thanks, cu andreas
--
`What a good friend you are to him, Dr. Maturin. His other friends are
so grateful to you.'
`I sew his ears on from time to time, sure'


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 
Old 07-05-2008, 08:38 AM
Andreas Metzler
 
Default upgrade problems switching from conflictiong to depending packages

Andreas Metzler <ametzler@downhill.at.eu.org> wrote:
> Hello,

> I found this when trying to solve #369386. There seems to be a problem
> when trying to go from two conflicting packages to a dummy package and
> the prefered one:

[...]

I seem to have wrongly diagnosed the problem. The actual seems to have
been a Provides: lynx in lynx-cur. Removing it seems to have fixed the
problem for me.

cu andreas
--
`What a good friend you are to him, Dr. Maturin. His other friends are
so grateful to you.'
`I sew his ears on from time to time, sure'


--
To UNSUBSCRIBE, email to debian-devel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
 

Thread Tools




All times are GMT. The time now is 09:06 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org