FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > CRUX > CRUX

 
 
LinkBack Thread Tools
 
Old 04-30-2008, 11:52 PM
"Mats Pettersson"
 
Default Apache, mod_php, gd library and jpeg support question

Hi!

I just installed apache 2.2.8 and mod_php 5.2.5 with GD library. The problem
is that i can't get JPEG support from GD. I have PNG, XML, GIF support but
not JPEG (it says so when i do a phpinfo()). I have libjpeg installed and
according to the settings in the Pkgfile in opt/libjpeg it is compiled with
"--enable-shared" which i read somewhere is needed for GD to use it. Apache
and mod_php works fine besides the JPEG support. I'm using CRUX 2.3

Anything i've missed?


_______________________________________________
CRUX mailing list
CRUX@lists.crux.nu
http://lists.crux.nu/mailman/listinfo/crux
 
Old 05-01-2008, 08:17 AM
Clemens Koller
 
Default Apache, mod_php, gd library and jpeg support question

Mats Pettersson schrieb:
> Hi!
>
> I just installed apache 2.2.8 and mod_php 5.2.5 with GD library. The problem
> is that i can't get JPEG support from GD. I have PNG, XML, GIF support but
> not JPEG (it says so when i do a phpinfo()). I have libjpeg installed and
> according to the settings in the Pkgfile in opt/libjpeg it is compiled with
> "--enable-shared" which i read somewhere is needed for GD to use it. Apache
> and mod_php works fine besides the JPEG support. I'm using CRUX 2.3
>
> Anything i've missed?

http://www.phpbuilder.com/board/showthread.php?t=10303811

"Build the jpeg library from ftp://ftp.uu.net/graphics/jpeg/ and compile php --with-jpeg-dir=DIR"

I think your question is more specific to GD and you
will get an answer from there more likely.

Regards,

Clemens
_______________________________________________
CRUX mailing list
CRUX@lists.crux.nu
http://lists.crux.nu/mailman/listinfo/crux
 
Old 05-01-2008, 09:48 PM
"Mats Pettersson"
 
Default Apache, mod_php, gd library and jpeg support question

> Mats Pettersson schrieb:
>> Hi!
>>
>> I just installed apache 2.2.8 and mod_php 5.2.5 with GD library. The
>> problem is that i can't get JPEG support from GD. I have PNG, XML, GIF
>> support but not JPEG (it says so when i do a phpinfo()). I have libjpeg
>> installed and according to the settings in the Pkgfile in opt/libjpeg it
>> is compiled with "--enable-shared" which i read somewhere is needed for
>> GD to use it. Apache and mod_php works fine besides the JPEG support. I'm
>> using CRUX 2.3
>>
>> Anything i've missed?
>
> http://www.phpbuilder.com/board/showthread.php?t=10303811
>
> "Build the jpeg library from ftp://ftp.uu.net/graphics/jpeg/ and compile
> php --with-jpeg-dir=DIR"
>
> I think your question is more specific to GD and you
> will get an answer from there more likely.

Thanks! Now it works!

/Mats

_______________________________________________
CRUX mailing list
CRUX@lists.crux.nu
http://lists.crux.nu/mailman/listinfo/crux
 

Thread Tools




All times are GMT. The time now is 10:25 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org