FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > CRUX > CRUX

 
 
LinkBack Thread Tools
 
Old 04-20-2008, 02:58 PM
Markus Heinz
 
Default Problem with svn: cannot checkout xfburn sources

Hello,

for a few days now I am trying to update the xfburn port on my Crux 2.4
system. All other ports are up to date. It always hangs while running
the svn checkout command until I kill -9 the svn process. Exactly it
hangs after creating the .svn directory
under /usr/ports/xfce/xfburn/work/src/xfburn.

I have rebuilt the subversion port and all of its dependencies without a
change of the behaviour of the svn checkout command in the xfburn port.

I have asked someone else with a different system (Mac OS X) to
checkout the xfburn sources with the same command as in the xfburn
port. He could check out the sources without a problem.

I have no clue where else to search for the cause. Can anyone
please help me?

Regards,

Markus
_______________________________________________
CRUX mailing list
CRUX@lists.crux.nu
http://lists.crux.nu/mailman/listinfo/crux
 
Old 04-20-2008, 05:13 PM
Predrag Ivanovic
 
Default Problem with svn: cannot checkout xfburn sources

On Sun, 20 Apr 2008 16:58:16 +0200
Markus Heinz wrote:

> Hello,
Hi, Markus.
> for a few days now I am trying to update the xfburn port on my Crux 2.4
> system. All other ports are up to date. It always hangs while running
> the svn checkout command until I kill -9 the svn process. Exactly it
> hangs after creating the .svn directory
> under /usr/ports/xfce/xfburn/work/src/xfburn.
---
pedja@deus:/usr/ports/xfce/xfburn ]$ pkgmk
=======> Building `/usr/pkgmk/package/xfburn#0.3.0svn-4597-1.pkg.tar.gz'.
=======> Entering fakeroot environment
=======> Building `/usr/pkgmk/package/xfburn#0.3.0svn-4597-1.pkg.tar.gz'.
+ build
+ svn co -r4597 http://svn.xfce.org/svn/goodies/xfburn/trunk xfburn
A xfburn/update-changelog.sh
A xfburn/class diagram.zuml
A xfburn/xfburn.ui
<snip>
A xfburn/po/zh_CN.po
U xfburn
Checked out revision 4597.
---
It works fine here.

> I have rebuilt the subversion port and all of its dependencies without a
> change of the behaviour of the svn checkout command in the xfburn port.
>
> I have asked someone else with a different system (Mac OS X) to
> checkout the xfburn sources with the same command as in the xfburn
> port. He could check out the sources without a problem.

Have you tried to to use svn to checkout something else from Xfce repo i.e 'svn co http://svn.xfce.org/svn/xfce/squeeze/ trunk'
or from any other project?

> I have no clue where else to search for the cause. Can anyone
> please help me?

I uploaded xfburn sources tarball here[1], so you can build a port, and later you can check if
'svn update' works.
HTH

[1]http://rapidshare.com/files/109031102/xfburn.tar.gz.html

Pedja
--
Crux is like a good looking, really good looking, gorgeous, hot girl
without any cheap perfume or makeup, waiting for you to customize her
in any way you see fit. On top of that, she is free, permanent and
wont make absurd and disturbing demands.
- Kunal Anshu@OSNews
_______________________________________________
CRUX mailing list
CRUX@lists.crux.nu
http://lists.crux.nu/mailman/listinfo/crux
 
Old 04-20-2008, 05:17 PM
Tilman Sauerbeck
 
Default Problem with svn: cannot checkout xfburn sources

Predrag Ivanovic [2008-04-20 19:13]:
> > I have no clue where else to search for the cause. Can anyone
> > please help me?
>
> I uploaded xfburn sources tarball here[1], so you can build a port, and later you can check if
> 'svn update' works.
> HTH
>
> [1]http://rapidshare.com/files/109031102/xfburn.tar.gz.html

I suggest that the port is changed to not call "svn co", but to grab a
snapshot tarball off the web.
Jose, what do you think?

Regards,
Tilman

--
A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?
A: Top-posting.
Q: What is the most annoying thing on usenet and in e-mail?
_______________________________________________
CRUX mailing list
CRUX@lists.crux.nu
http://lists.crux.nu/mailman/listinfo/crux
 
Old 04-20-2008, 06:07 PM
Markus Heinz
 
Default Problem with svn: cannot checkout xfburn sources

Hello,

On Sun, 20 Apr 2008 19:13:03 +0200
Predrag Ivanovic <predivan@nadlanu.com> wrote:

> On Sun, 20 Apr 2008 16:58:16 +0200
> Markus Heinz wrote:
>
> > Hello,
> Hi, Markus.
> > for a few days now I am trying to update the xfburn port on my Crux
> > 2.4 system. All other ports are up to date. It always hangs while
> > running the svn checkout command until I kill -9 the svn process.
> > Exactly it hangs after creating the .svn directory
> > under /usr/ports/xfce/xfburn/work/src/xfburn.
> [...]
> It works fine here.
>
> > I have rebuilt the subversion port and all of its dependencies
> > without a change of the behaviour of the svn checkout command in
> > the xfburn port.
> >
> > I have asked someone else with a different system (Mac OS X) to
> > checkout the xfburn sources with the same command as in the xfburn
> > port. He could check out the sources without a problem.
>
> Have you tried to to use svn to checkout something else from Xfce
> repo i.e 'svn co http://svn.xfce.org/svn/xfce/squeeze/ trunk' or from
> any other project?

I have run the above command and it hang too after retrivieng the .svn
folder.

> > I have no clue where else to search for the cause. Can anyone
> > please help me?
>
> I uploaded xfburn sources tarball here[1], so you can build a port,
> and later you can check if 'svn update' works.

Thanks. At least I could build the port with the tarball. But running
an update in the xfburn folder did hang too.

Here some background information: I have installed the Gnome ports from
the Gnome repository in order be able to use Zattoo for which I have
created some ports too. Before installing Gnome I could run the svn
commands without problems. But now it does not work anymore. Until now
I do not see a relation between installing Gnome and Zattoo and svn
ceasing to function.

Regards,

Markus
_______________________________________________
CRUX mailing list
CRUX@lists.crux.nu
http://lists.crux.nu/mailman/listinfo/crux
 
Old 04-21-2008, 05:27 AM
Danny Rawlins
 
Default Problem with svn: cannot checkout xfburn sources

Tilman Sauerbeck wrote:
> Predrag Ivanovic [2008-04-20 19:13]:
>
>>> I have no clue where else to search for the cause. Can anyone
>>> please help me?
>>>
>> I uploaded xfburn sources tarball here[1], so you can build a port, and later you can check if
>> 'svn update' works.
>> HTH
>>
>> [1]http://rapidshare.com/files/109031102/xfburn.tar.gz.html
>>
>
> I suggest that the port is changed to not call "svn co", but to grab a
> snapshot tarball off the web.
>
Like I have done with x264 and other ports. Snapshots are a lot better
for a ports repository IMO as not everyone will want to install
subversion to get that port just like i got told off for forcing LZMA in
some of my ports.

Regards,
Romster
> Jose, what do you think?
>
> Regards,
> Tilman
>
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> CRUX mailing list
> CRUX@lists.crux.nu
> http://lists.crux.nu/mailman/listinfo/crux
>

_______________________________________________
CRUX mailing list
CRUX@lists.crux.nu
http://lists.crux.nu/mailman/listinfo/crux

Mon Apr 21 08:30:01 2008
Return-path: <gentoo-user+bounces-78662-tom=linux-archive.org@lists.gentoo.org>
Envelope-to: tom@linux-archive.org
Delivery-date: Mon, 21 Apr 2008 08:28:02 +0300
Received: from pigeon.gentoo.org ([69.77.167.62] helo=lists.gentoo.org)
by s2.java-tips.org with esmtp (Exim 4.68)
(envelope-from <gentoo-user+bounces-78662-tom=linux-archive.org@lists.gentoo.org>)
id 1JnoZO-0004h6-LY
for tom@linux-archive.org; Mon, 21 Apr 2008 08:28:02 +0300
Received: from pigeon.gentoo.org (localhost [127.0.0.1])
by pigeon.gentoo.org (Postfix) with SMTP id 44AAAE0294;
Mon, 21 Apr 2008 05:27:03 +0000 (UTC)
X-Original-To: gentoo-user@lists.gentoo.org
Delivered-To: gentoo-user@lists.gentoo.org
Received: from poczta.o2.pl (mx10.go2.pl [193.17.41.74])
by pigeon.gentoo.org (Postfix) with ESMTP id F3366E028A
for <gentoo-user@lists.gentoo.org>; Mon, 21 Apr 2008 05:27:01 +0000 (UTC)
Received: from poczta.o2.pl (mx10.go2.pl [127.0.0.1])
by poczta.o2.pl (Postfix) with ESMTP id E648B58021
for <gentoo-user@lists.gentoo.org>; Mon, 21 Apr 2008 07:27:00 +0200 (CEST)
Received: from [192.168.1.67] (unknown [83.238.169.96])
(using TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits))
(No client certificate requested)
by poczta.o2.pl (Postfix) with ESMTP
for <gentoo-user@lists.gentoo.org>; Mon, 21 Apr 2008 07:26:59 +0200 (CEST)
Message-ID: <480C27B1.5020905@o2.pl>
Date: Mon, 21 Apr 2008 07:35:45 +0200
From: =?ISO-8859-2?Q?=22Mateusz_A=2E_Mierzwi=F1ski=22?=
<mateuszmierzwinski@o2.pl>
User-Agent: Thunderbird 2.0.0.12 (X11/20080307)
Precedence: bulk
List-Post: <mailto:gentoo-user@lists.gentoo.org>
List-Help: <mailto:gentoo-user+help@lists.gentoo.org>
List-Unsubscribe: <mailto:gentoo-user+unsubscribe@lists.gentoo.org>
List-Subscribe: <mailto:gentoo-user+subscribe@lists.gentoo.org>
List-Id: Gentoo Linux mail <gentoo-user.gentoo.org>
X-BeenThere: gentoo-user@lists.gentoo.org
Reply-to: gentoo-user@lists.gentoo.org
MIME-Version: 1.0
To: gentoo-user@lists.gentoo.org
Subject: [gentoo-user] Samba build problem after system update
Content-Type: text/plain; charset=ISO-8859-2; format=flowed
Content-Transfer-Encoding: 7bit

Hi!

I have problem with installing/updating couple apps after system update.
After upgrading I've done revdep-rebuild (as usual) and everything is
ok. I've try to emerge autoconfig but error also occurred. What should I
do with this? Any suggestions?


* samba-3.0.28a.tar.gz RMD160 SHA1 SHA256 size ;-) ...
[ ok ]
* checking ebuild checksums ;-)
... [ ok ]
* checking auxfile checksums ;-)
... [ ok ]
* checking miscfile checksums ;-)
... [ ok ]
* checking samba-3.0.28a.tar.gz ;-)
... [ ok ]
>>> Unpacking source...
>>> Unpacking samba-3.0.28a.tar.gz to
/var/tmp/portage/net-fs/samba-3.0.28a/work
* Applying 3.0.26a-lazyldflags.patch
... [ ok ]
* Applying 3.0.26a-invalid-free-fix.patch
... [ ok ]
* Applying 3.0.28-libcap_detection.patch
... [ ok ]
* Applying 3.0.28-fix_broken_readdir_detection.patch
... [ ok ]
* Running autoconf -I. -Ilib/replace
... [ !! ]

* Failed Running autoconf !
*
* Include in your bugreport the contents of:
*
* /var/tmp/portage/net-fs/samba-3.0.28a/temp/autoconf-22578.out

*
* ERROR: net-fs/samba-3.0.28a failed.
* Call stack:
* ebuild.sh, line 49: Called src_unpack
* environment, line 3625: Called eautoconf '-I.'
'-Ilib/replace'
* environment, line 1276: Called autotools_run_tool
'autoconf' '-I.' '-Ilib/replace'
* environment, line 572: Called die
* The specific snippet of code:
* die "Failed Running $1 !";
* The die message:
* Failed Running autoconf !
*
* If you need support, post the topmost build error, and the call stack
if relevant.
* A complete build log is located at
'/var/tmp/portage/net-fs/samba-3.0.28a/temp/build.log'.
* The ebuild environment file is located at
'/var/tmp/portage/net-fs/samba-3.0.28a/temp/environment'.


Greet's
Mateusz M.

PS: Environment is not hardned, x86_64 architecture on Intel Core 2 Quad
CPU.
--
gentoo-user@lists.gentoo.org mailing list
 

Thread Tools




All times are GMT. The time now is 02:38 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org