FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > CRUX > CRUX

 
 
LinkBack Thread Tools
 
Old 06-14-2010, 05:04 AM
James Mills
 
Default Xorg keyboard/mouse

Hi all,

I'm sorry about this, but I'm at a complete loss.
Everything I've tried gets me nowhere.

Problem: keyboard and mouse do not work in X

There seem to be no noticeable errors in the X logs.

Where do I start ?

I've tried:
* recompiling xorg-server
* recompiling xorg-server then xorg-xf86-input-evdev
* recompiling all of xorg (prt-get quickdep xorg)
* recompiling hal
* ensuring hald is running
* recompiling udev
* ensuring udev is running

cheers
James

--
-- "Problems are solved by method"
_______________________________________________
CRUX mailing list
CRUX@lists.crux.nu
http://lists.crux.nu/mailman/listinfo/crux
 
Old 06-14-2010, 05:39 AM
Volker Beyer
 
Default Xorg keyboard/mouse

Hi James,

did you try this in xorg.conf? :

Section "ServerFlags"
Option "AllowEmptyInput" "false"
EndSection

Cheers
Volker
-----Ursprüngliche Nachricht-----
Von: James Mills <prologic@shortcircuit.net.au>
Gesendet: 14.06.2010 07:04:03
An: crux@lists.crux.nu
Betreff: Xorg keyboard/mouse

>Hi all,
>
>I'm sorry about this, but I'm at a complete loss.
>Everything I've tried gets me nowhere.
>
>Problem: keyboard and mouse do not work in X
>
>There seem to be no noticeable errors in the X logs.
>
>Where do I start ?
>
>I've tried:
> * recompiling xorg-server
> * recompiling xorg-server then xorg-xf86-input-evdev
> * recompiling all of xorg (prt-get quickdep xorg)
> * recompiling hal
> * ensuring hald is running
> * recompiling udev
> * ensuring udev is running
>
>cheers
>James
>
>--
>-- "Problems are solved by method"
>_______________________________________________
>CRUX mailing list
>CRUX@lists.crux.nu
>http://lists.crux.nu/mailman/listinfo/crux
_______________________________________________
CRUX mailing list
CRUX@lists.crux.nu
http://lists.crux.nu/mailman/listinfo/crux
 
Old 06-14-2010, 05:55 AM
James Mills
 
Default Xorg keyboard/mouse

On Mon, Jun 14, 2010 at 3:39 PM, Volker Beyer <vbeyer@web.de> wrote:
> Hi James,
>
> did you try this in xorg.conf? :
>
> Section "ServerFlags"
> *Option "AllowEmptyInput" "false"
> EndSection

tilman actually helped me solve this on IRC just now.
(Thank you). But I'll share what the problem was:

For some reason on my system (maybe because of an older kernel?)
I have /dev/event* devices. the 10-evdev.conf file in
/usr/share/X11/xorg.conf.d/
expects the input devices to be in /dev/input/event* (which they are
not on my system).

I'm tempoarily fixed the problem b y manually editing this file.

I'm also going to upgrade to a later kernel (2.6.30.5)
and try to ensure I've compiled all the right things in.

cheers
James
_______________________________________________
CRUX mailing list
CRUX@lists.crux.nu
http://lists.crux.nu/mailman/listinfo/crux
 

Thread Tools




All times are GMT. The time now is 10:36 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org