FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > CRUX > CRUX

 
 
LinkBack Thread Tools
 
Old 06-13-2010, 12:33 AM
James Mills
 
Default ABI major version issues with latest xorg and nvidia

Hi guys,

Just wondering if anyone's come across this and solved it:

CRUX 2.6 with:

xorg 7.4
xorg-server 1.8.1
nvidia 195.36.24

Tried upgrading to nvidia 195.36.31 but no go.

I keep getting the following in the logs:
"(EE) module ABI major version (2) doesn't match the server's version (3)"

Also my keyboard/mouse inputs do not work despite rebuilding
xorg-server and xorg-xf86-input-evdev
but I'm trying to solve the above problem/error first.

Thanks,

cheers
James

--
-- "Problems are solved by method"
_______________________________________________
CRUX mailing list
CRUX@lists.crux.nu
http://lists.crux.nu/mailman/listinfo/crux
 
Old 06-13-2010, 09:46 AM
Moritz Wilhelmy
 
Default ABI major version issues with latest xorg and nvidia

Hi,

> xorg 7.4
> xorg-server 1.8.1
> nvidia 195.36.24
>
> Tried upgrading to nvidia 195.36.31 but no go.
>
> I keep getting the following in the logs:
> "(EE) module ABI major version (2) doesn't match the server's version (3)"

I'm still on nvidia legacy and I seriously doubt they will ever continue it's
development. I downgraded xorg-server to 1.7.6 and it works fine so far. For
the future, there will be nouveau [1], which I'm probably going to package, but
I didn't even try to build it yet.

> Also my keyboard/mouse inputs do not work despite rebuilding
> xorg-server and xorg-xf86-input-evdev
> but I'm trying to solve the above problem/error first.

good luck.

Kind regards,

Moritz

[1] http://nouveau.freedesktop.org/
_______________________________________________
CRUX mailing list
CRUX@lists.crux.nu
http://lists.crux.nu/mailman/listinfo/crux
 
Old 06-13-2010, 06:56 PM
Moritz Wilhelmy
 
Default ABI major version issues with latest xorg and nvidia

> * Moritz Wilhelmy (moritz+crux@wzff.de) wrote:
> > I'm still on nvidia legacy and I seriously doubt they will ever continue >
> > it's development. I downgraded xorg-server to 1.7.6 and it works fine so
> > far.> For the future, there will be nouveau [1], which I'm probably going
> > to packag> e, but I didn't even try to build it yet.
>
> The packaging process for nouveau (the X.org module) should be straight
> forward (even though the build process stops with failure *after* creating
> the import .so driver-file). Correct versions for libdrm and mesa3d are a
> greater "issue" here, I think.
>
> regards, Thomas (still running with 2.6.34-rc5 and nouveau)

I'm still on 2.6.30 since I didn't bother upgrading my kernel source (and
recompile) to anything newer, and I'm not sure it will work on it. I'll wait
for 2.7.

By the way, we should add a reply-to to this mailing list, so replying to mails
does not result in replying to the people who sent them, since that's very
annoying and information loss is possible this way. I included the whole E-Mail
from Thomas for this reason.

Kind regards,

Moritz
_______________________________________________
CRUX mailing list
CRUX@lists.crux.nu
http://lists.crux.nu/mailman/listinfo/crux
 

Thread Tools




All times are GMT. The time now is 12:19 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org