Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   CentOS (http://www.linux-archive.org/centos/)
-   -   CentOS 6.3 on ASUS G73S does not work external video (http://www.linux-archive.org/centos/689763-centos-6-3-asus-g73s-does-not-work-external-video.html)

John R Pierce 08-02-2012 04:33 AM

CentOS 6.3 on ASUS G73S does not work external video
 
On 08/01/12 9:21 PM, Rob Kampen wrote:
> just wondering which driver I need to be looking at / for that deals
> with the laptop's external video connector.

the video hardware driver

>
> Background - went to deliver a presentation last week and found that
> there was no way to get any video output to the external D-15
> connector (hooked up to a video projector).
> Eventually I re-booted to windoze 7 and all worked just fine - major
> embarrassment after telling everyone how great Linux was.
>
> The laptop has a nvidia GTX 460M card and I use the el-repo
> kmod-nvidia-295.59-1.el6.elrepo.x86_64
> and
> nvidia-x11-drv-295.59-1.el6.elrepo.x86_64
>
> I do have compiz-0.8.2-24.el6.x86_64 and
> compiz-gnome-0.8.2-24.el6.x86_64 running but as these should not be
> dealing directly with the hardware am not thinking they should matter.
>
> Not sure where to start trouble shooting - I tried lots of different
> screen resolutions via the System > Preferences > Display but no joy
> getting any signal out to the external connector. This laptop does
> have an hdmi socket but I was not using that, I thought the good old
> fashioned D-15 video plug should "just work" (tm).
>
> The function key <Fn> <F8> did toggle the laptop screen off and on and
> varied the resolution of the laptop display but never any output on
> the external connector.

those laptop graphics chips treat the VGA connector like a 2nd monitor,
I have no idea how you configure linux for multimonitor, but I know its
not nearly as easy as MS Windows where it just works.



--
john r pierce N 37, W 122
santa cruz ca mid-left coast

_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos

Johnny Hughes 08-02-2012 05:10 AM

CentOS 6.3 on ASUS G73S does not work external video
 
On 08/01/2012 11:33 PM, John R Pierce wrote:
> On 08/01/12 9:21 PM, Rob Kampen wrote:
>> just wondering which driver I need to be looking at / for that deals
>> with the laptop's external video connector.
> the video hardware driver
>
>> Background - went to deliver a presentation last week and found that
>> there was no way to get any video output to the external D-15
>> connector (hooked up to a video projector).
>> Eventually I re-booted to windoze 7 and all worked just fine - major
>> embarrassment after telling everyone how great Linux was.
>>
>> The laptop has a nvidia GTX 460M card and I use the el-repo
>> kmod-nvidia-295.59-1.el6.elrepo.x86_64
>> and
>> nvidia-x11-drv-295.59-1.el6.elrepo.x86_64
>>
>> I do have compiz-0.8.2-24.el6.x86_64 and
>> compiz-gnome-0.8.2-24.el6.x86_64 running but as these should not be
>> dealing directly with the hardware am not thinking they should matter.
>>
>> Not sure where to start trouble shooting - I tried lots of different
>> screen resolutions via the System > Preferences > Display but no joy
>> getting any signal out to the external connector. This laptop does
>> have an hdmi socket but I was not using that, I thought the good old
>> fashioned D-15 video plug should "just work" (tm).
>>
>> The function key <Fn> <F8> did toggle the laptop screen off and on and
>> varied the resolution of the laptop display but never any output on
>> the external connector.
> those laptop graphics chips treat the VGA connector like a 2nd monitor,
> I have no idea how you configure linux for multimonitor, but I know its
> not nearly as easy as MS Windows where it just works.
>
>

Indeed that connector is treated as an "all the time on" 2nd monitor

If it is an nvidia card, you can use use the NVIDIA X Server Settings
link in "Menu => System => Administration" (if you install the drivers
from elrepo, which I recommend)

If it is another card that uses system drivers, you can use the "Menu =>
System => Display"

I just create 2 xorg.conf files and copy the one I need into place when
I hook up to my docking station on my Dell M4500.



_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos

Rob Kampen 08-02-2012 07:13 AM

CentOS 6.3 on ASUS G73S does not work external video
 
On 08/02/2012 05:10 PM, Johnny Hughes wrote:

On 08/01/2012 11:33 PM, John R Pierce wrote:

On 08/01/12 9:21 PM, Rob Kampen wrote:

just wondering which driver I need to be looking at / for that deals
with the laptop's external video connector.

the video hardware driver


Background - went to deliver a presentation last week and found that
there was no way to get any video output to the external D-15
connector (hooked up to a video projector).
Eventually I re-booted to windoze 7 and all worked just fine - major
embarrassment after telling everyone how great Linux was.

The laptop has a nvidia GTX 460M card and I use the el-repo
kmod-nvidia-295.59-1.el6.elrepo.x86_64
and
nvidia-x11-drv-295.59-1.el6.elrepo.x86_64

I do have compiz-0.8.2-24.el6.x86_64 and
compiz-gnome-0.8.2-24.el6.x86_64 running but as these should not be
dealing directly with the hardware am not thinking they should matter.

Not sure where to start trouble shooting - I tried lots of different
screen resolutions via the System> Preferences> Display but no joy
getting any signal out to the external connector. This laptop does
have an hdmi socket but I was not using that, I thought the good old
fashioned D-15 video plug should "just work" (tm).

The function key<Fn> <F8> did toggle the laptop screen off and on and
varied the resolution of the laptop display but never any output on
the external connector.

those laptop graphics chips treat the VGA connector like a 2nd monitor,
I have no idea how you configure linux for multimonitor, but I know its
not nearly as easy as MS Windows where it just works.



Indeed that connector is treated as an "all the time on" 2nd monitor

If it is an nvidia card, you can use use the NVIDIA X Server Settings
link in "Menu => System => Administration" (if you install the drivers
from elrepo, which I recommend)

If it is another card that uses system drivers, you can use the "Menu =>
System => Display"

I just create 2 xorg.conf files and copy the one I need into place when
I hook up to my docking station on my Dell M4500.


Okay - I think I understand and the idea of two xorg.conf files seems
like a great idea.
Will give this a try as soon as I locate another external video monitor
with a VGA connector.

Thanks




_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos


_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos


All times are GMT. The time now is 03:56 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.