FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > CentOS > CentOS

 
 
LinkBack Thread Tools
 
Old 07-23-2012, 09:48 PM
Boris Epstein
 
Default missing V4L or related dependencies

Hello all,

I am trying to install Epiphan's ( http://www.epiphan.com/ ) VGA2USB device
on a Centos 6 machine and when I am trying to compile and install the
driver for it I get the following errors:

WARNING: /lib/modules/2.6.32-279.2.1.el6.x86_64/extra/vga2usb.ko needs
unknown symbol videobuf_streamoff
WARNING: /lib/modules/2.6.32-279.2.1.el6.x86_64/extra/vga2usb.ko needs
unknown symbol videobuf_poll_stream
WARNING: /lib/modules/2.6.32-279.2.1.el6.x86_64/extra/vga2usb.ko needs
unknown symbol video_ioctl2
WARNING: /lib/modules/2.6.32-279.2.1.el6.x86_64/extra/vga2usb.ko needs
unknown symbol videobuf_reqbufs
WARNING: /lib/modules/2.6.32-279.2.1.el6.x86_64/extra/vga2usb.ko needs
unknown symbol videobuf_dqbuf
WARNING: /lib/modules/2.6.32-279.2.1.el6.x86_64/extra/vga2usb.ko needs
unknown symbol videobuf_to_vmalloc
WARNING: /lib/modules/2.6.32-279.2.1.el6.x86_64/extra/vga2usb.ko needs
unknown symbol videobuf_vmalloc_free
WARNING: /lib/modules/2.6.32-279.2.1.el6.x86_64/extra/vga2usb.ko needs
unknown symbol video_devdata
WARNING: /lib/modules/2.6.32-279.2.1.el6.x86_64/extra/vga2usb.ko needs
unknown symbol videobuf_stop
WARNING: /lib/modules/2.6.32-279.2.1.el6.x86_64/extra/vga2usb.ko needs
unknown symbol videobuf_read_stream
WARNING: /lib/modules/2.6.32-279.2.1.el6.x86_64/extra/vga2usb.ko needs
unknown symbol videobuf_querybuf
WARNING: /lib/modules/2.6.32-279.2.1.el6.x86_64/extra/vga2usb.ko needs
unknown symbol video_unregister_device
WARNING: /lib/modules/2.6.32-279.2.1.el6.x86_64/extra/vga2usb.ko needs
unknown symbol videobuf_qbuf
WARNING: /lib/modules/2.6.32-279.2.1.el6.x86_64/extra/vga2usb.ko needs
unknown symbol video_register_device
WARNING: /lib/modules/2.6.32-279.2.1.el6.x86_64/extra/vga2usb.ko needs
unknown symbol videobuf_iolock
WARNING: /lib/modules/2.6.32-279.2.1.el6.x86_64/extra/vga2usb.ko needs
unknown symbol videobuf_streamon
WARNING: /lib/modules/2.6.32-279.2.1.el6.x86_64/extra/vga2usb.ko needs
unknown symbol videobuf_queue_vmalloc_init
WARNING: /lib/modules/2.6.32-279.2.1.el6.x86_64/extra/vga2usb.ko needs
unknown symbol videobuf_mmap_mapper
WARNING: /lib/modules/2.6.32-279.2.1.el6.x86_64/extra/vga2usb.ko needs
unknown symbol videobuf_mmap_free

Does anybody happen to know which library I need to install to get these
functions?

Thanks.

Boris.
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 07-24-2012, 05:44 PM
Boris Epstein
 
Default missing V4L or related dependencies

Hello again,

Looks like the functions I need - at least some of them - are defined in

videobuf-vmalloc.h

I still have no idea where to find them - i.e., what to include/install to
make them resolve.

Boris.

On Mon, Jul 23, 2012 at 5:48 PM, Boris Epstein <borepstein@gmail.com> wrote:

> Hello all,
>
> I am trying to install Epiphan's ( http://www.epiphan.com/ ) VGA2USB
> device on a Centos 6 machine and when I am trying to compile and install
> the driver for it I get the following errors:
>
> WARNING: /lib/modules/2.6.32-279.2.1.el6.x86_64/extra/vga2usb.ko needs
> unknown symbol videobuf_streamoff
> WARNING: /lib/modules/2.6.32-279.2.1.el6.x86_64/extra/vga2usb.ko needs
> unknown symbol videobuf_poll_stream
> WARNING: /lib/modules/2.6.32-279.2.1.el6.x86_64/extra/vga2usb.ko needs
> unknown symbol video_ioctl2
> WARNING: /lib/modules/2.6.32-279.2.1.el6.x86_64/extra/vga2usb.ko needs
> unknown symbol videobuf_reqbufs
> WARNING: /lib/modules/2.6.32-279.2.1.el6.x86_64/extra/vga2usb.ko needs
> unknown symbol videobuf_dqbuf
> WARNING: /lib/modules/2.6.32-279.2.1.el6.x86_64/extra/vga2usb.ko needs
> unknown symbol videobuf_to_vmalloc
> WARNING: /lib/modules/2.6.32-279.2.1.el6.x86_64/extra/vga2usb.ko needs
> unknown symbol videobuf_vmalloc_free
> WARNING: /lib/modules/2.6.32-279.2.1.el6.x86_64/extra/vga2usb.ko needs
> unknown symbol video_devdata
> WARNING: /lib/modules/2.6.32-279.2.1.el6.x86_64/extra/vga2usb.ko needs
> unknown symbol videobuf_stop
> WARNING: /lib/modules/2.6.32-279.2.1.el6.x86_64/extra/vga2usb.ko needs
> unknown symbol videobuf_read_stream
> WARNING: /lib/modules/2.6.32-279.2.1.el6.x86_64/extra/vga2usb.ko needs
> unknown symbol videobuf_querybuf
> WARNING: /lib/modules/2.6.32-279.2.1.el6.x86_64/extra/vga2usb.ko needs
> unknown symbol video_unregister_device
> WARNING: /lib/modules/2.6.32-279.2.1.el6.x86_64/extra/vga2usb.ko needs
> unknown symbol videobuf_qbuf
> WARNING: /lib/modules/2.6.32-279.2.1.el6.x86_64/extra/vga2usb.ko needs
> unknown symbol video_register_device
> WARNING: /lib/modules/2.6.32-279.2.1.el6.x86_64/extra/vga2usb.ko needs
> unknown symbol videobuf_iolock
> WARNING: /lib/modules/2.6.32-279.2.1.el6.x86_64/extra/vga2usb.ko needs
> unknown symbol videobuf_streamon
> WARNING: /lib/modules/2.6.32-279.2.1.el6.x86_64/extra/vga2usb.ko needs
> unknown symbol videobuf_queue_vmalloc_init
> WARNING: /lib/modules/2.6.32-279.2.1.el6.x86_64/extra/vga2usb.ko needs
> unknown symbol videobuf_mmap_mapper
> WARNING: /lib/modules/2.6.32-279.2.1.el6.x86_64/extra/vga2usb.ko needs
> unknown symbol videobuf_mmap_free
>
> Does anybody happen to know which library I need to install to get these
> functions?
>
> Thanks.
>
> Boris.
>
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 07-24-2012, 06:41 PM
 
Default missing V4L or related dependencies

Boris Epstein wrote:
> Hello again,
>
> Looks like the functions I need - at least some of them - are defined in
>
> videobuf-vmalloc.h
>
> I still have no idea where to find them - i.e., what to include/install to
> make them resolve.

Ah, a locate found it. It's in kernel-devel.

mark

_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 07-24-2012, 06:45 PM
Boris Epstein
 
Default missing V4L or related dependencies

On Tue, Jul 24, 2012 at 2:41 PM, <m.roth@5-cent.us> wrote:

> Boris Epstein wrote:
> > Hello again,
> >
> > Looks like the functions I need - at least some of them - are defined in
> >
> > videobuf-vmalloc.h
> >
> > I still have no idea where to find them - i.e., what to include/install
> to
> > make them resolve.
>
> Ah, a locate found it. It's in kernel-devel.
>
> mark
>
>
>
OK... thanks Mark!

Then how come I fail to link to it?

Boris.
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 07-24-2012, 06:48 PM
 
Default missing V4L or related dependencies

Boris Epstein wrote:
> On Tue, Jul 24, 2012 at 2:41 PM, <m.roth@5-cent.us> wrote:
>> Boris Epstein wrote:
>> > Hello again,
>> >
>> > Looks like the functions I need - at least some of them - are defined
>> > in videobuf-vmalloc.h
>> >
>> > I still have no idea where to find them - i.e., what to
>> > include/install to make them resolve.
>>
>> Ah, a locate found it. It's in kernel-devel.
>>
> OK... thanks Mark!
>
> Then how come I fail to link to it?

Wait - this is in something already compiled, or are you building it? If
the former, then for some reason, it may not be in your link path, or you
might need to add it to LD_LIBRARY_PATH. If the former, I dunno why it
wouldn't have the path right. You're not building a 32-bit on a 64 bit, or
vice versa, are you?

mark

_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 07-24-2012, 07:27 PM
Boris Epstein
 
Default missing V4L or related dependencies

On Tue, Jul 24, 2012 at 2:48 PM, <m.roth@5-cent.us> wrote:

> Boris Epstein wrote:
> > On Tue, Jul 24, 2012 at 2:41 PM, <m.roth@5-cent.us> wrote:
> >> Boris Epstein wrote:
> >> > Hello again,
> >> >
> >> > Looks like the functions I need - at least some of them - are defined
> >> > in videobuf-vmalloc.h
> >> >
> >> > I still have no idea where to find them - i.e., what to
> >> > include/install to make them resolve.
> >>
> >> Ah, a locate found it. It's in kernel-devel.
> >>
> > OK... thanks Mark!
> >
> > Then how come I fail to link to it?
>
> Wait - this is in something already compiled, or are you building it? If
> the former, then for some reason, it may not be in your link path, or you
> might need to add it to LD_LIBRARY_PATH. If the former, I dunno why it
> wouldn't have the path right. You're not building a 32-bit on a 64 bit, or
> vice versa, are you?
>
> mark
>
> _______________________________________________
> CentOS mailing list
> CentOS@centos.org
> http://lists.centos.org/mailman/listinfo/centos
>

Mark,

I was trying to compile the software on a 64-bit machine. kernel-devel was
installed. After I ran a

yum update

and rebooted the system the compilation worked like a charm.

This must have been some ldconfig issue or some such.

Thanks for your help.

Boris.
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 07-24-2012, 07:56 PM
 
Default missing V4L or related dependencies

Boris Epstein wrote:
> On Tue, Jul 24, 2012 at 2:48 PM, <m.roth@5-cent.us> wrote:
>> Boris Epstein wrote:
>> > On Tue, Jul 24, 2012 at 2:41 PM, <m.roth@5-cent.us> wrote:
>> >> Boris Epstein wrote:
>> >> >
>> >> > Looks like the functions I need - at least some of them - are
>> >> > defined in videobuf-vmalloc.h
>> >> >
>> >> > I still have no idea where to find them - i.e., what to
>> >> > include/install to make them resolve.
>> >>
>> >> Ah, a locate found it. It's in kernel-devel.
>> >>
>> > OK... thanks Mark!
>> >
>> > Then how come I fail to link to it?
>>
>> Wait - this is in something already compiled, or are you building it? If
>> the former, then for some reason, it may not be in your link path, or
>> you might need to add it to LD_LIBRARY_PATH. If the former, I dunno why it
>> wouldn't have the path right. You're not building a 32-bit on a 64 bit,
>> or vice versa, are you?
>
> I was trying to compile the software on a 64-bit machine. kernel-devel was
> installed. After I ran a
>
> yum update
>
> and rebooted the system the compilation worked like a charm.
>
> This must have been some ldconfig issue or some such.

Sounds like it, though reference to a .h means the include path in the
makefile wasn't set correctly, or rather was missing the correct setting.
Perhaps something in the environment, or your environment (did you ever
log out and log back in, before rebooting?) wasn't right.
>
> Thanks for your help.

Glad it works!

mark

_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 

Thread Tools




All times are GMT. The time now is 05:08 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org