FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > CentOS > CentOS

 
 
LinkBack Thread Tools
 
Old 05-17-2012, 03:09 PM
Bowie Bailey
 
Default Problem building latest Courier-authlib on CentOS4

Upgrading to CentOS6 is on my list, but I'm trying to get the latest Courier-MTA running at the moment.

I downloaded the current courier tarballs and tried to build the rpms on a CentOS4 system. I got these errors:

$ rpmbuild -tb courier-authlib-0.64.0.tar.bz2
...
libtool: link: ar cru .libs/libauthpipe.a authpipe.o authpipelib.o
libtool: link: ranlib .libs/libauthpipe.a
libtool: link: ( cd ".libs" && rm -f "libauthpipe.la" && ln -s
"../libauthpipe.la" "libauthpipe.la" )
libtool: link: gcc -I/usr/include/mysql -g -pipe -m32 -march=i386
-mtune=pentium4 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
-fno-strict-aliasing -I/usr/include -O2 -g -pipe -m32 -march=i386
-mtune=pentium4 -Wall -I.. -I./.. -o authdaemontest authdaemontest.o
./.libs/libcourierauthcommon.a
/home/bowieb/rpm/BUILD/courier-authlib-0.64.0/.libs/libcourierauth.a -ldl
libtool: link: cannot find the library `libltdl/libltdlc.la' or
unhandled argument `libltdl/libltdlc.la'
make[2]: *** [authdaemondprog] Error 1
make[2]: *** Waiting for unfinished jobs....
libtool: link: gcc -I/usr/include/mysql -g -pipe -m32 -march=i386
-mtune=pentium4 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
-fno-strict-aliasing -I/usr/include -O2 -g -pipe -m32 -march=i386
-mtune=pentium4 -Wall -I.. -I./.. -o .libs/authpasswd authpasswd.o
./.libs/libcourierauthcommon.so
/home/bowieb/rpm/BUILD/courier-authlib-0.64.0/.libs/libcourierauth.so
libhmac/.libs/libhmac.a md5/.libs/libmd5.a sha1/.libs/libsha1.a
rfc822/.libs/libencode.a -ldl -Wl,-rpath -Wl,/usr/lib/courier-authlib
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.93944 (%build)


RPM build errors:
Bad exit status from /var/tmp/rpm-tmp.93944 (%build)

I asked on the Courier list and Sam said that my libtool is too old. He suggested adding an "autoreconf" line to the spec file, but that just generated an error that my Autoconf is too old.

Can someone give me a pointer as to how to fix this?

Thanks

--
Bowie

_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 

Thread Tools




All times are GMT. The time now is 01:37 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org