FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > CentOS > CentOS

 
 
LinkBack Thread Tools
 
Old 04-10-2012, 12:53 PM
John Doe
 
Default yum priorities and obsoleting...

Hey,

I ran into a yum conflict regarding an repoforge extra package obsoleting a base package.
The thing is that I set a lower priority to repoforge extra...
Any idea how come I ran into this issue...?

The question is more about the yum priorities than repoforge.


...

1743 packages excluded due to repository priority protections

...
--> Running transaction check
---> Package perl-rrdtool.x86_64 0:1.4.5-1.el6.rfx will be obsoleting
--> Processing Dependency: rrdtool = 1.4.5 for package: perl-rrdtool-1.4.5-1.el6.rfx.x86_64
---> Package rrdtool-perl.x86_64 0:1.3.8-6.el6 will be obsoleted
--> Finished Dependency Resolution
Error: Package: perl-rrdtool-1.4.5-1.el6.rfx.x86_64 (rpmforge-extras)
********** Requires: rrdtool = 1.4.5
********** Installed: rrdtool-1.3.8-6.el6.x86_64 (@base)
************** rrdtool = 1.3.8-6.el6

lua-rrdtool.x86_64*********************** 1.4.7-1.el6.rfx************** rpmforge-extras
perl-rrdtool.x86_64********************** 1.4.5-1.el6.rfx************** rpmforge-extras
python-rrdtool.x86_64******************** 1.4.5-1.el6.rfx************** rpmforge-extras
rrdtool-devel.i686*********************** 1.3.8-6.el6****************** base***
rrdtool-devel.x86_64********************* 1.3.8-6.el6****************** base***
rrdtool-doc.x86_64*********************** 1.3.8-6.el6****************** base***
rrdtool.i686***************************** 1.3.8-6.el6****************** base***
rrdtool-perl.x86_64********************** 1.3.8-6.el6****************** @base***
rrdtool-php.x86_64*********************** 1.3.8-6.el6****************** base***
rrdtool-python.x86_64******************** 1.3.8-6.el6****************** base***
rrdtool-ruby.x86_64********************** 1.3.8-6.el6****************** base***
rrdtool-tcl.x86_64*********************** 1.3.8-6.el6****************** base***
rrdtool.x86_64*************************** 1.3.8-6.el6****************** @base**
ruby-rrdtool.x86_64********************** 1.4.5-1.el6.rfx************** rpmforge-extras
tcl-rrdtool.x86_64*********************** 1.4.5-1.el6.rfx************** rpmforge-extras


Thx,
JD

_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 04-10-2012, 01:20 PM
Markus Falb
 
Default yum priorities and obsoleting...

On 10.4.2012 14:53, John Doe wrote:
> The question is more about the yum priorities than repoforge.
...
> Error: Package: perl-rrdtool-1.4.5-1.el6.rfx.x86_64 (rpmforge-extras)
> Requires: rrdtool = 1.4.5
> Installed: rrdtool-1.3.8-6.el6.x86_64 (@base)
> rrdtool = 1.3.8-6.el6

yum priorities can not overrule hard coded dependencies.
yum priorities can decide what to prefer if there were multiple choices.

You tried to install a package that explicitly stated
Requires: rrdtool = 1.4.5

If the only rrdtool 1.4.5 is in rpmforge, yum priorities cant help you.

Maybe you could try to update rrdtool first.
$ yum update rrdtool
$ yum install whatever
However, existing rrdtool functionality may break.
--
Kind Regards, Markus Falb

_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 04-10-2012, 02:32 PM
John Doe
 
Default yum priorities and obsoleting...

From: Markus Falb <markus.falb@fasel.at>

> yum priorities can not overrule hard coded dependencies.
> yum priorities can decide what to prefer if there were multiple choices.
> You tried to install a package that explicitly stated
> Requires: rrdtool = 1.4.5
> If the only rrdtool 1.4.5 is in rpmforge, yum priorities cant help you.

Ahh, now it makes sense...
Priorities did protect my rrdtool, but it won't "recursively" exclude perl-rrdtool from being updated.
I just removed perl-rrdtool since it was apparently not used anymore...

Thx,
JD
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 

Thread Tools




All times are GMT. The time now is 02:15 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org