FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > CentOS > CentOS

 
 
LinkBack Thread Tools
 
Old 04-09-2012, 11:08 PM
Veli-Pekka Kestilš
 
Default Problem with NFS4 and CentOs 5.8

Hi,

I hope someone could give me help with following problem on centos 5.8
kernel and nfs4.

On server i have bind mounted directory shared to the client with
following setup:
mounted directory:
/srv/nfs/imagetest on /exports/imagetest type none (rw,bind)

/etc/exports file:
/exports
10.0.4.0/24(ro,insecure,sync,wdelay,no_subtree_check,no_roo t_squash,fsid=0,crossmnt)
/exports/imagetest
10.0.4.20(rw,insecure,sync,wdelay,no_subtree_check ,nohide,no_root_squash)

On client I have mounted it with following command:
10.0.4.2:/ on /media/nfs type nfs4
(rw,nodev,sync,proto=tcp,retry=10,rsize=32768,wsiz e=32768,hard,intr,addr=10.0.4.2)

This works fine with kernel: 2.6.18-274.17.1.el5.centos.plusxen

But with 2.6.18-308.1.1.el5.centos.plusxen I get the following error:
-bash: cd: imagetest/: Not a directory when accessing the share.

If I disable nohide-option I can access the directory, but with the
contents of the original /exports/imagetest without the mounting.

Greetings,
-vpk



_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 04-10-2012, 12:11 AM
Rob Kampen
 
Default Problem with NFS4 and CentOs 5.8

On 04/10/2012 11:08 AM, Veli-Pekka Kestilš wrote:
> Hi,
>
> I hope someone could give me help with following problem on centos 5.8
> kernel and nfs4.
>
> On server i have bind mounted directory shared to the client with
> following setup:
> mounted directory:
> /srv/nfs/imagetest on /exports/imagetest type none (rw,bind)
>
> /etc/exports file:
> /exports
> 10.0.4.0/24(ro,insecure,sync,wdelay,no_subtree_check,no_roo t_squash,fsid=0,crossmnt)
> /exports/imagetest
> 10.0.4.20(rw,insecure,sync,wdelay,no_subtree_check ,nohide,no_root_squash)
>
> On client I have mounted it with following command:
> 10.0.4.2:/ on /media/nfs type nfs4
> (rw,nodev,sync,proto=tcp,retry=10,rsize=32768,wsiz e=32768,hard,intr,addr=10.0.4.2)
It appears that this client IP is one of the ro list of IPs - thus
trying to mount rw will be a problem??
> This works fine with kernel: 2.6.18-274.17.1.el5.centos.plusxen
>
> But with 2.6.18-308.1.1.el5.centos.plusxen I get the following error:
> -bash: cd: imagetest/: Not a directory when accessing the share.
>
> If I disable nohide-option I can access the directory, but with the
> contents of the original /exports/imagetest without the mounting.
>
> Greetings,
> -vpk
>
>
>
> _______________________________________________
> CentOS mailing list
> CentOS@centos.org
> http://lists.centos.org/mailman/listinfo/centos

_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 04-10-2012, 10:42 AM
Veli-Pekka Kestilš
 
Default Problem with NFS4 and CentOs 5.8

On 10.4.2012 3:11, Rob Kampen wrote:
> On 04/10/2012 11:08 AM, Veli-Pekka Kestilš wrote:
>> I hope someone could give me help with following problem on centos 5.8
>> kernel and nfs4.
>>
>> On server i have bind mounted directory shared to the client with
>> following setup:
>> mounted directory:
>> /srv/nfs/imagetest on /exports/imagetest type none (rw,bind)
>>
>> /etc/exports file:
>> /exports
>> 10.0.4.0/24(ro,insecure,sync,wdelay,no_subtree_check,no_roo t_squash,fsid=0,crossmnt)
>> /exports/imagetest
>> 10.0.4.20(rw,insecure,sync,wdelay,no_subtree_check ,nohide,no_root_squash)
>>
>> On client I have mounted it with following command:
>> 10.0.4.2:/ on /media/nfs type nfs4
>> (rw,nodev,sync,proto=tcp,retry=10,rsize=32768,wsiz e=32768,hard,intr,addr=10.0.4.2)
> It appears that this client IP is one of the ro list of IPs - thus
> trying to mount rw will be a problem??
It actually isn't a problem, that later rw export overrides the ro
definition. And the problem still persists even I move the /exports to
be rw.
>> This works fine with kernel: 2.6.18-274.17.1.el5.centos.plusxen
>>
>> But with 2.6.18-308.1.1.el5.centos.plusxen I get the following error:
>> -bash: cd: imagetest/: Not a directory when accessing the share.
>>
>> If I disable nohide-option I can access the directory, but with the
>> contents of the original /exports/imagetest without the mounting.
-vpk
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 

Thread Tools




All times are GMT. The time now is 08:05 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org