FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > CentOS > CentOS

 
 
LinkBack Thread Tools
 
Old 11-15-2011, 07:46 PM
Alan McKay
 
Default pgadmin3 missing dependencies

I searched the list archives and I found one answer to this which
suggested I should install the PG yum repos. I don't like that
answer for reasons which follow.

I'm running Centos 6.0 freshly installed, and I've decided that with
this box I'm sticking as much as possible to just the CentOS repos
that go with that release. I figure in particular I do not need any
PG features above what are offered in release 8.4 that comes from the
CentOS repos, so I don't really want to install PG repos.

But first of all I do not even see pgadmin3 in the CentOS repos
anywhere. Am I correct that in order to get this tool I need to get
it from the PG repo? It seems odd to me that CentOS would not have it
but stranger things have happened.

So I pull down the pgadmin3 RPM manually, and try to do a manual
install only to find that a number of RPMs are missing and required.
I guess at this point I could just install the repo for PG to yum it
all, but I'd like to know what RPMs are required and I am unable to
figure that out. I figured out at least that I need libxslt, but
cannot figure out from the below output what other RPMs are needed
and where I get them. libxslt I got from 6.0 yum repos.

[root@cc-bc4d99dffae2 ~]# rpm --install pgadmin3-1.12.2-1.rhel6.i686.rpm
warning: pgadmin3-1.12.2-1.rhel6.i686.rpm: Header V4 DSA/SHA1
Signature, key ID 442df0f8: NOKEY
error: Failed dependencies:
libwx_baseu-2.8.so.0 is needed by pgadmin3-1.12.2-1.rhel6.i686
libwx_baseu-2.8.so.0(WXU_2.8) is needed by pgadmin3-1.12.2-1.rhel6.i686
libwx_baseu-2.8.so.0(WXU_2.8.5) is needed by pgadmin3-1.12.2-1.rhel6.i686
libwx_baseu_net-2.8.so.0 is needed by pgadmin3-1.12.2-1.rhel6.i686
libwx_baseu_net-2.8.so.0(WXU_2.8) is needed by pgadmin3-1.12.2-1.rhel6.i686
libwx_baseu_xml-2.8.so.0 is needed by pgadmin3-1.12.2-1.rhel6.i686
libwx_baseu_xml-2.8.so.0(WXU_2.8) is needed by pgadmin3-1.12.2-1.rhel6.i686
libwx_gtk2u_adv-2.8.so.0 is needed by pgadmin3-1.12.2-1.rhel6.i686
libwx_gtk2u_adv-2.8.so.0(WXU_2.8) is needed by pgadmin3-1.12.2-1.rhel6.i686
libwx_gtk2u_aui-2.8.so.0 is needed by pgadmin3-1.12.2-1.rhel6.i686
libwx_gtk2u_aui-2.8.so.0(WXU_2.8) is needed by pgadmin3-1.12.2-1.rhel6.i686
libwx_gtk2u_core-2.8.so.0 is needed by pgadmin3-1.12.2-1.rhel6.i686
libwx_gtk2u_core-2.8.so.0(WXU_2.8) is needed by pgadmin3-1.12.2-1.rhel6.i686
libwx_gtk2u_html-2.8.so.0 is needed by pgadmin3-1.12.2-1.rhel6.i686
libwx_gtk2u_html-2.8.so.0(WXU_2.8) is needed by pgadmin3-1.12.2-1.rhel6.i686
libwx_gtk2u_ogl-2.8.so.0 is needed by pgadmin3-1.12.2-1.rhel6.i686
libwx_gtk2u_ogl-2.8.so.0(WXU_2.8) is needed by pgadmin3-1.12.2-1.rhel6.i686
libwx_gtk2u_qa-2.8.so.0 is needed by pgadmin3-1.12.2-1.rhel6.i686
libwx_gtk2u_richtext-2.8.so.0 is needed by pgadmin3-1.12.2-1.rhel6.i686
libwx_gtk2u_stc-2.8.so.0 is needed by pgadmin3-1.12.2-1.rhel6.i686
libwx_gtk2u_stc-2.8.so.0(WXU_2.8) is needed by pgadmin3-1.12.2-1.rhel6.i686
libwx_gtk2u_xrc-2.8.so.0 is needed by pgadmin3-1.12.2-1.rhel6.i686
libwx_gtk2u_xrc-2.8.so.0(WXU_2.8) is needed by pgadmin3-1.12.2-1.rhel6.i686
wxGTK is needed by pgadmin3-1.12.2-1.rhel6.i686
[root@cc-bc4d99dffae2 ~]#


--
“Don't eat anything you've ever seen advertised on TV”
* * * ** - Michael Pollan, author of "In Defense of Food"
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 11-15-2011, 07:54 PM
John R Pierce
 
Default pgadmin3 missing dependencies

On 11/15/11 12:46 PM, Alan McKay wrote:
> [root@cc-bc4d99dffae2 ~]# rpm --install pgadmin3-1.12.2-1.rhel6.i686.rpm
> warning: pgadmin3-1.12.2-1.rhel6.i686.rpm: Header V4 DSA/SHA1
> Signature, key ID 442df0f8: NOKEY
> error: Failed dependencies:
> libwx_baseu-2.8.so.0 is needed by pgadmin3-1.12.2-1.rhel6.i686


try...

# yum localinstall pgadmin3-1.12.2-1.rhel6.i686.rpm

I haven' tried this, but it should work. It will tell you what other
RPMs its going to install and ask if its OK before it does so.




--
john r pierce N 37, W 122
santa cruz ca mid-left coast

_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 11-15-2011, 08:01 PM
Dale Dellutri
 
Default pgadmin3 missing dependencies

On Tue, Nov 15, 2011 at 2:46 PM, Alan McKay <alan.mckay@gmail.com> wrote:
> I searched the list archives and I found one answer to this which
> suggested I should install the PG yum repos. * I don't like that
> answer for reasons which follow.
>
> I'm running Centos 6.0 freshly installed, and I've decided that with
> this box I'm sticking as much as possible to just the CentOS repos
> that go with that release. *I figure in particular I do not need any
> PG features above what are offered in release 8.4 that comes from the
> CentOS repos, so I don't really want to install PG repos.
>
> But first of all I do not even see pgadmin3 in the CentOS repos
> anywhere. * Am I correct that in order to get this tool I need to get
> it from the PG repo? *It seems odd to me that CentOS would not have it
> but stranger things have happened.
>
> So I pull down the pgadmin3 RPM manually, and try to do a manual
> install only to find that a number of RPMs are missing and required.
> I guess at this point I could just install the repo for PG to yum it
> all, but I'd like to know what RPMs are required and I am unable to
> figure that out. *I figured out at least that I need libxslt, but
> cannot figure out from the below output what other RPMs are needed
> and where I get them. *libxslt I got from 6.0 yum repos.
>
> [root@cc-bc4d99dffae2 ~]# rpm --install pgadmin3-1.12.2-1.rhel6.i686.rpm

Instead of rpm, use
yum install pgadmin3-1.12.2-1.rhel6.i686.rpm
assuming the rpm is in the present working directory.
Yum will note the dependencies and download them if they
are available in your currently enabled repos. If not, you'll
have to install and enable other repos.

You might need:
yum --nogpgcheck install pgadmin3-1.12.2-1.rhel6.i686.rpm

> warning: pgadmin3-1.12.2-1.rhel6.i686.rpm: Header V4 DSA/SHA1
> Signature, key ID 442df0f8: NOKEY
> error: Failed dependencies:
> * * * *libwx_baseu-2.8.so.0 is needed by pgadmin3-1.12.2-1.rhel6.i686
> * * * *libwx_baseu-2.8.so.0(WXU_2.8) is needed by pgadmin3-1.12.2-1.rhel6.i686
> * * * *libwx_baseu-2.8.so.0(WXU_2.8.5) is needed by pgadmin3-1.12.2-1.rhel6.i686
> * * * *libwx_baseu_net-2.8.so.0 is needed by pgadmin3-1.12.2-1.rhel6.i686
> * * * *libwx_baseu_net-2.8.so.0(WXU_2.8) is needed by pgadmin3-1.12.2-1.rhel6.i686
> * * * *libwx_baseu_xml-2.8.so.0 is needed by pgadmin3-1.12.2-1.rhel6.i686
> * * * *libwx_baseu_xml-2.8.so.0(WXU_2.8) is needed by pgadmin3-1.12.2-1.rhel6.i686
> * * * *libwx_gtk2u_adv-2.8.so.0 is needed by pgadmin3-1.12.2-1.rhel6.i686
> * * * *libwx_gtk2u_adv-2.8.so.0(WXU_2.8) is needed by pgadmin3-1.12.2-1.rhel6.i686
> * * * *libwx_gtk2u_aui-2.8.so.0 is needed by pgadmin3-1.12.2-1.rhel6.i686
> * * * *libwx_gtk2u_aui-2.8.so.0(WXU_2.8) is needed by pgadmin3-1.12.2-1.rhel6.i686
> * * * *libwx_gtk2u_core-2.8.so.0 is needed by pgadmin3-1.12.2-1.rhel6.i686
> * * * *libwx_gtk2u_core-2.8.so.0(WXU_2.8) is needed by pgadmin3-1.12.2-1.rhel6.i686
> * * * *libwx_gtk2u_html-2.8.so.0 is needed by pgadmin3-1.12.2-1.rhel6.i686
> * * * *libwx_gtk2u_html-2.8.so.0(WXU_2.8) is needed by pgadmin3-1.12.2-1.rhel6.i686
> * * * *libwx_gtk2u_ogl-2.8.so.0 is needed by pgadmin3-1.12.2-1.rhel6.i686
> * * * *libwx_gtk2u_ogl-2.8.so.0(WXU_2.8) is needed by pgadmin3-1.12.2-1.rhel6.i686
> * * * *libwx_gtk2u_qa-2.8.so.0 is needed by pgadmin3-1.12.2-1.rhel6.i686
> * * * *libwx_gtk2u_richtext-2.8.so.0 is needed by pgadmin3-1.12.2-1.rhel6.i686
> * * * *libwx_gtk2u_stc-2.8.so.0 is needed by pgadmin3-1.12.2-1.rhel6.i686
> * * * *libwx_gtk2u_stc-2.8.so.0(WXU_2.8) is needed by pgadmin3-1.12.2-1.rhel6.i686
> * * * *libwx_gtk2u_xrc-2.8.so.0 is needed by pgadmin3-1.12.2-1.rhel6.i686
> * * * *libwx_gtk2u_xrc-2.8.so.0(WXU_2.8) is needed by pgadmin3-1.12.2-1.rhel6.i686
> * * * *wxGTK is needed by pgadmin3-1.12.2-1.rhel6.i686
> [root@cc-bc4d99dffae2 ~]#
>
>
> --
> “Don't eat anything you've ever seen advertised on TV”
> * * * ** - Michael Pollan, author of "In Defense of Food"
> _______________________________________________
> CentOS mailing list
> CentOS@centos.org
> http://lists.centos.org/mailman/listinfo/centos
>



--
Dale Dellutri
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 11-15-2011, 08:12 PM
Alan McKay
 
Default pgadmin3 missing dependencies

Thanks for the quick reponses guys - tried that and it still does not
work which tells me I need those PG repos afterall, I guess. No
biggie. My desired for a "clean" system has been smashed, but I'll
live :-)


--
“Don't eat anything you've ever seen advertised on TV”
* * * ** - Michael Pollan, author of "In Defense of Food"
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 11-15-2011, 09:04 PM
John R Pierce
 
Default pgadmin3 missing dependencies

On 11/15/11 1:12 PM, Alan McKay wrote:
> Thanks for the quick reponses guys - tried that and it still does not
> work which tells me I need those PG repos afterall, I guess. No
> biggie. My desired for a "clean" system has been smashed, but I'll
> live :-)

did yum say what specific packages it needed ? I'm pretty sure you have
to use 'yum localinstall' to install from an rpm file, and not just
'install'...



--
john r pierce N 37, W 122
santa cruz ca mid-left coast

_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 11-15-2011, 09:15 PM
Dale Dellutri
 
Default pgadmin3 missing dependencies

On Tue, Nov 15, 2011 at 4:04 PM, John R Pierce <pierce@hogranch.com> wrote:
> On 11/15/11 1:12 PM, Alan McKay wrote:
>> Thanks for the quick reponses guys - tried that and it still does not
>> work which tells me I need those PG repos afterall, I guess. * No
>> biggie. *My desired for a "clean" system has been smashed, but I'll
>> live :-)
>
> did yum say what specific packages it needed ? *I'm pretty sure you have
> to use 'yum localinstall' to install from an rpm file, and not just
> 'install'...

from man yum:
* localinstall rpmfile1 [rpmfile2] [...]
(maintained for legacy reasons only - use install)
and further:
If the name is a file, then install works like localinstall.

Actually, I've been using localinstall, but I started to use
install a few months ago.

--
Dale Dellutri
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 11-15-2011, 09:26 PM
John R Pierce
 
Default pgadmin3 missing dependencies

On 11/15/11 2:15 PM, Dale Dellutri wrote:
>> > did yum say what specific packages it needed ? I'm pretty sure you have
>> > to use 'yum localinstall' to install from an rpm file, and not just
>> > 'install'...
> from man yum:
> * localinstall rpmfile1 [rpmfile2] [...]
> (maintained for legacy reasons only - use install)
> and further:
> If the name is a file, then install works like localinstall.
>
> Actually, I've been using localinstall, but I started to use
> install a few months ago.

ah, ok. so, did you get the same errors as the rpm command or
something else??

--
john r pierce N 37, W 122
santa cruz ca mid-left coast

_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 11-15-2011, 10:59 PM
Alan McKay
 
Default pgadmin3 missing dependencies

> ah, ok. * so, did you get the same errors as the rpm command or
> something else??

I tried both and they both seemed to do the same thing. I'm not at
work now so don't have all the details but it did not tell me which
packages I needed. In the end I just installed the PG repo and that
fixed things up for me.


--
“Don't eat anything you've ever seen advertised on TV”
* * * ** - Michael Pollan, author of "In Defense of Food"
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 

Thread Tools




All times are GMT. The time now is 08:54 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org