FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > CentOS > CentOS

 
 
LinkBack Thread Tools
 
Old 10-11-2011, 11:43 AM
Nicolas Thierry-Mieg
 
Default Is there a problem with C6 CR and glibc?

Patrick Bervoets wrote:
> Well, I've found the file when browsing to mirrors.centos.org:
>
> in 6.0/cr/rpms I find glibc-2.12-1.25.el6.i686.rpm
> in 6.0/cr/drpms I find glibc-2.12-1.7.el6_2.12-1.25.el6_1.3.i686.drpm


you should find the el6_1.3.i686 rpm in cr/rpms, it does show up for me:
http://mirror.centos.org/centos/6.0/cr/x86_64/RPMS/glibc-2.12-1.25.el6_1.3.i686.rpm

if not I guess your nearest mirror has a problem, maybe try another mirror.

yes DL'ing the file and doing yum localinstall should be fine.
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 10-11-2011, 11:57 AM
Ljubomir Ljubojevic
 
Default Is there a problem with C6 CR and glibc?

Vreme: 10/11/2011 01:43 PM, Nicolas Thierry-Mieg piše:
> Patrick Bervoets wrote:
>> Well, I've found the file when browsing to mirrors.centos.org:
>>
>> in 6.0/cr/rpms I find glibc-2.12-1.25.el6.i686.rpm
>> in 6.0/cr/drpms I find glibc-2.12-1.7.el6_2.12-1.25.el6_1.3.i686.drpm
>
>
> you should find the el6_1.3.i686 rpm in cr/rpms, it does show up for me:
> http://mirror.centos.org/centos/6.0/cr/x86_64/RPMS/glibc-2.12-1.25.el6_1.3.i686.rpm
>
> if not I guess your nearest mirror has a problem, maybe try another mirror.
>
> yes DL'ing the file and doing yum localinstall should be fine.

You can do that as a short term measure, but you really need to solve this.

Try changing link for cr repo to specific mirror from
http://www.centos.org/modules/tinycontent/index.php?id=30

Also, maybe "yum reinstall centos-release centos-release-cr" might help
(taking care that it is consistant with your other repo files).

If neither of those things helps, then you should post your content of
your .repo files.


--

Ljubomir Ljubojevic
(Love is in the Air)
PL Computers
Serbia, Europe

Google is the Mother, Google is the Father, and traceroute is your
trusty Spiderman...
StarOS, Mikrotik and CentOS/RHEL/Linux consultant
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 10-11-2011, 12:05 PM
Patrick Bervoets
 
Default Is there a problem with C6 CR and glibc?

Op 11-10-11 13:43, Nicolas Thierry-Mieg schreef:
> Patrick Bervoets wrote:
>> Well, I've found the file when browsing to mirrors.centos.org:
>>
>> in 6.0/cr/rpms I find glibc-2.12-1.25.el6.i686.rpm
>> in 6.0/cr/drpms I find glibc-2.12-1.7.el6_2.12-1.25.el6_1.3.i686.drpm
>
> you should find the el6_1.3.i686 rpm in cr/rpms, it does show up for me:
> http://mirror.centos.org/centos/6.0/cr/x86_64/RPMS/glibc-2.12-1.25.el6_1.3.i686.rpm
>
> if not I guess your nearest mirror has a problem, maybe try another mirror.
>
> yes DL'ing the file and doing yum localinstall should be fine.
> _______________________________________________
> CentOS mailing list
> CentOS@centos.org
> http://lists.centos.org/mailman/listinfo/centos
>

Okay, look at me being a fool!
While I was shure I added priority=1 to the CR.repo I didn't doublecheck that file (I did check my other .repo's). Until now.

Thanks Nicolas and Ljubomir for your time and help!

What a shame....



For the record:

I local-installed glibc without problems
Installing : glibc-2.12-1.25.el6_1.3.i686
Installing : nss-softokn-freebl-3.12.8-1.el6_0.i686

but then...

yum install samba
[...]
Error: Protected multilib versions: zlib-1.2.3-25.el6.i686 != zlib-1.2.3-26.el6.x86_64
Error: Protected multilib versions: audit-libs-2.0.4-1.el6.i686 != audit-libs-2.1-5.el6.x86_64
Error: Protected multilib versions: samba-common-3.5.4-68.el6_0.2.i686 != samba-common-3.5.6-86.el6_1.4.x86_64
Error: Protected multilib versions: libtdb-1.2.1-2.el6.i686 != libtdb-1.2.1-3.el6.x86_64
Error: Protected multilib versions: pam-1.1.1-4.el6_0.1.i686 != pam-1.1.1-8.el6.x86_64
Error: Protected multilib versions: libcom_err-1.41.12-3.el6.i686 != libcom_err-1.41.12-7.el6.x86_64
Error: Protected multilib versions: openldap-2.4.19-15.el6_0.2.i686 != openldap-2.4.23-15.el6_1.1.x86_64
Error: Protected multilib versions: samba-winbind-clients-3.5.4-68.el6_0.2.i686 != samba-winbind-clients-3.5.6-86.el6_1.4.x86_64
Error: Protected multilib versions: libuuid-2.17.2-6.el6_0.1.i686 != libuuid-2.17.2-12.el6.x86_64
Error: Protected multilib versions: openssl-1.0.0-4.el6_0.2.i686 != openssl-1.0.0-10.el6_1.4.x86_64
Error: Protected multilib versions: krb5-libs-1.8.2-3.el6_0.7.i686 != krb5-libs-1.9-9.el6.x86_64
Error: Protected multilib versions: libselinux-2.0.94-2.el6.i686 != libselinux-2.0.94-5.el6.x86_64
Error: Protected multilib versions: libattr-2.4.44-4.el6.i686 != libattr-2.4.44-7.el6.x86_64

And then I went back to my cr.repo

Strange thing is, now it installs only the samba.x86_64 without complaining. No more i686's.

_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 

Thread Tools




All times are GMT. The time now is 11:36 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org