FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > CentOS > CentOS

 
 
LinkBack Thread Tools
 
Old 10-11-2011, 09:13 AM
Patrick Bervoets
 
Default Is there a problem with C6 CR and glibc?

C6 with CR x86_64

Third time when trying to install a packet I get:

yum install samba
[...]
--> Finished Dependency Resolution
Error: Package: glibc-2.12-1.7.el6_0.5.i686 (updates)
Requires: glibc-common = 2.12-1.7.el6_0.5
Installed: glibc-common-2.12-1.25.el6_1.3.x86_64 (@cr)
glibc-common = 2.12-1.25.el6_1.3
Available: glibc-common-2.12-1.7.el6.x86_64 (base)
glibc-common = 2.12-1.7.el6
Available: glibc-common-2.12-1.7.el6_0.3.x86_64 (updates)
glibc-common = 2.12-1.7.el6_0.3
Available: glibc-common-2.12-1.7.el6_0.4.x86_64 (updates)
glibc-common = 2.12-1.7.el6_0.4
Available: glibc-common-2.12-1.7.el6_0.5.x86_64 (updates)
glibc-common = 2.12-1.7.el6_0.5

Had the same problem yesterday with a Canondriver-rpm and earlier with either Hugin or Scribus.
Searched on Google and found many old pages (afaik nothing C6).

I don't think there is a glibc-common i686 package (neither do I know if that would be a good idea).
Should I downgrade glibc-common to 2.12-1.7? Or install a second glibc-common? Or just wait?

BTW I tried to install Samba with only Base, Updates and CR repo enabled.

Thanks
Patrick
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 10-11-2011, 09:30 AM
Nicolas Thierry-Mieg
 
Default Is there a problem with C6 CR and glibc?

Patrick Bervoets wrote:
> C6 with CR x86_64
>
> Third time when trying to install a packet I get:
>
> yum install samba
> [...]
> --> Finished Dependency Resolution
> Error: Package: glibc-2.12-1.7.el6_0.5.i686 (updates)
> Requires: glibc-common = 2.12-1.7.el6_0.5
> Installed: glibc-common-2.12-1.25.el6_1.3.x86_64 (@cr)
> glibc-common = 2.12-1.25.el6_1.3
> Available: glibc-common-2.12-1.7.el6.x86_64 (base)
> glibc-common = 2.12-1.7.el6
> Available: glibc-common-2.12-1.7.el6_0.3.x86_64 (updates)
> glibc-common = 2.12-1.7.el6_0.3
> Available: glibc-common-2.12-1.7.el6_0.4.x86_64 (updates)
> glibc-common = 2.12-1.7.el6_0.4
> Available: glibc-common-2.12-1.7.el6_0.5.x86_64 (updates)
> glibc-common = 2.12-1.7.el6_0.5
>
> Had the same problem yesterday with a Canondriver-rpm and earlier with either Hugin or Scribus.
> Searched on Google and found many old pages (afaik nothing C6).
>
> I don't think there is a glibc-common i686 package (neither do I know if that would be a good idea).
> Should I downgrade glibc-common to 2.12-1.7? Or install a second glibc-common? Or just wait?
>
> BTW I tried to install Samba with only Base, Updates and CR repo enabled.


works here, you should be getting glibc-2.12-1.25.el6_1.3.i686 from CR.

are you using yum priorities? base, updates and CR need the same priority.

otherwise do "yum clean all" then try again, as usual when yum breaks.
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 10-11-2011, 09:52 AM
Patrick Bervoets
 
Default Is there a problem with C6 CR and glibc?

Op 11-10-11 11:30, Nicolas Thierry-Mieg schreef:
> Patrick Bervoets wrote:
>> C6 with CR x86_64
>>
>> Third time when trying to install a packet I get:
>>
>> yum install samba
>> [...]
>> --> Finished Dependency Resolution
>> Error: Package: glibc-2.12-1.7.el6_0.5.i686 (updates)
>> Requires: glibc-common = 2.12-1.7.el6_0.5
>> Installed: glibc-common-2.12-1.25.el6_1.3.x86_64 (@cr)
>> glibc-common = 2.12-1.25.el6_1.3
>> Available: glibc-common-2.12-1.7.el6.x86_64 (base)
>> glibc-common = 2.12-1.7.el6
>> Available: glibc-common-2.12-1.7.el6_0.3.x86_64 (updates)
>> glibc-common = 2.12-1.7.el6_0.3
>> Available: glibc-common-2.12-1.7.el6_0.4.x86_64 (updates)
>> glibc-common = 2.12-1.7.el6_0.4
>> Available: glibc-common-2.12-1.7.el6_0.5.x86_64 (updates)
>> glibc-common = 2.12-1.7.el6_0.5
>>
>> Had the same problem yesterday with a Canondriver-rpm and earlier with either Hugin or Scribus.
>> Searched on Google and found many old pages (afaik nothing C6).
>>
>> I don't think there is a glibc-common i686 package (neither do I know if that would be a good idea).
>> Should I downgrade glibc-common to 2.12-1.7? Or install a second glibc-common? Or just wait?
>>
>> BTW I tried to install Samba with only Base, Updates and CR repo enabled.
>
> works here, you should be getting glibc-2.12-1.25.el6_1.3.i686 from CR.
>
> are you using yum priorities? base, updates and CR need the same priority.
>
> otherwise do "yum clean all" then try again, as usual when yum breaks.
> _______________________________________________
> CentOS mailing list
> CentOS@centos.org
> http://lists.centos.org/mailman/listinfo/centos
>
I am using priorities and base = updates = cr = 1. Normally epel and rpmforge = 50; but for testing I disabled them.
While I forgot to "clean all" (and started to feel silly); it doesn't help.
Is there a glibc 2.12-1.25 in CR? I get a "No package glibc-2.12-1.25.el6_1.3.i686 available." message. For i686 only the 1.7 release shows.

Thanks for helping


_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 10-11-2011, 10:36 AM
Ljubomir Ljubojevic
 
Default Is there a problem with C6 CR and glibc?

Vreme: 10/11/2011 11:52 AM, Patrick Bervoets piše:
> Is there a glibc 2.12-1.25 in CR? I get a "No package glibc-2.12-1.25.el6_1.3.i686 available." message. For i686 only the 1.7 release shows.

Yes there is, I have it on x86_64 system. Try deleting
/var/cache/yum/<folders for repos> manually, maybe that helps.

--

Ljubomir Ljubojevic
(Love is in the Air)
PL Computers
Serbia, Europe

Google is the Mother, Google is the Father, and traceroute is your
trusty Spiderman...
StarOS, Mikrotik and CentOS/RHEL/Linux consultant
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 10-11-2011, 11:05 AM
Patrick Bervoets
 
Default Is there a problem with C6 CR and glibc?

Op 11-10-11 12:36, Ljubomir Ljubojevic schreef:
> Vreme: 10/11/2011 11:52 AM, Patrick Bervoets piše:
>> Is there a glibc 2.12-1.25 in CR? I get a "No package glibc-2.12-1.25.el6_1.3.i686 available." message. For i686 only the 1.7 release shows.
> Yes there is, I have it on x86_64 system. Try deleting
> /var/cache/yum/<folders for repos> manually, maybe that helps.
>
No luck with that either.
Well, I've found the file when browsing to mirrors.centos.org:

in 6.0/cr/rpms I find glibc-2.12-1.25.el6.i686.rpm <http://mirror.centos.org/centos/6.0/cr/x86_64/RPMS/glibc-2.12-1.25.el6.i686.rpm>
in 6.0/cr/drpms I find glibc-2.12-1.7.el6_2.12-1.25.el6_1.3.i686.drpm <http://mirror.centos.org/centos/6.0/cr/x86_64/drpms/glibc-2.12-1.7.el6_2.12-1.25.el6_1.3.i686.drpm>

Should I download that file and localinstall it?

_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 

Thread Tools




All times are GMT. The time now is 10:13 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org