FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > CentOS > CentOS

 
 
LinkBack Thread Tools
 
Old 08-31-2011, 09:37 PM
david
 
Default Unable to run yum update

Folks

The system involved is a 32-bit system, installed via the net about a
week ago. The command

yum update

encountered the following diagonstic

Error: Package: yaf-1.3.2-1.el6.rf.x86_64 (@rpmforge)
Requires: libfixbuf-0.9.0.so.8()(64bit)
Removing: libfixbuf-0.9.0-1.el6.rf.x86_64 (@rpmforge)
libfixbuf-0.9.0.so.8()(64bit)
Updated By: libfixbuf-1.0.1-1.el6.rf.x86_64 (rpmforge)
Not found
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

The repositories I use are:

base
epel
extras
rpmforge
updates
virtualbox


I wonder if using priorities would help? Rpmforge is "supposed" to
be non-conflicting, but then....

Please let me know what I should do.

David

_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 08-31-2011, 10:37 PM
Jim Perrin
 
Default Unable to run yum update

On Wed, Aug 31, 2011 at 4:37 PM, david <david@daku.org> wrote:

Folks



The system involved is a 32-bit system...

If the system* really is 32bit, then I'd question how you installed the rpmforge repo, as it's looking for 64bit packages.
It's entirely possible that you installed the 64bit rpmforge-release package on a 32bit system, which would likely result in what you're seeing.


--
During times of universal deceit, telling the truth becomes a revolutionary act.
George Orwell

_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 09-01-2011, 02:56 PM
Robert Spangler
 
Default Unable to run yum update

On Wednesday 31 August 2011 17:37, the following was written:

> The system involved is a 32-bit system, installed via the net about a
>
> yum update
>
> encountered the following diagonstic
>
> Error: Package: yaf-1.3.2-1.el6.rf.x86_64 (@rpmforge)
> Requires: libfixbuf-0.9.0.so.8()(64bit)
> Removing: libfixbuf-0.9.0-1.el6.rf.x86_64 (@rpmforge)
> libfixbuf-0.9.0.so.8()(64bit)
> Updated By: libfixbuf-1.0.1-1.el6.rf.x86_64 (rpmforge)
> Not found


These are 64 bit programs. Look at them closely.

'x86_64'
'(64bit)'

Are your clues.


--

Regards
Robert

Linux
The adventure of a lifetime.

Linux User #296285
Get Counted
http://linuxcounter.net/
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 09-01-2011, 03:47 PM
david
 
Default Unable to run yum update

Robert:

Good eyes, but the error is in MY description. The machine is a
64-bit machine. I was misled by some other issues I had with a
near-by 32-bit machine.

So, I'm back to trying to figure this out, and trying to understand
why it happened on one of my 64-bit systems and not others, where
I've configured them pretty much the same.

David


At 07:56 AM 9/1/2011, you wrote:
>On Wednesday 31 August 2011 17:37, the following was written:
>
> > The system involved is a 64-bit system, installed via the net about a
> >
> > yum update
> >
> > encountered the following diagonstic
> >
> > Error: Package: yaf-1.3.2-1.el6.rf.x86_64 (@rpmforge)
> > Requires: libfixbuf-0.9.0.so.8()(64bit)
> > Removing: libfixbuf-0.9.0-1.el6.rf.x86_64 (@rpmforge)
> > libfixbuf-0.9.0.so.8()(64bit)
> > Updated By: libfixbuf-1.0.1-1.el6.rf.x86_64 (rpmforge)
> > Not found

_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 09-02-2011, 10:21 AM
John Doe
 
Default Unable to run yum update

From: david <david@daku.org>

>> >* The system involved is a 64-bit system, installed via the net about a
>> >* * yum update
>> >* encountered the following diagonstic
>> >
>> >* Error: Package: yaf-1.3.2-1.el6.rf.x86_64 (@rpmforge)
>> >* * * * * * * Requires: libfixbuf-0.9.0.so.8()(64bit)
>> >* * * * * * * Removing: libfixbuf-0.9.0-1.el6.rf.x86_64 (@rpmforge)
>> >* * * * * * * * * libfixbuf-0.9.0.so.8()(64bit)
>> >* * * * * * * Updated By: libfixbuf-1.0.1-1.el6.rf.x86_64 (rpmforge)
>> >* * * * * * * * * Not found

Works fine here:

Resolving Dependencies
--> Running transaction check
---> Package yaf.x86_64 0:1.3.2-1.el6.rf set to be updated
--> Processing Dependency: libfixbuf-0.9.0.so.8()(64bit) for package: yaf-1.3.2-1.el6.rf.x86_64
--> Running transaction check
---> Package libfixbuf.x86_64 0:0.9.0-1.el6.rf set to be updated
--> Finished Dependency Resolution
Dependencies Resolved

But as you can see, there is no libfixbuf-1.0.1-1 trying to replace ...
Repoforge bug?
Tried yum clean all?

JD
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 10-08-2011, 01:53 PM
Ljubomir Ljubojevic
 
Default Unable to run yum update

yaf-1.3.2-1.el6.rf.x86_64 did request older version of libfixbuf. And
libfixbuf 1.0.1 was introduced Sept 28th.

There is yaf-2.1.1-2.el6.rf.x86_64.rpm as of yesterday. It should use
newer libfixbuf.


--

Ljubomir Ljubojevic
(Love is in the Air)
PL Computers
Serbia, Europe

Google is the Mother, Google is the Father, and traceroute is your
trusty Spiderman...
StarOS, Mikrotik and CentOS/RHEL/Linux consultant
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 

Thread Tools




All times are GMT. The time now is 02:13 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org