Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   CentOS (http://www.linux-archive.org/centos/)
-   -   5.1.6 php to 5.3, a few questions (http://www.linux-archive.org/centos/565092-5-1-6-php-5-3-few-questions.html)

Bob Hoffman 08-17-2011 04:20 AM

5.1.6 php to 5.3, a few questions
 
Alright, looks like I have to do this (centos 5.x install).

Some questions..

1) I imagine I have to uninstall my current version of php...will yum
remove want to take a ton of programs with it? Would I have to
individually uninstall each package instead?

2) yum down the new version from some repo and then install it. I
imagine nothing from the previous setup will be there and I would have
to start going through the program and config files to make it work with
my system, yes?

3) for those that have done it, how many things broke when you took out
the old and added the new?

honestly just thinking about getting a new comp, installing centos6,
adding some virtuals, moving the sites over to the new one and being
done with it.

Not comfortable with a version of php that will not be backported like
5.1.6 is with centos team.

any problems you encountered, would love to hear about them.

thanks
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos

Brian Mathis 08-17-2011 02:05 PM

5.1.6 php to 5.3, a few questions
 
On Wed, Aug 17, 2011 at 12:20 AM, Bob Hoffman <bob@bobhoffman.com> wrote:
> Alright, looks like I have to do this (centos 5.x install).
>
> Some questions..
>
> 1) I imagine I have to uninstall my current version of php...will yum
> remove want to take a ton of programs with it? Would I have to
> individually uninstall each package instead?
>
> 2) yum down the new version from some repo and then install it. I
> imagine nothing from the previous setup will be there and I would have
> to start going through the program and config files to make it work with
> my system, yes?
>
> 3) for those that have done it, how many things broke when you took out
> the old and added the new?
>
> honestly just thinking about getting a new comp, installing centos6,
> adding some virtuals, moving the sites over to the new one and being
> done with it.
>
> Not comfortable with a version of php that will not be backported like
> 5.1.6 is with centos team.
>
> any problems you encountered, would love to hear about them.
>
> thanks


The official php53 packages do not provide "php", in the rpm
dependency sense, (they use "php53") so any app that requires the php
dependency will not install or complain if you try to remove the
original php package. This makes the official php53 packages
unusable, IMO.

The IUS repository provides php 5.3 rpms that do provide the correct
'php' dependency, so the apps won't have dependency issues.


-☙ Brian Mathis ❧-
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos


All times are GMT. The time now is 10:21 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.