FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > CentOS > CentOS

 
 
LinkBack Thread Tools
 
Old 05-03-2011, 08:50 PM
"James A. Peltier"
 
Default libpq.so.4 missing

Anyone else seeing this when trying to install httpd? My mirror is completely up to date and the machine is a fresh install of CentOS 5.6

Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
Excluding Packages from CentOS-5 - Base
Finished
Excluding Packages from CentOS-5 - Updates
Finished
7 packages excluded due to repository priority protections
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package httpd.x86_64 0:2.2.3-45.el5.centos set to be updated
NSG/filelists | 157 kB 00:00
addons/filelists | 197 B 00:00
adobe-linux/filelists | 140 kB 00:00
base/filelists_db | 4.0 MB 00:00
extras/filelists_db | 225 kB 00:00
updates/filelists_db | 1.5 MB 00:00
--> Processing Dependency: libaprutil-1.so.0()(64bit) for package: httpd
--> Processing Dependency: libapr-1.so.0()(64bit) for package: httpd
--> Running transaction check
---> Package apr.x86_64 0:1.2.7-11.el5_5.3 set to be updated
---> Package apr-util.x86_64 0:1.2.7-11.el5_5.2 set to be updated
--> Processing Dependency: libpq.so.4()(64bit) for package: apr-util
--> Finished Dependency Resolution
apr-util-1.2.7-11.el5_5.2.x86_64 from base has depsolving problems
--> Missing Dependency: libpq.so.4()(64bit) is needed by package apr-util-1.2.7-11.el5_5.2.x86_64 (base)
Error: Missing Dependency: libpq.so.4()(64bit) is needed by package apr-util-1.2.7-11.el5_5.2.x86_64 (base)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest


--
James A. Peltier
IT Services - Research Computing Group
Simon Fraser University - Burnaby Campus
Phone : 778-782-6573
Fax : 778-782-3045
E-Mail : jpeltier@sfu.ca
Website : http://www.sfu.ca/itservices
http://blogs.sfu.ca/people/jpeltier


_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 05-03-2011, 08:55 PM
Steven Crothers
 
Default libpq.so.4 missing

"Your" mirror? Try another mirror perhaps?

On Tue, May 3, 2011 at 4:50 PM, James A. Peltier <jpeltier@sfu.ca> wrote:
> Anyone else seeing this when trying to install httpd? *My mirror is completely up to date and the machine is a fresh install of CentOS 5.6
>
> Loaded plugins: fastestmirror, priorities
> Loading mirror speeds from cached hostfile
> Excluding Packages from CentOS-5 - Base
> Finished
> Excluding Packages from CentOS-5 - Updates
> Finished
> 7 packages excluded due to repository priority protections
> Setting up Install Process
> Resolving Dependencies
> --> Running transaction check
> ---> Package httpd.x86_64 0:2.2.3-45.el5.centos set to be updated
> NSG/filelists * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * | 157 kB * * 00:00
> addons/filelists * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *| *197 B * * 00:00
> adobe-linux/filelists * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * | 140 kB * * 00:00
> base/filelists_db * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * | 4.0 MB * * 00:00
> extras/filelists_db * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * | 225 kB * * 00:00
> updates/filelists_db * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *| 1.5 MB * * 00:00
> --> Processing Dependency: libaprutil-1.so.0()(64bit) for package: httpd
> --> Processing Dependency: libapr-1.so.0()(64bit) for package: httpd
> --> Running transaction check
> ---> Package apr.x86_64 0:1.2.7-11.el5_5.3 set to be updated
> ---> Package apr-util.x86_64 0:1.2.7-11.el5_5.2 set to be updated
> --> Processing Dependency: libpq.so.4()(64bit) for package: apr-util
> --> Finished Dependency Resolution
> apr-util-1.2.7-11.el5_5.2.x86_64 from base has depsolving problems
> *--> Missing Dependency: libpq.so.4()(64bit) is needed by package apr-util-1.2.7-11.el5_5.2.x86_64 (base)
> Error: Missing Dependency: libpq.so.4()(64bit) is needed by package apr-util-1.2.7-11.el5_5.2.x86_64 (base)
> *You could try using --skip-broken to work around the problem
> *You could try running: package-cleanup --problems
> * * * * * * * * * * * *package-cleanup --dupes
> * * * * * * * * * * * *rpm -Va --nofiles --nodigest
>
>
> --
> James A. Peltier
> IT Services - Research Computing Group
> Simon Fraser University - Burnaby Campus
> Phone * : 778-782-6573
> Fax * * : 778-782-3045
> E-Mail *: jpeltier@sfu.ca
> Website : http://www.sfu.ca/itservices
> * * * * *http://blogs.sfu.ca/people/jpeltier
>
>
> _______________________________________________
> CentOS mailing list
> CentOS@centos.org
> http://lists.centos.org/mailman/listinfo/centos
>



--
Steven Crothers
steven.crothers@gmail.com
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 05-03-2011, 08:58 PM
"James A. Peltier"
 
Default libpq.so.4 missing

Considering that I am mirroring from us-msync and that my mirror is less than 1 hour behind and that I've been trying for days I would not think it to be my mirror, but yeah I'll try it.

----- Original Message -----
| "Your" mirror? Try another mirror perhaps?
|
| On Tue, May 3, 2011 at 4:50 PM, James A. Peltier <jpeltier@sfu.ca>
| wrote:
| > Anyone else seeing this when trying to install httpd? My mirror is
| > completely up to date and the machine is a fresh install of CentOS
| > 5.6
| >
| > Loaded plugins: fastestmirror, priorities
| > Loading mirror speeds from cached hostfile
| > Excluding Packages from CentOS-5 - Base
| > Finished
| > Excluding Packages from CentOS-5 - Updates
| > Finished
| > 7 packages excluded due to repository priority protections
| > Setting up Install Process
| > Resolving Dependencies
| > --> Running transaction check
| > ---> Package httpd.x86_64 0:2.2.3-45.el5.centos set to be updated
| > NSG/filelists | 157 kB 00:00
| > addons/filelists | 197 B 00:00
| > adobe-linux/filelists | 140 kB 00:00
| > base/filelists_db | 4.0 MB 00:00
| > extras/filelists_db | 225 kB 00:00
| > updates/filelists_db | 1.5 MB 00:00
| > --> Processing Dependency: libaprutil-1.so.0()(64bit) for package:
| > httpd
| > --> Processing Dependency: libapr-1.so.0()(64bit) for package: httpd
| > --> Running transaction check
| > ---> Package apr.x86_64 0:1.2.7-11.el5_5.3 set to be updated
| > ---> Package apr-util.x86_64 0:1.2.7-11.el5_5.2 set to be updated
| > --> Processing Dependency: libpq.so.4()(64bit) for package: apr-util
| > --> Finished Dependency Resolution
| > apr-util-1.2.7-11.el5_5.2.x86_64 from base has depsolving problems
| > *--> Missing Dependency: libpq.so.4()(64bit) is needed by package
| > *apr-util-1.2.7-11.el5_5.2.x86_64 (base)
| > Error: Missing Dependency: libpq.so.4()(64bit) is needed by package
| > apr-util-1.2.7-11.el5_5.2.x86_64 (base)
| > *You could try using --skip-broken to work around the problem
| > *You could try running: package-cleanup --problems
| > * * * * * * * * * * * *package-cleanup --dupes
| > * * * * * * * * * * * *rpm -Va --nofiles --nodigest
| >
| >
| > --
| > James A. Peltier
| > IT Services - Research Computing Group
| > Simon Fraser University - Burnaby Campus
| > Phone : 778-782-6573
| > Fax : 778-782-3045
| > E-Mail : jpeltier@sfu.ca
| > Website : http://www.sfu.ca/itservices
| > * * * * *http://blogs.sfu.ca/people/jpeltier
| >
| >
| > _______________________________________________
| > CentOS mailing list
| > CentOS@centos.org
| > http://lists.centos.org/mailman/listinfo/centos
| >
|
|
|
| --
| Steven Crothers
| steven.crothers@gmail.com
| _______________________________________________
| CentOS mailing list
| CentOS@centos.org
| http://lists.centos.org/mailman/listinfo/centos

--
James A. Peltier
IT Services - Research Computing Group
Simon Fraser University - Burnaby Campus
Phone : 778-782-6573
Fax : 778-782-3045
E-Mail : jpeltier@sfu.ca
Website : http://www.sfu.ca/itservices
http://blogs.sfu.ca/people/jpeltier


_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 05-03-2011, 09:17 PM
Ljubomir Ljubojevic
 
Default libpq.so.4 missing

James A. Peltier wrote:
> Considering that I am mirroring from us-msync and that my mirror is less than 1 hour behind and that I've been trying for days I would not think it to be my mirror, but yeah I'll try it.
>
> ----- Original Message -----
> | "Your" mirror? Try another mirror perhaps?
> |
> | On Tue, May 3, 2011 at 4:50 PM, James A. Peltier <jpeltier@sfu.ca>
> | wrote:
> | > Anyone else seeing this when trying to install httpd? My mirror is
> | > completely up to date and the machine is a fresh install of CentOS
> | > 5.6
> | >
> | > Loaded plugins: fastestmirror, priorities
> | > Loading mirror speeds from cached hostfile
> | > Excluding Packages from CentOS-5 - Base
> | > Finished
> | > Excluding Packages from CentOS-5 - Updates
> | > Finished
> | > 7 packages excluded due to repository priority protections
> | > Setting up Install Process
> | > Resolving Dependencies
> | > --> Running transaction check
> | > ---> Package httpd.x86_64 0:2.2.3-45.el5.centos set to be updated
> | > NSG/filelists | 157 kB 00:00
> | > addons/filelists | 197 B 00:00
> | > adobe-linux/filelists | 140 kB 00:00
> | > base/filelists_db | 4.0 MB 00:00
> | > extras/filelists_db | 225 kB 00:00
> | > updates/filelists_db | 1.5 MB 00:00
> | > --> Processing Dependency: libaprutil-1.so.0()(64bit) for package:
> | > httpd
> | > --> Processing Dependency: libapr-1.so.0()(64bit) for package: httpd
> | > --> Running transaction check
> | > ---> Package apr.x86_64 0:1.2.7-11.el5_5.3 set to be updated
> | > ---> Package apr-util.x86_64 0:1.2.7-11.el5_5.2 set to be updated
> | > --> Processing Dependency: libpq.so.4()(64bit) for package: apr-util
> | > --> Finished Dependency Resolution
> | > apr-util-1.2.7-11.el5_5.2.x86_64 from base has depsolving problems
> | > --> Missing Dependency: libpq.so.4()(64bit) is needed by package
> | > apr-util-1.2.7-11.el5_5.2.x86_64 (base)
> | > Error: Missing Dependency: libpq.so.4()(64bit) is needed by package
> | > apr-util-1.2.7-11.el5_5.2.x86_64 (base)
> | > You could try using --skip-broken to work around the problem
> | > You could try running: package-cleanup --problems
> | > package-cleanup --dupes
> | > rpm -Va --nofiles --nodigest
> | >
> | >
> | > --
> | > James A. Peltier
> | > IT Services - Research Computing Group
> | > Simon Fraser University - Burnaby Campus
> | > Phone : 778-782-6573
> | > Fax : 778-782-3045
> | > E-Mail : jpeltier@sfu.ca
> | > Website : http://www.sfu.ca/itservices
> | > http://blogs.sfu.ca/people/jpeltier
> | >
> | >
> | > _______________________________________________
> | > CentOS mailing list
> | > CentOS@centos.org
> | > http://lists.centos.org/mailman/listinfo/centos
> | >
> |
> |
> |
> | --
> | Steven Crothers
> | steven.crothers@gmail.com
> | _______________________________________________
> | CentOS mailing list
> | CentOS@centos.org
> | http://lists.centos.org/mailman/listinfo/centos
>
libpq.so.4 is from postgresql-libs-8.1.23-1.el5_6.1.x86_64 package in
base and update repositories. Try installing manually and try clearing
cache and maybe check your yum/rpm databases?

Have you installed any third party PostgreSQL packages?

Ljubomir
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 05-03-2011, 09:18 PM
John R Pierce
 
Default libpq.so.4 missing

On 05/03/11 1:50 PM, James A. Peltier wrote:
> Anyone else seeing this when trying to install httpd? My mirror is completely up to date and the machine is a fresh install of CentOS 5.6

/usr/lib/libpq.so.4 should be a symlink to libpq.so.4.1, which is
provided by postgresql-libs

now, I'm running a newer postgres from the yum.postgresql.org
repository, they provide libpq.so.4 via compat-postgresql-libs



_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 05-03-2011, 09:36 PM
"James A. Peltier"
 
Default libpq.so.4 missing

----- Original Message -----
| On 05/03/11 1:50 PM, James A. Peltier wrote:
| > Anyone else seeing this when trying to install httpd? My mirror is
| > completely up to date and the machine is a fresh install of CentOS
| > 5.6
|
| /usr/lib/libpq.so.4 should be a symlink to libpq.so.4.1, which is
| provided by postgresql-libs
|
| now, I'm running a newer postgres from the yum.postgresql.org
| repository, they provide libpq.so.4 via compat-postgresql-libs


I don't have PostgreSQL installed. I have no need for it to be installed.

I have run a yum -y clean all on the host which has only @core installed and some necessary packages to build torque and maui

I have tried to run yum -y install httpd no third party repositories enabled and it fails with the error described earlier. I even tried with

yum -y install httpd --disablerepo=* --enablerepo=base

no dice. I'm trying a different mirror on a VM just to be sure it's not me

--
James A. Peltier
IT Services - Research Computing Group
Simon Fraser University - Burnaby Campus
Phone : 778-782-6573
Fax : 778-782-3045
E-Mail : jpeltier@sfu.ca
Website : http://www.sfu.ca/itservices
http://blogs.sfu.ca/people/jpeltier


_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 05-03-2011, 10:12 PM
John R Pierce
 
Default libpq.so.4 missing

On 05/03/11 2:36 PM, James A. Peltier wrote:
> I don't have PostgreSQL installed. I have no need for it to be installed.

Well, if you loaded any of the following packages, they require
postgresql-libs...

$ rpm -q --whatrequires libpq.so.4
dovecot-1.0.7-7.el5
apr-util-1.2.7-7.el5_3.2
perl-DBD-Pg-1.49-2.el5_3.1
php-pgsql-5.2.10-1.el5.centos

now, postgresql-libs is JUST a few small libraries, probably 250kbyte
total, so its not that big of a deal, and for sure, this does NOT
include the postgres database SERVER, just the client runtime.


_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 05-04-2011, 12:40 AM
Steven Crothers
 
Default libpq.so.4 missing

Out of curiosity do you have any postgrestuff installed at all?

rpm -qa | grep postgre

Possible scenario:
You have an rpm installed "providing" the lib, but the lib is now
missing for whatever reason.

*shrugs*

It's hard to diagnose issues over email.

On Tue, May 3, 2011 at 6:12 PM, John R Pierce <pierce@hogranch.com> wrote:
> On 05/03/11 2:36 PM, James A. Peltier wrote:
>> I don't have PostgreSQL installed. *I have no need for it to be installed.
>
> Well, if you loaded any of the following packages, they require
> postgresql-libs...
>
> $ rpm -q --whatrequires libpq.so.4
> dovecot-1.0.7-7.el5
> apr-util-1.2.7-7.el5_3.2
> perl-DBD-Pg-1.49-2.el5_3.1
> php-pgsql-5.2.10-1.el5.centos
>
> now, postgresql-libs is JUST a few small libraries, probably 250kbyte
> total, so its not that big of a deal, and for sure, this does NOT
> include the postgres database SERVER, just the client runtime.
>
>
> _______________________________________________
> CentOS mailing list
> CentOS@centos.org
> http://lists.centos.org/mailman/listinfo/centos
>



--
Steven Crothers
steven.crothers@gmail.com
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 05-04-2011, 01:38 AM
Johnny Hughes
 
Default libpq.so.4 missing

On 05/03/2011 04:36 PM, James A. Peltier wrote:
> ----- Original Message -----
> | On 05/03/11 1:50 PM, James A. Peltier wrote:
> | > Anyone else seeing this when trying to install httpd? My mirror is
> | > completely up to date and the machine is a fresh install of CentOS
> | > 5.6
> |
> | /usr/lib/libpq.so.4 should be a symlink to libpq.so.4.1, which is
> | provided by postgresql-libs
> |
> | now, I'm running a newer postgres from the yum.postgresql.org
> | repository, they provide libpq.so.4 via compat-postgresql-libs
>
>
> I don't have PostgreSQL installed. I have no need for it to be installed.
>
> I have run a yum -y clean all on the host which has only @core installed and some necessary packages to build torque and maui
>
> I have tried to run yum -y install httpd no third party repositories enabled and it fails with the error described earlier. I even tried with
>
> yum -y install httpd --disablerepo=* --enablerepo=base
>
> no dice. I'm trying a different mirror on a VM just to be sure it's not me
>

Do you have any "exclude=" items in your
/etc/yum.repos.d/CentOS-Base.repo or your /etc/yum.conf file ...
specifically is postgresql-libs (or postgresql*) excluded?



_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 

Thread Tools




All times are GMT. The time now is 09:44 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org