Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   CentOS (http://www.linux-archive.org/centos/)
-   -   php53 and MSSQL (http://www.linux-archive.org/centos/514543-php53-mssql.html)

John Beranek 04-15-2011 11:23 AM

php53 and MSSQL
 
[Reposted now I've joined the list, so I hopefully don't get moderated out]

Hi,

I've upgraded lots of machines to 5.6 (thanks!) and there was one
particular machine that I'd also like to upgrade to PHP 5.3.
Unfortunately it seems I can't.

On the machine I have php-mssql installed, and it appears that there is
no php53-mssql.

php-mssql is built from the php-extras SRPM, so is there going to be a
php53-extras SRPM?

I've checked upstream, and they also don't have a php53-mssql package,
so if there _were_ to be solved it'd have to be in the 'Extras'
repository I guess...

Cheers,

John.

--
John Beranek To generalise is to be an idiot.
http://redux.org.uk/ -- William Blake

_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos

John Beranek 04-15-2011 11:45 AM

php53 and MSSQL
 
On 15/04/11 12:23, John Beranek wrote:
> [Reposted now I've joined the list, so I hopefully don't get moderated out]
>
> Hi,
>
> I've upgraded lots of machines to 5.6 (thanks!) and there was one
> particular machine that I'd also like to upgrade to PHP 5.3.
> Unfortunately it seems I can't.
>
> On the machine I have php-mssql installed, and it appears that there is
> no php53-mssql.

I was going to see if I could rebuild the php53 SRPM support with MSSQL
support, until I found that the SRPMs still aren't available on the
CentOS mirrors yet. Downloading the upstream RPM now, will see how that
goes...

John.

--
John Beranek To generalise is to be an idiot.
http://redux.org.uk/ -- William Blake

_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos

Phil Schaffner 04-15-2011 12:49 PM

php53 and MSSQL
 
John Beranek wrote on 04/15/2011 07:45 AM:
> On 15/04/11 12:23, John Beranek wrote:
>> [Reposted now I've joined the list, so I hopefully don't get moderated out]
>>
>> Hi,
>>
>> I've upgraded lots of machines to 5.6 (thanks!) and there was one
>> particular machine that I'd also like to upgrade to PHP 5.3.
>> Unfortunately it seems I can't.
>>
>> On the machine I have php-mssql installed, and it appears that there is
>> no php53-mssql.
>
> I was going to see if I could rebuild the php53 SRPM support with MSSQL
> support, until I found that the SRPMs still aren't available on the
> CentOS mirrors yet. Downloading the upstream RPM now, will see how that
> goes...


I sound like a shill for IUS this morning - not the case I assure you -
but they have php53u-mssql-5.3.6-1.ius.el5

Probably will not work unless you uninstall php or php53 and install
their whole set.

Phil
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos

John Beranek 04-15-2011 01:32 PM

php53 and MSSQL
 
On 15/04/11 13:49, Phil Schaffner wrote:
> John Beranek wrote on 04/15/2011 07:45 AM:
>> On 15/04/11 12:23, John Beranek wrote:
>>> [Reposted now I've joined the list, so I hopefully don't get moderated out]
>>>
>>> Hi,
>>>
>>> I've upgraded lots of machines to 5.6 (thanks!) and there was one
>>> particular machine that I'd also like to upgrade to PHP 5.3.
>>> Unfortunately it seems I can't.
>>>
>>> On the machine I have php-mssql installed, and it appears that there is
>>> no php53-mssql.
>>
>> I was going to see if I could rebuild the php53 SRPM support with MSSQL
>> support, until I found that the SRPMs still aren't available on the
>> CentOS mirrors yet. Downloading the upstream RPM now, will see how that
>> goes...
>
>
> I sound like a shill for IUS this morning - not the case I assure you -
> but they have php53u-mssql-5.3.6-1.ius.el5

Well, I've now rebuilt the RHEL SRPM with mssql support. It's now built
in the openSUSE Build Service at:

https://build.opensuse.org/package/show?package=php53&project=home%3Ajohnberanek%3Aph p53_centos

Not ideal in that it's the while php53 SRPM, and additionally because
OBS is currently building with CentOS 5.5 instead of 5.6. The latter
issue has brought me to raise a bug in the OBS Bugzilla:

https://bugzilla.novell.com/show_bug.cgi?id=687848
Update CentOS build to 5.6

Installed my built PHP 5.3 RPMs on the machine I wanted them on -
painful! Why do you need to remove the PHP 5.1 RPMs before you can
install the 'php53' ones, surely the php53 RPMs could have had
"Deprecated" lines!?

John.

--
John Beranek To generalise is to be an idiot.
http://redux.org.uk/ -- William Blake

_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos


All times are GMT. The time now is 09:59 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.