FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > CentOS > CentOS

 
 
LinkBack Thread Tools
 
Old 02-10-2011, 03:40 PM
Lars Hecking
 
Default Centos 5.5 + firefox 3.6 and 64bit javaplugin (1.6u23)

Eero Volotinen writes:
> Hi List,
>
> Any success running 64bit javaplugin on centos 5.5 & firefox 3.6?
>
> For me it always complains about wrong elfclass64 ?

Check out these threads:
http://lists.centos.org/pipermail/centos/2010-November/101229.html
http://lists.centos.org/pipermail/centos/2010-November/101365.html
http://lists.centos.org/pipermail/centos/2010-November/101528.html

You're either running a 32-bit browser with the 64-bit plugin or
enountered a bug I described here

http://lists.centos.org/pipermail/centos/2010-November/101568.html



---------------------------------------------------------------
This message and any attachments may contain Cypress (or its
subsidiaries) confidential information. If it has been received
in error, please advise the sender and immediately delete this
message.
---------------------------------------------------------------

_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 02-10-2011, 04:12 PM
Eero Volotinen
 
Default Centos 5.5 + firefox 3.6 and 64bit javaplugin (1.6u23)

2011/2/10 Lars Hecking <lhecking@users.sourceforge.net>:
> Eero Volotinen writes:
>> Hi List,
>>
>> Any success running 64bit javaplugin on centos 5.5 & firefox 3.6?
>>
>> For me it always complains about wrong elfclass64 ?
>
> *Check out these threads:
> *http://lists.centos.org/pipermail/centos/2010-November/101229.html
> *http://lists.centos.org/pipermail/centos/2010-November/101365.html
> *http://lists.centos.org/pipermail/centos/2010-November/101528.html
>
> *You're either running a 32-bit browser with the 64-bit plugin or
> *enountered a bug I described here
>
> *http://lists.centos.org/pipermail/centos/2010-November/101568.html

Looks like firefox is 32bit version, not 64bit version, but 32bit java
1.6.u23 still fails.

aboutlugins just says no plugins are installed. any clues?

--
Eero
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 02-10-2011, 04:33 PM
Mathieu Baudier
 
Default Centos 5.5 + firefox 3.6 and 64bit javaplugin (1.6u23)

> Looks like firefox is 32bit version, not 64bit version, but 32bit java
> 1.6.u23 still fails.

Where did you install Java from?
The Java browser plugin is not available in teh OpenJDK shipped with CentOS 5.5.
You need to install the JRE from Sun.

In this page:
http://wiki.centos.org/HowTos/JavaOnCentOS
the following tutorial is recommended:
http://www.trading-shim.org/faq/?java
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 02-10-2011, 08:06 PM
Keith Roberts
 
Default Centos 5.5 + firefox 3.6 and 64bit javaplugin (1.6u23)

On Thu, 10 Feb 2011, Eero Volotinen wrote:

> To: CentOS mailing list <centos@centos.org>
> From: Eero Volotinen <eero.volotinen@iki.fi>
> Subject: Re: [CentOS] Centos 5.5 + firefox 3.6 and 64bit javaplugin (1.6u23)

snip

> Looks like firefox is 32bit version, not 64bit version, but 32bit java
> 1.6.u23 still fails.
>
> aboutlugins just says no plugins are installed. any clues?

Yep

I had the same problem. It appears the name of the java
plugin has now changed. Also it lives in an obscure place.

In a nutshell - You need a symlink from your mozilla
plugins directory to the JAVA plugin file, which is now
called libnpjp2.so

[ajb@stxsl /usr/lib/mozilla/plugins]$

OLD JAVA PLUGIN:

lrwxrwxrwx 1 root root 54 May 24 15:36
libjavaplugin_oji.so ->
/usr/java/default/plugin/i386/ns7/libjavaplugin_oji.so


NEW JAVA PLUGIN:
lrwxrwxrwx 1 root root 38 May 24 15:57 libnpjp2.so ->
/usr/java/default/lib/i386/libnpjp2.so


Please see this forum link for all the gory details:
https://www.centos.org/modules/newbb/viewtopic.php?topic_id=27062&forum=38&post_id=1110 90#forumpost111090


Kind Regards,

Keith Roberts

-----------------------------------------------------------------
Websites:
http://www.karsites.net
http://www.php-debuggers.net
http://www.raised-from-the-dead.org.uk

All email addresses are challenge-response protected with
TMDA [http://tmda.net]
-----------------------------------------------------------------
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 02-11-2011, 01:50 AM
yonatan pingle
 
Default Centos 5.5 + firefox 3.6 and 64bit javaplugin (1.6u23)

Hey there!

the newer plugin should work with latest Firefox , just configure the
path correctly and you are set ,or use a symlink.

check out this fine article

http://koolinus.wordpress.com/2009/10/29/enable-java-plugin-on-firefox-with-centos-or-rhel-64bit/


what is your uname -a ? , maybe you have a repo that has it.





On Thu, Feb 10, 2011 at 11:06 PM, Keith Roberts <keith@karsites.net> wrote:
> On Thu, 10 Feb 2011, Eero Volotinen wrote:
>
>> To: CentOS mailing list <centos@centos.org>
>> From: Eero Volotinen <eero.volotinen@iki.fi>
>> Subject: Re: [CentOS] Centos 5.5 + firefox 3.6 and 64bit javaplugin (1.6u23)
>
> snip
>
>> Looks like firefox is 32bit version, not 64bit version, but 32bit java
>> 1.6.u23 still fails.
>>
>> aboutlugins just says no plugins are installed. any clues?
>
> Yep
>
> I had the same problem. It appears the name of the java
> plugin has now changed. Also it lives in an obscure place.
>
> In a nutshell - You need a symlink from your mozilla
> plugins directory to the JAVA plugin file, which is now
> called libnpjp2.so
>
> [ajb@stxsl /usr/lib/mozilla/plugins]$
>
> OLD JAVA PLUGIN:
>
> lrwxrwxrwx 1 root root * * 54 May 24 15:36
> libjavaplugin_oji.so ->
> /usr/java/default/plugin/i386/ns7/libjavaplugin_oji.so
>
>
> NEW JAVA PLUGIN:
> lrwxrwxrwx 1 root root * * 38 May 24 15:57 libnpjp2.so ->
> /usr/java/default/lib/i386/libnpjp2.so
>
>
> Please see this forum link for all the gory details:
> https://www.centos.org/modules/newbb/viewtopic.php?topic_id=27062&forum=38&post_id=1110 90#forumpost111090
>
>
> Kind Regards,
>
> Keith Roberts
>
> -----------------------------------------------------------------
> Websites:
> http://www.karsites.net
> http://www.php-debuggers.net
> http://www.raised-from-the-dead.org.uk
>
> All email addresses are challenge-response protected with
> TMDA [http://tmda.net]
> -----------------------------------------------------------------
> _______________________________________________
> CentOS mailing list
> CentOS@centos.org
> http://lists.centos.org/mailman/listinfo/centos
>



--
Best Regards,
Yonatan Pingle
RHCT | RHCSA | CCNA
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 

Thread Tools




All times are GMT. The time now is 12:26 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org