FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > CentOS > CentOS

 
 
LinkBack Thread Tools
 
Old 02-02-2011, 03:29 PM
John Doe
 
Default yum confusion...

Hi,

I just installed a new server and my final yum update fails...
I have rpmforge and rpmforge-extras, but with yum priorities...

# grep enabled /etc/yum/pluginconf.d/priorities.conf
enabled = 1

# cat /etc/yum.repos.d/CentOS-Base.repo | grep "priority|^["
[base]
priority=1
[updates]
priority=1
...

# yum clean all

# yum list | grep "tcp_wrappers|nfs-utils"
nfs-utils.x86_64 1:1.0.9-47.el5_5 installed
nfs-utils-lib.x86_64 1.0.8-7.6.el5 installed
tcp_wrappers.i386 7.6-40.7.el5 installed
tcp_wrappers.x86_64 7.6-40.7.el5 installed
nfs-utils-lib.i386 1.0.8-7.6.el5 base
nfs-utils-lib-devel.i386 1.0.8-7.6.el5 base
nfs-utils-lib-devel.x86_64 1.0.8-7.6.el5 base
tcp_wrappers-devel.x86_64 7.6-57.el5.rfx rpmforge-extras
tcp_wrappers-libs.x86_64 7.6-57.el5.rfx rpmforge-extras

# yum update
...
132 packages excluded due to repository priority protections
Setting up Update Process
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: tcp_wrappers for package: nfs-utils
--> Processing Dependency: tcp_wrappers for package: nfs-utils
---> Package tcp_wrappers-devel.x86_64 0:7.6-57.el5.rfx set to be updated
---> Package tcp_wrappers-libs.x86_64 0:7.6-57.el5.rfx set to be updated
--> Finished Dependency Resolution
1:nfs-utils-1.0.9-47.el5_5.x86_64 from installed has depsolving problems
--> Missing Dependency: tcp_wrappers is needed by package
1:nfs-utils-1.0.9-47.el5_5.x86_64 (installed)
Error: Missing Dependency: tcp_wrappers is needed by package
1:nfs-utils-1.0.9-47.el5_5.x86_64 (installed)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest

I removed tcp_wrappers.i386

# yum list | grep "tcp_wrappers|nfs-utils"
nfs-utils.x86_64 1:1.0.9-47.el5_5 installed
nfs-utils-lib.x86_64 1.0.8-7.6.el5 installed
tcp_wrappers.x86_64 7.6-40.7.el5 installed
nfs-utils-lib.i386 1.0.8-7.6.el5 base
nfs-utils-lib-devel.i386 1.0.8-7.6.el5 base
nfs-utils-lib-devel.x86_64 1.0.8-7.6.el5 base
tcp_wrappers.i386 7.6-40.7.el5 base
tcp_wrappers-devel.x86_64 7.6-57.el5.rfx
rpmforge-extras
tcp_wrappers-libs.x86_64 7.6-57.el5.rfx
rpmforge-extras

# yum update
...
132 packages excluded due to repository priority protections
Setting up Update Process
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: tcp_wrappers for package: nfs-utils
---> Package tcp_wrappers-devel.x86_64 0:7.6-57.el5.rfx set to be updated
---> Package tcp_wrappers-libs.x86_64 0:7.6-57.el5.rfx set to be updated
--> Running transaction check
---> Package tcp_wrappers.i386 0:7.6-40.7.el5 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================== ==================================================

Package Arch Version
Repository Size
================================================== ==================================================

Installing:
tcp_wrappers-devel x86_64 7.6-57.el5.rfx
rpmforge-extras 8.7 k
replacing tcp_wrappers.x86_64 7.6-40.7.el5
tcp_wrappers-libs x86_64 7.6-57.el5.rfx
rpmforge-extras 88 k
replacing tcp_wrappers.x86_64 7.6-40.7.el5
Installing for dependencies:
tcp_wrappers i386 7.6-40.7.el5
base 109 k

nfs-utils insists on reinstalling tcp_wrappers.i386, and priorities apparently
does not protect the CentOS packages...
If I disable rpmforge, I get "No Packages marked for Update", but still have "7
packages excluded due to repository priority protections"
If I also disable priorities, I just get "No Packages marked for Update"

# ll /etc/yum.repos.d/
total 28
-rw-r--r-- 1 root root 2412 Jan 27 14:38 CentOS-Base.repo
-rw-r--r-- 1 root root 626 Apr 26 2010 CentOS-Media.repo
-rw-r--r-- 1 root root 739 Nov 13 04:55 mirrors-rpmforge
-rw-r--r-- 1 root root 717 Nov 13 04:55 mirrors-rpmforge-extras
-rw-r--r-- 1 root root 728 Nov 13 04:55 mirrors-rpmforge-testing
-rw-r--r-- 1 root root 1113 Feb 2 17:15 rpmforge.repo

Any idea what is going on or how I can clean up this mess...?
Do you have to block all i386 packages?

Thx,
JD



_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 02-02-2011, 03:58 PM
Karanbir Singh
 
Default yum confusion...

On 02/02/2011 04:29 PM, John Doe wrote:
> # yum list | grep "tcp_wrappers|nfs-utils"
> nfs-utils.x86_64 1:1.0.9-47.el5_5 installed
> nfs-utils-lib.x86_64 1.0.8-7.6.el5 installed
> tcp_wrappers.i386 7.6-40.7.el5 installed
> tcp_wrappers.x86_64 7.6-40.7.el5 installed
> nfs-utils-lib.i386 1.0.8-7.6.el5 base
> nfs-utils-lib-devel.i386 1.0.8-7.6.el5 base
> nfs-utils-lib-devel.x86_64 1.0.8-7.6.el5 base
> tcp_wrappers-devel.x86_64 7.6-57.el5.rfx rpmforge-extras
> tcp_wrappers-libs.x86_64 7.6-57.el5.rfx rpmforge-extras
...
> Any idea what is going on or how I can clean up this mess...?
> Do you have to block all i386 packages?

I can guess that the rcp_weappers-libs and -devel are not being masked.
Try running yum with a -d7 and see if it clears up what is going on

- KB
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 02-02-2011, 03:59 PM
Nicolas Thierry-Mieg
 
Default yum confusion...

John Doe wrote:
> Hi,
>
> I just installed a new server and my final yum update fails...
> I have rpmforge and rpmforge-extras, but with yum priorities...
>
> # grep enabled /etc/yum/pluginconf.d/priorities.conf
> enabled = 1
>
> # cat /etc/yum.repos.d/CentOS-Base.repo | grep "priority|^["
> [base]
> priority=1
> [updates]
> priority=1

Du you have a priority=XX in rpmforge.repo ?

_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 02-03-2011, 04:38 AM
Nico Kadel-Garcia
 
Default yum confusion...

On Wed, Feb 2, 2011 at 11:58 AM, Karanbir Singh <mail-lists@karan.org> wrote:
> On 02/02/2011 04:29 PM, John Doe wrote:
>> # yum list | grep "tcp_wrappers|nfs-utils"
>> nfs-utils.x86_64 * * * * * * * 1:1.0.9-47.el5_5 * * * installed
>> nfs-utils-lib.x86_64 * * * * * 1.0.8-7.6.el5 * * * * *installed
>> tcp_wrappers.i386 * * * * * * *7.6-40.7.el5 * * * * * installed
>> tcp_wrappers.x86_64 * * * * * *7.6-40.7.el5 * * * * * installed
>> nfs-utils-lib.i386 * * * * * * 1.0.8-7.6.el5 * * * * *base
>> nfs-utils-lib-devel.i386 * * * 1.0.8-7.6.el5 * * * * *base
>> nfs-utils-lib-devel.x86_64 * * 1.0.8-7.6.el5 * * * * *base
>> tcp_wrappers-devel.x86_64 * * *7.6-57.el5.rfx * * * * rpmforge-extras
>> tcp_wrappers-libs.x86_64 * * * 7.6-57.el5.rfx * * * * rpmforge-extras
> ...
>> Any idea what is going on or how I can clean up this mess...?
>> Do you have to block all i386 packages?
>
> I can guess that the rcp_weappers-libs and -devel are not being masked.
> Try running yum with a -d7 and see if it clears up what is going on

The problem is probably that RPMforge's repository for x86_64 does not
include matching i386 components, even if the out-of-date components
for RHEL included both in the same repository. I ran into this
headlong with Subversion: My system kept trying to reach back for the
subverion.i386 and subversion-devel.i386 components, even though I 'd
only asked for "subverison".

One option is to exclude them in yum.conf. Another is to exclude them
in your CentOS yum files.
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 02-03-2011, 09:05 AM
John Doe
 
Default yum confusion...

From: Nicolas Thierry-Mieg <Nicolas.Thierry-Mieg@imag.fr>
> Du you have a priority=XX in rpmforge.repo ?

I have no priority in rpmforge.repo...

From: Karanbir Singh <mail-lists@karan.org>

> I can guess that the rcp_weappers-libs and -devel are not being masked.
> Try running yum with a -d7 and see if it clears up what is going on

...
Resolving Dependencies
--> Running transaction check
Checking deps for tcp_wrappers.x86_64 0-7.6-40.7.el5 - None
1:nfs-utils-1.0.9-47.el5_5.x86_64 requires: tcp_wrappers
--> Processing Dependency: tcp_wrappers for package: nfs-utils
Potential Provider: tcp_wrappers.x86_64 0:7.6-40.7.el5
Mode is u for provider of tcp_wrappers: tcp_wrappers.x86_64 0:7.6-40.7.el5
Mode for pkg providing tcp_wrappers: u
Cannot find an update path for dep for: tcp_wrappers
Searching pkgSack for dep: tcp_wrappers
Potential match for tcp_wrappers from tcp_wrappers-7.6-40.7.el5.x86_64
Matched tcp_wrappers-7.6-40.7.el5.x86_64 to require for tcp_wrappers
Potential match for tcp_wrappers from tcp_wrappers-7.6-40.7.el5.i386
Matched tcp_wrappers-7.6-40.7.el5.i386 to require for tcp_wrappers
tcp_wrappers-7.6-40.7.el5.x86_64 is in providing packages but it is already
installed, removing.
Package: tcp_wrappers-libs-7.6-57.el5.rfx.x86_64 - already in transaction set
Package: tcp_wrappers-devel-7.6-57.el5.rfx.x86_64 - already in transaction set
TSINFO: Marking tcp_wrappers-7.6-40.7.el5.i386 as install for
1:nfs-utils-1.0.9-47.el5_5.x86_64
---> Package tcp_wrappers-devel.x86_64 0:7.6-57.el5.rfx set to be updated
Checking deps for tcp_wrappers-devel.x86_64 0-7.6-57.el5.rfx - u
looking for ('tcp_wrappers-libs', 'EQ', ('0', '7.6', '57.el5.rfx')) as a
requirement of tcp_wrappers-devel.x86_64 0-7.6-57.el5.rfx - u
looking for ('libwrap.so.0()(64bit)', None, (None, None, None)) as a requirement
of tcp_wrappers-devel.x86_64 0-7.6-57.el5.rfx - u
---> Package tcp_wrappers-libs.x86_64 0:7.6-57.el5.rfx set to be updated
Checking deps for tcp_wrappers-libs.x86_64 0-7.6-57.el5.rfx - u
looking for ('libnsl.so.1(GLIBC_2.2.5)(64bit)', None, (None, None, None)) as a
requirement of tcp_wrappers-libs.x86_64 0-7.6-57.el5.rfx - u
looking for ('libc.so.6(GLIBC_2.4)(64bit)', None, (None, None, None)) as a
requirement of tcp_wrappers-libs.x86_64 0-7.6-57.el5.rfx - u
looking for ('libc.so.6(GLIBC_2.3.4)(64bit)', None, (None, None, None)) as a
requirement of tcp_wrappers-libs.x86_64 0-7.6-57.el5.rfx - u
looking for ('libc.so.6(GLIBC_2.2.5)(64bit)', None, (None, None, None)) as a
requirement of tcp_wrappers-libs.x86_64 0-7.6-57.el5.rfx - u
looking for ('rtld(GNU_HASH)', None, (None, None, None)) as a requirement of
tcp_wrappers-libs.x86_64 0-7.6-57.el5.rfx - u
looking for ('libc.so.6(GLIBC_2.3)(64bit)', None, (None, None, None)) as a
requirement of tcp_wrappers-libs.x86_64 0-7.6-57.el5.rfx - u
looking for ('/sbin/ldconfig', None, (None, None, None)) as a requirement of
tcp_wrappers-libs.x86_64 0-7.6-57.el5.rfx - u
looking for ('libnsl.so.1()(64bit)', None, (None, None, None)) as a requirement
of tcp_wrappers-libs.x86_64 0-7.6-57.el5.rfx - u
looking for ('libc.so.6()(64bit)', None, (None, None, None)) as a requirement of
tcp_wrappers-libs.x86_64 0-7.6-57.el5.rfx - u
--> Running transaction check
---> Package tcp_wrappers.i386 0:7.6-40.7.el5 set to be updated
Checking deps for tcp_wrappers.i386 0-7.6-40.7.el5 - u
looking for ('libc.so.6(GLIBC_2.3.4)', None, (None, None, None)) as a
requirement of tcp_wrappers.i386 0-7.6-40.7.el5 - u
looking for ('libc.so.6(GLIBC_2.4)', None, (None, None, None)) as a requirement
of tcp_wrappers.i386 0-7.6-40.7.el5 - u
looking for ('libc.so.6', None, (None, None, None)) as a requirement of
tcp_wrappers.i386 0-7.6-40.7.el5 - u
looking for ('/sbin/ldconfig', None, (None, None, None)) as a requirement of
tcp_wrappers.i386 0-7.6-40.7.el5 - u
looking for ('libc.so.6(GLIBC_2.1)', None, (None, None, None)) as a requirement
of tcp_wrappers.i386 0-7.6-40.7.el5 - u
looking for ('rtld(GNU_HASH)', None, (None, None, None)) as a requirement of
tcp_wrappers.i386 0-7.6-40.7.el5 - u
looking for ('libc.so.6(GLIBC_2.1.3)', None, (None, None, None)) as a
requirement of tcp_wrappers.i386 0-7.6-40.7.el5 - u
looking for ('libnsl.so.1', None, (None, None, None)) as a requirement of
tcp_wrappers.i386 0-7.6-40.7.el5 - u
looking for ('libc.so.6(GLIBC_2.0)', None, (None, None, None)) as a requirement
of tcp_wrappers.i386 0-7.6-40.7.el5 - u
looking for ('libc.so.6(GLIBC_2.3)', None, (None, None, None)) as a requirement
of tcp_wrappers.i386 0-7.6-40.7.el5 - u
looking for ('libnsl.so.1(GLIBC_2.0)', None, (None, None, None)) as a
requirement of tcp_wrappers.i386 0-7.6-40.7.el5 - u
--> Finished Dependency Resolution
Dependency Process ending
Depsolve time: 0.975

Dependencies Resolved

================================================== ==================================================

Package Arch Version
Repository Size
================================================== ==================================================

Installing:
tcp_wrappers-devel x86_64 7.6-57.el5.rfx
rpmforge-extras 8.7 k
replacing tcp_wrappers.x86_64 7.6-40.7.el5

tcp_wrappers-libs x86_64 7.6-57.el5.rfx
rpmforge-extras 88 k
replacing tcp_wrappers.x86_64 7.6-40.7.el5

Installing for dependencies:
tcp_wrappers i386 7.6-40.7.el5
base 109 k

Transaction Summary
================================================== ==================================================

Install 3 Package(s)
Upgrade 0 Package(s)


So apparently priorities would still let through some updates?
I did deactivate priorities once just to update subversion with rpmforge-extra
1.6 version...

# yum list | grep installed | grep '.rf'
compat-libevent-11a.x86_64 3.2.1-1.el5.rf installed
djvulibre.x86_64 3.5.22-1.el5.rf installed
exiv2.x86_64 0.20-1.el5.rf installed
fping.x86_64 2.4-1.b2.3.el5.rf installed
gsm.i386 1.0.13-1.el5.rf installed
jasper.x86_64 1.900.1-2.el5.rf installed
lame.x86_64 3.98.4-1.el5.rf installed
libmhash.x86_64 0.9.1-1.2.el5.rf installed
libmhash-devel.x86_64 0.9.1-1.2.el5.rf installed
memcached.x86_64 1.4.5-1.el5.rf installed
nagios-nrpe.x86_64 2.12-1.el5.rf installed
nagios-plugins.x86_64 1.4.15-2.el5.rf installed
perl-AnyEvent.noarch 5.240-1.el5.rf installed
perl-Compress-Raw-Bzip2.x86_64 2.031-1.el5.rf installed
perl-Compress-Raw-Zlib.x86_64 2.030-1.el5.rf installed
perl-Crypt-DES.x86_64 2.05-3.2.el5.rf installed
perl-EV.x86_64 3.9-1.el5.rf installed
perl-Guard.x86_64 1.021-1.el5.rf installed
perl-IO-Compress.noarch 2.030-2.el5.rfx installed
perl-JSON.noarch 2.17-1.el5.rf installed
perl-JSON-XS.x86_64 2.27-1.el5.rf installed
perl-Net-SNMP.noarch 5.2.0-1.2.el5.rf installed
perl-Net-SSLeay.x86_64 1.36-1.el5.rfx installed
perl-TermReadKey.x86_64 2.30-3.el5.rf installed
perl-YAML.noarch 0.71-1.el5.rf installed
perl-common-sense.x86_64 3.0-1.el5.rf installed
rpmforge-release.x86_64 0.5.2-2.el5.rf installed
subversion.x86_64 1.6.15-0.1.el5.rfx installed
xdg-utils.noarch 1.0.2-2.el5.rf installed


Thx,
JD



_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 02-04-2011, 09:07 AM
John Doe
 
Default yum confusion...

Solved by adding 'check_obsoletes=1' to the priorities.conf..


JD



_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 02-04-2011, 12:31 PM
Kai Schaetzl
 
Default yum confusion...

John Doe wrote on Fri, 4 Feb 2011 02:07:59 -0800 (PST):

> Solved by adding 'check_obsoletes=1' to the priorities.conf..

Ah, well, I have it in my kickstarts :-) It's a pity it doesn't get set
when installing the priorities plugin.

Kai


_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 

Thread Tools




All times are GMT. The time now is 07:08 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org