FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > CentOS > CentOS

 
 
LinkBack Thread Tools
 
Old 12-14-2010, 10:46 AM
Lanny Marcus
 
Default {SOLVED} Yum Updates dependencies missing (rpmforge)

On Sun, Dec 5, 2010 at 8:43 AM, Lanny Marcus <lmmailinglists@gmail.com> wrote:
> There are updates available, for the below multimedia packages (CentOS
> 5.5, 32 bit), but I'm getting missing dependency errors from yum
> update for these.
<snip>
>From the time the problem began, it had to do with

Error: Missing Dependency: libx264.so.68 is needed by package
cinelerra-2.1-0.15.20070108.el5.rf.i386 (installed)

However, cinelerra was *never* one of the packages set to be updated.
It always hung, on the Missing Dependency: libx264.so.68 for
cinelerra

I am not using cinelerra at this time, so I removed it this morning:

cinelerra.i386 0:2.1-0.15.20070108.el5.rf

After that, I was able to yum update the box, with no issues.

There is probably a much more proper way to have gotten around this
issue, but this box is fully updated again. Thanks to everyone who
replied in this thread!
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 12-14-2010, 04:03 PM
Bart Schaefer
 
Default {SOLVED} Yum Updates dependencies missing (rpmforge)

On Tue, Dec 14, 2010 at 3:46 AM, Lanny Marcus <lmmailinglists@gmail.com> wrote:
> From the time the problem began, it had to do with
>
> Error: Missing Dependency: libx264.so.68 is needed by package
> cinelerra-2.1-0.15.20070108.el5.rf.i386 (installed)
>
> However, cinelerra was *never* one of the packages set to be updated.

The problem may be that libx264 was set to be updated, but could not
be because installed package cinelerra had an absolute dependency on
an older version (rather than an "at least" dependency).

> I am not using cinelerra at this time, so I removed it this morning:
>
> cinelerra.i386 0:2.1-0.15.20070108.el5.rf
>
> After that, I was able to yum update the box, with no issues.

I seem to recall having to drop several packages that depended on a
specific libx264 version a while ago, but I no longer remember which
ones (lua related, possibly?).
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 12-15-2010, 01:51 PM
Lanny Marcus
 
Default {SOLVED} Yum Updates dependencies missing (rpmforge)

On Tue, Dec 14, 2010 at 12:03 PM, Bart Schaefer
<barton.schaefer@gmail.com> wrote:
> On Tue, Dec 14, 2010 at 3:46 AM, Lanny Marcus <lmmailinglists@gmail.com> wrote:
>> From the time the problem began, it had to do with
>>
>> Error: Missing Dependency: libx264.so.68 is needed by package
>> cinelerra-2.1-0.15.20070108.el5.rf.i386 (installed)
>>
>> However, cinelerra was *never* one of the packages set to be updated.
>
> The problem may be that libx264 was set to be updated, but could not
> be because installed package cinelerra had an absolute dependency on
> an older version (rather than an "at least" dependency).
<snip>
> I seem to recall having to drop several packages that depended on a
> specific libx264 version a while ago, but I no longer remember which
> ones (lua related, possibly?).

Bart: Thank you for the explanation! That's probably what happened. Lanny
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 

Thread Tools




All times are GMT. The time now is 03:17 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org