FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > CentOS > CentOS

 
 
LinkBack Thread Tools
 
Old 06-28-2010, 06:30 PM
Karanbir Singh
 
Default Upgrading MySQL

On 28/06/2010 18:21, Susan Day wrote:
> Hi;
> I'm trying to install django and got this error:
>
> django.core.exceptions.ImproperlyConfigured: MySQLdb-1.2.1p2 or newer is
> required; you have 1.2.1
>
> So then I tried yum upgrade mysql and got this:

You should go and talk about this in the django lists, you clearly need
very basic help.

Also, that message indicates you need a newer MySQL-python package, not
mysql. Have you considered starting with a very basic tutorial on django
and python first ? Getting some of the concepts right, early on, will
help make sure you go a lot further.

- KB
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 06-28-2010, 07:59 PM
Jakub Jedelský
 
Default Upgrading MySQL

2010/6/28 Susan Day <suzieprogrammer@gmail.com>

Hi;
I'm trying to install django and got this error:

django.core.exceptions.ImproperlyConfigured: MySQLdb-1.2.1p2 or newer is required; you have 1.2.1

So then I tried yum upgrade mysql and got this:



No Packages marked for Update

Please advise.
TIA,
Susan


_______________________________________________

CentOS mailing list

CentOS@centos.org

http://lists.centos.org/mailman/listinfo/centos




Hi,

you can use package MySQL-python from CentOS Testing repo - there is newer version (1.2.2) which works ok. I'm using it without any problems
--
Jakub Jedelský

e-mail: jakub.jedelsky@gmail.com

_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 06-28-2010, 09:15 PM
Meenoo Shivdasani
 
Default Upgrading MySQL

> django.core.exceptions.ImproperlyConfigured: MySQLdb-1.2.1p2 or newer is
> required; you have 1.2.1

To identify what package contains a specific file, you can use yum search.

For example:

yum search MySQLdb

returns

MySQL-python.x86_64 : An interface to MySQL

therefore MySQLdb can be updated by updating MySQL-python.

M
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 10-28-2011, 05:48 PM
Jack Fredrikson
 
Default Upgrading MySQL

Hi;
Upon trying to run django, I get this error:

ImproperlyConfigured: MySQLdb-1.2.1p2 or newer is required; you have 1.2.1

If I run yum update mysql I don't upgrade (expected). What do?
TIA,
Jack
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 10-31-2011, 11:47 AM
John Doe
 
Default Upgrading MySQL

From: Jack Fredrikson <jackfredrikson@yahoo.com>
> Upon trying to run django, I get this error:
> ImproperlyConfigured: MySQLdb-1.2.1p2 or newer is required; you have 1.2.1
> If I run yum update mysql I don't upgrade (expected). What do?

Why are you trying to update mysql when the error says 'MySQLdb'?
Check also the version... mysql is 5.x; not 1.x.
# yum whatprovides */MySQLdb
...
MySQL-python-1.2.1... on CentOS 5
MySQL-python-1.2.3... on CentOS 6.

How did you install django?
There are django packages from repoforge and elrepo...

JD
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 

Thread Tools




All times are GMT. The time now is 09:31 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org