Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   CentOS (http://www.linux-archive.org/centos/)
-   -   problems building nfdump / nfsen (http://www.linux-archive.org/centos/385661-problems-building-nfdump-nfsen.html)

Alan McKay 06-14-2010 02:45 PM

problems building nfdump / nfsen
 
Hey folks, I posted this as part of another old thread but am starting
a new thread for it because I got no response. I've also since found
the nfdump mailing list but it seems to be dead. I was not able to
find either of these guys in a CentOS repository anywhere, so I'm
building them manually. Below was on CentOS 5.2.

---snip---

I'm going to kick this old thread because I'm just getting around to
nfdump and nfsen myself, and am having trouble building nfsen. I do
not see a mailing list for it so I'll try here first.

I am using softflowd to pump netflow information from various linux
boxes into a central collector. The collector is running nfcapd to
capture everything. And I also want to run nfsen on this box to be
able to view the pretty graphs on the web :-) I have verified with
nfdump built on this box that the collector seems to be working fine -
so far so good.

Then when trying to build nfsen it complained about nfprofile not
being there - so some googling later and I found that I have to go
back and rebuild nfdump to include it.

So I do :
./configure --enable-nfprofile
which dies thus :
[...]
checking for stdint.h... yes
checking for unistd.h... yes
checking for rrd_update in -lrrd... no
configure: error: Can not link librrd. Please specify
--with-rrdpath=.. configure failed!

But I check and I see I have librrd installed.

[root@rcadmin:~/nf/nfdump-1.6.1]# rpm -qa | grep -i rrd
perl-rrdtool-1.3.7-1.el5.rf
rrdtool-1.3.7-1.el5.rf
[root@rcadmin:~/nf/nfdump-1.6.1]# ls -al /usr/lib/librrd*
-rw-r--r-- 1 root root 321930 May 23 2009 /usr/lib/librrd.a
lrwxrwxrwx 1 root root 15 Jun 3 2009 /usr/lib/librrd.so.4 ->
librrd.so.4.0.6
-rwxr-xr-x 1 root root 493565 May 23 2009 /usr/lib/librrd.so.4.0.6
-rw-r--r-- 1 root root 319096 May 23 2009 /usr/lib/librrd_th.a
lrwxrwxrwx 1 root root 18 Jun 3 2009 /usr/lib/librrd_th.so.4 ->
librrd_th.so.4.0.6
-rwxr-xr-x 1 root root 488881 May 23 2009 /usr/lib/librrd_th.so.4.0.6

And I do not seem to be able to tell configure how to find it.
These all fail :
./configure --enable-nfprofile --with-rrdpath=/usr/lib
./configure --enable-nfprofile --with-rrdpath=/usr
./configure --enable-nfprofile --with-rrdpath=..
./configure --enable-nfprofile --with-rrdpath=/usr/lib/librrd.so.4
./configure --enable-nfprofile --with-rrdpath=/usr/lib/librrd.a

What am I doing wrong?


[root@rcadmin:~/nf/nfdump-1.6.1]# cat /etc/redhat-release
CentOS release 5.2 (Final)

--
“Don't eat anything you've ever seen advertised on TV”
- Michael Pollan, author of "In Defense of Food"
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos

Tim Shubitz 06-14-2010 02:58 PM

problems building nfdump / nfsen
 
On Jun 14, 2010, at 9:45 AM, Alan McKay wrote:

> And I do not seem to be able to tell configure how to find it.
> These all fail :
> ./configure --enable-nfprofile --with-rrdpath=/usr/lib
> ./configure --enable-nfprofile --with-rrdpath=/usr
> ./configure --enable-nfprofile --with-rrdpath=..
> ./configure --enable-nfprofile --with-rrdpath=/usr/lib/librrd.so.4
> ./configure --enable-nfprofile --with-rrdpath=/usr/lib/librrd.a
>
> What am I doing wrong?


I had this same problem. Drove me nuts.

The issue (for me anyway) was that the RRD development libraries weren't installed.

Give this a whirl then re-run 'configure'.

sudo yum install rrdtool-devel


- tim


_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos

Alan McKay 06-14-2010 05:05 PM

problems building nfdump / nfsen
 
THanks for the quick response - I think i tried that early on just out
of habit (always try something with -devel ending) but it did not find
anything so I figured there was no such thing. But sounds like I just
have to figure out what repo I'm missing.

[root@rcadmin:~]# yum --enablerepo=* -y install rrdtool-devel
centosplus 100% |=========================| 1.9 kB 00:00
primary.sqlite.bz2 100% |=========================| 203 kB 00:01
Setting up Install Process
Parsing package install arguments
No package rrdtool-devel available.
Nothing to do
[root@rcadmin:~]#





--
“Don't eat anything you've ever seen advertised on TV”
- Michael Pollan, author of "In Defense of Food"
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos


All times are GMT. The time now is 03:59 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.