FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > CentOS > CentOS

 
 
LinkBack Thread Tools
 
Old 05-11-2010, 11:22 PM
a arias
 
Default ldconfig: /usr/lib64/libfreebl3.so is not a symbolic link

I have been getting the following error when trying to run ldconfig:
ldconfig: /usr/lib64/libfreebl3.so is not a symbolic link

# ll /usr/lib64/libfreebl3.so
-rwxr-xr-x 1 root root 312336 Mar 28 11:13 /usr/lib64/libfreebl3.so
I've used "yum whatprovides /usr/lib64/libfreeb13.so" to determine that this file belongs to nss. I have tried to reinstall nss but that does not fix the problem.

Any ideas? How can I fix this?

_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 05-11-2010, 11:39 PM
Dominik Zyla
 
Default ldconfig: /usr/lib64/libfreebl3.so is not a symbolic link

On Tue, May 11, 2010 at 07:22:05PM -0400, a arias wrote:
> I have been getting the following error when trying to run ldconfig:
>
>
> ldconfig: /usr/lib64/libfreebl3.so is not a symbolic link
>
>
> # ll /usr/lib64/libfreebl3.so
>
> -rwxr-xr-x 1 root root 312336 Mar 28 11:13 /usr/lib64/libfreebl3.so
>
>
> I've used "yum whatprovides /usr/lib64/libfreeb13.so" to determine that this
> file belongs to nss. I have tried to reinstall nss but that does not fix the
> problem.
>
> Any ideas? How can I fix this?

Try to reinstall glibc.

--
Dominik Zyla

_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 05-12-2010, 12:12 AM
Dominik Zyla
 
Default ldconfig: /usr/lib64/libfreebl3.so is not a symbolic link

On Tue, May 11, 2010 at 07:50:05PM -0400, a arias wrote:
> That did not work. It fact, i got the following message during the yum
> reinstall process:
>
> /sbin/ldconfig: /usr/lib64/libfreebl3.so is not a symbolic link

According to `yum deplist glibc-2.5-42.el5_4.3.x86_64' you may also try
with reinstalling `libgcc' and `glibc-common'.

--
Dominik Zyla

_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 05-12-2010, 05:28 PM
Gordon Messmer
 
Default ldconfig: /usr/lib64/libfreebl3.so is not a symbolic link

On 05/11/2010 07:09 PM, a arias wrote:
>
> I wonder if I am the only one who is experiencing this. What could
> have caused this?
>

Look for other files that would otherwise be the targets of a symlink:

# ls /usr/lib64/libfreebl3*

It's normal for /usr/lib64/libfreebl3.so to not be a symlink. It
shouldn't be a problem unless ldconfig locates another file which it
will try to use as the target of a symlink.

Once you locate the other file, you can either remove the package that
provides it (or remove the file if there is no such package) or ignore
the error.

_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 

Thread Tools




All times are GMT. The time now is 08:30 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org