FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > CentOS > CentOS

 
 
LinkBack Thread Tools
 
Old 05-05-2010, 07:14 AM
John R Pierce
 
Default compile httpd 2.3.5 error

Chaitanya Yanamadala wrote:
> hai
> i need to upgrade my apache to 2.3.5 and what i need is to compile it
> out by myself not to use the rpm.. so where i am stuck is that i
> require to have the apr 1.3 but i got the 1.2.7 with me, so i have
> downloaded the apr-1.3 rpm but now when i am upgrading it out i am
> getting an error of dependencies problem like this.Can any one help me
> on this..
>
>
> uname(release) >= 2.6 is needed by apr-1.3.3-1.i586
> rpmlib(PayloadIsLzma) <= 4.4.6-1 is needed by apr-1.3.3-1.i586
> apr = 1.2.7-11.el5_3.1 is needed by (installed)
> apr-devel-1.2.7-11.el5_3.1.i386

compile your apache and any dependencies to run in a non-standard path,
like /opt/myapache/... or /usr/local/...

anything else will raise major havoc with the structure of your base
OS. this apr-1.3.rpm you installed, what OS is it targeted at? el5
uses apr 1.2.7


_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 05-05-2010, 11:24 AM
Jim Perrin
 
Default compile httpd 2.3.5 error

On Wed, May 5, 2010 at 3:01 AM, Chaitanya Yanamadala
<dr.virus.india@gmail.com> wrote:
> hai
> *i need to upgrade my apache to 2.3.5 and what i need is to compile it out
> by myself not to use the rpm.. so where i am stuck is that i require to have
> the apr 1.3 but i got the 1.2.7 with me, so i have downloaded the apr-1.3
> rpm but now when i am upgrading it out i am getting an error of dependencies
> problem like this.Can any one help me on this..


Why do you need to update to a development release?
Where did you get the apr-1.3 rpm? Is this an rpm for centos or for
some other distro?


> *uname(release) >= 2.6 is needed by apr-1.3.3-1.i586
> *rpmlib(PayloadIsLzma) <= 4.4.6-1 is needed by apr-1.3.3-1.i586
> *apr = 1.2.7-11.el5_3.1 is needed by (installed)
> apr-devel-1.2.7-11.el5_3.1.i386



--
During times of universal deceit, telling the truth becomes a revolutionary act.
George Orwell
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 

Thread Tools




All times are GMT. The time now is 04:30 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org