FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > CentOS > CentOS

 
 
LinkBack Thread Tools
 
Old 05-02-2010, 02:00 AM
Les Mikesell
 
Default Sendmail Configuration Problem - 550 5.1.1 - User unknown Problem

Wang, Mary Y wrote:
> Hi,
> I'm having this Sendmail configuration problem and stuck. I've been doing googling/reading posts and none of the solutions matched my problem.
> I'm doing some testing, and have been getting this 550 5.1.1 ....User unknown error when I send the email to my company's email address. When I send it to an external email address, such as yahoo, the message delivered successfully. Of course, I'm doing the configuration behind a firewall. I'm using a relay too, and I did declare the relay host in 'SMART_HOST' in the sendmail.mc file and have also recompiled it to produce the sendmail.cf. I also restarted the sendmail service.
> ----------------------------------------------------------------------------------------------------------------------------------------------------
> telnet ana.boeing.com 25
> Trying 134.51.151.114...
> Connected to ana.boeing.com (134.51.151.114).
> Escape character is '^]'.
> 220 ana.boeing.com ESMTP Sendmail 8.12.11.20060308/8.12.11; Sat, 1 May 2010 16:39:06 -0700
> helo ana.boeing.com
> 250 ana.boeing.com Hello ana.boeing.com [134.51.151.114], pleased to meet you
> mail from:root@ana.boeing.com
> 250 2.1.0 root@ana.boeing.com... Sender ok
> rcpt to:mary.y.wang@boeing.com
> 550 5.1.1 mary.y.wang@boeing.com... User unknown
>
> Any ideas? I'm running on Sendmail 8.12.11
>

Is ana.boeing.com your machine, the relay, or the target MX receiver? Whatever
it is, it thinks it should be able to deliver mail to boeing.com locally, but
doesn't have a mary.y.wang user or alias.

--
Les Mikesell
lesmikesell@gmail.com
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 05-02-2010, 03:06 AM
"Wang, Mary Y"
 
Default Sendmail Configuration Problem - 550 5.1.1 - User unknown Problem

It's working now. I just commented out some of the FEATURE lines in sendmail.mc file.
Mary


_____________________________________________
From: Wang, Mary Y
Sent: Saturday, May 01, 2010 6:21 PM
To: 'centos@centos.org'
Subject: Sendmail Configuration Problem - 550 5.1.1 - User unknown Problem

Hi,
I'm having this Sendmail configuration problem and stuck. I've been doing googling/reading posts and none of the solutions matched my problem.
I'm doing some testing, and have been getting this 550 5.1.1 ....User unknown error when I send the email to my company's email address. When I send it to an external email address, such as yahoo, the message delivered successfully. Of course, I'm doing the configuration behind a firewall. I'm using a relay too, and I did declare the relay host in 'SMART_HOST' in the sendmail.mc file and have also recompiled it to produce the sendmail.cf. I also restarted the sendmail service.
----------------------------------------------------------------------------------------------------------------------------------------------------
telnet ana.boeing.com 25
Trying 134.51.151.114...
Connected to ana.boeing.com (134.51.151.114).
Escape character is '^]'.
220 ana.boeing.com ESMTP Sendmail 8.12.11.20060308/8.12.11; Sat, 1 May 2010 16:39:06 -0700
helo ana.boeing.com
250 ana.boeing.com Hello ana.boeing.com [134.51.151.114], pleased to meet you
mail from:root@ana.boeing.com
250 2.1.0 root@ana.boeing.com... Sender ok
rcpt to:mary.y.wang@boeing.com
550 5.1.1 mary.y.wang@boeing.com... User unknown

Any ideas? I'm running on Sendmail 8.12.11

Mary



_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 05-03-2010, 12:32 AM
Jobst Schmalenbach
 
Default Sendmail Configuration Problem - 550 5.1.1 - User unknown Problem

On Sat, May 01, 2010 at 08:06:05PM -0700, Wang, Mary Y (mary.y.wang@boeing.com) wrote:
> It's working now. I just commented out some of the FEATURE lines in sendmail.mc file.
> Mary

I hope you know what you are doing coz commenting out "feature lines" (randomly)
"just" to get sendmail "working" is not a good idea ... for example I would not
comment out these:

FEATURE(delay_checks,friend)
FEATURE(`dnsbl',`zen.spamhaus.org',`go away spammer')
FEATURE(`no_default_msa',`dnl')dnl
FEATURE(`smrsh',`/usr/sbin/smrsh')dnl
FEATURE(`virtusertable',`hash /etc/mail/virtusertable')dnl
FEATURE(redirect)dnl
FEATURE(always_add_domain)
FEATURE(use_cw_file)
FEATURE(use_ct_file)
FEATURE(local_procmail,`',`procmail -t -Y -a $h -d $u')dnl
FEATURE(`access_db',`hash -T<TMPF> /etc/mail/access.db')dnl
FEATURE(`greet_pause',5000)
FEATURE(blacklist_recipients)
FEATURE(masquerade_envelope)dnl
FEATURE(masquerade_entire_domain)dnl
FEATURE(allmasquerade)

But I comment out (and highly recommend that) these:

dnl FEATURE(`accept_unresolvable_domains')dnl
dnl FEATURE(`relay_based_on_MX')dnl


So I assume the SMART_HOST is your ISP's mailserver?
When you send an email "internally" what is the error in the sendmail maillog (as your mailserver becomes the recipient)?


Jobst




>
>
> _____________________________________________
> From: Wang, Mary Y
> Sent: Saturday, May 01, 2010 6:21 PM
> To: 'centos@centos.org'
> Subject: Sendmail Configuration Problem - 550 5.1.1 - User unknown Problem
>
> Hi,
> I'm having this Sendmail configuration problem and stuck. I've been doing googling/reading posts and none of the solutions matched my problem.
> I'm doing some testing, and have been getting this 550 5.1.1 ....User unknown error when I send the email to my company's email address. When I send it to an external email address, such as yahoo, the message delivered successfully. Of course, I'm doing the configuration behind a firewall. I'm using a relay too, and I did declare the relay host in 'SMART_HOST' in the sendmail.mc file and have also recompiled it to produce the sendmail.cf. I also restarted the sendmail service.
> ----------------------------------------------------------------------------------------------------------------------------------------------------
> telnet ana.boeing.com 25
> Trying 134.51.151.114...
> Connected to ana.boeing.com (134.51.151.114).
> Escape character is '^]'.
> 220 ana.boeing.com ESMTP Sendmail 8.12.11.20060308/8.12.11; Sat, 1 May 2010 16:39:06 -0700
> helo ana.boeing.com
> 250 ana.boeing.com Hello ana.boeing.com [134.51.151.114], pleased to meet you
> mail from:root@ana.boeing.com
> 250 2.1.0 root@ana.boeing.com... Sender ok
> rcpt to:mary.y.wang@boeing.com
> 550 5.1.1 mary.y.wang@boeing.com... User unknown
>
> Any ideas? I'm running on Sendmail 8.12.11
>
> Mary
>
>
>
> _______________________________________________
> CentOS mailing list
> CentOS@centos.org
> http://lists.centos.org/mailman/listinfo/centos

--
The future isn't what it used to be (it never was).

| |0| | Jobst Schmalenbach, jobst@barrett.com.au, General Manager
| | |0| Barrett Consulting Group P/L & The Meditation Room P/L
|0|0|0| +61 3 9532 7677, POBox 277, Caulfield South, 3162, Australia
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 

Thread Tools




All times are GMT. The time now is 06:54 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org