FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > CentOS > CentOS

 
 
LinkBack Thread Tools
 
Old 03-04-2010, 06:00 PM
Sean Carolan
 
Default Permissions problem

What am I doing wrong here? I need to be able to write to /var/cvs.
This used to work before I moved these groups into an LDAP directory
instead of /etc/group:

[scarolan@watcher:/var/cvs]$ touch test.txt
touch: cannot touch `test.txt': Permission denied

[scarolan@watcher:/var/cvs]$ ls -ld
drwxrwsr-x 4 cvs cvsgrp 4096 May 18 2008 .

[scarolan@watcher:/var/cvs]$ id scarolan
uid=4002(scarolan) gid=4002(scarolan)
groups=10000(operations),10001(cvsgrp),4002(scarol an)
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 03-04-2010, 06:15 PM
"Marko A. Jennings"
 
Default Permissions problem

On Thu, March 4, 2010 2:00 pm, Sean Carolan wrote:
> What am I doing wrong here? I need to be able to write to /var/cvs.
> This used to work before I moved these groups into an LDAP directory
> instead of /etc/group:
>
> [scarolan@watcher:/var/cvs]$ touch test.txt
> touch: cannot touch `test.txt': Permission denied
>
> [scarolan@watcher:/var/cvs]$ ls -ld
> drwxrwsr-x 4 cvs cvsgrp 4096 May 18 2008 .
>
> [scarolan@watcher:/var/cvs]$ id scarolan
> uid=4002(scarolan) gid=4002(scarolan)
> groups=10000(operations),10001(cvsgrp),4002(scarol an)

One possibility is that test.txt already exists in that directory and that
the group cvsgrp does not have write permissions to it.

What is the output of 'ls -l /var/cvs/test.txt' ?

Marko
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 03-04-2010, 06:24 PM
Sean Carolan
 
Default Permissions problem

> What is the output of 'ls -l /var/cvs/test.txt' ?
>
> Marko

No, it doesn't exist. Oddly I have another user called "cfmaster" who
can write files in there just fine:

[cfmaster@watcher cvs]$ pwd
/var/cvs
[cfmaster@watcher cvs]$ touch test.txt
[cfmaster@watcher cvs]$ id cfmaster
uid=5101(cfmaster) gid=10001(cvsgrp) groups=10001(cvsgrp)
[cfmaster@watcher cvs]$ ls -l test.txt
-rw-r--r-- 1 cfmaster cvsgrp 0 Mar 4 13:24 test.txt
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 03-04-2010, 06:32 PM
Benjamin Donnachie
 
Default Permissions problem

On 4 March 2010 19:24, Sean Carolan <scarolan@gmail.com> wrote:
> No, it doesn't exist. *Oddly I have another user called "cfmaster" who
> can write files in there just fine:

When was the user scarolan added to the cvsgrp group? Have you logged
out and back in since?

Ben
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 03-04-2010, 06:52 PM
Kwan Lowe
 
Default Permissions problem

On Thu, Mar 4, 2010 at 2:00 PM, Sean Carolan <scarolan@gmail.com> wrote:
> What am I doing wrong here? *I need to be able to write to /var/cvs.
> This used to work before I moved these groups into an LDAP directory
> instead of /etc/group:

You might want to check that the cvsgrp group ID in /etc/group matches
the one in LDAP.
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 03-04-2010, 07:46 PM
Craig White
 
Default Permissions problem

On Thu, 2010-03-04 at 14:52 -0500, Kwan Lowe wrote:
> On Thu, Mar 4, 2010 at 2:00 PM, Sean Carolan <scarolan@gmail.com> wrote:
> > What am I doing wrong here? I need to be able to write to /var/cvs.
> > This used to work before I moved these groups into an LDAP directory
> > instead of /etc/group:
>
> You might want to check that the cvsgrp group ID in /etc/group matches
> the one in LDAP.
----
having a group with the same name in both /etc/group and LDAP groups
would be the surest path to insanity. Likewise, for /etc/passwd and LDAP
users.

Craig


--
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 03-04-2010, 09:34 PM
Sean Carolan
 
Default Permissions problem

> having a group with the same name in both /etc/group and LDAP groups
> would be the surest path to insanity. Likewise, for /etc/passwd and LDAP
> users.

I just needed to log out and back in again. Thanks for all your help!
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 04-14-2010, 07:58 AM
NW
 
Default Permissions problem

I have been looking at the possibility of using my one printer for all
three computers at home, see other thread. Now I don't know if I have
done anything silly but .....

Yesterday I couldn't print anything. Research tracked down the problem
to the permissions on dev/lp0. They were rw-rw---- with user = root and
group = lp. So others had no permissions.

I used chmod (with sudo) to change the permissions to rw-rw-rw- and I
was then able to print. Fine.

Today same problem. The permissions had reverted to rw-rw----. I have
changed them again. Now I don't want to have to keep running chmod every
session, that is just silly and anyway it has only just started to happen.

Can anyone help here please? For a start I don't understand why the new
set of permissions changed back. Shouldn't my change remain fixed?

If it is relevant I am running kubuntu Hardy on this computer.

Thanks

Neil

--
kubuntu-users mailing list
kubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users
 
Old 04-14-2010, 09:47 AM
Jonas Norlander
 
Default Permissions problem

2010/4/14 NW <barnaby@drofle.com>:
> I have been looking at the possibility of using my one printer for all
> three computers at home, see other thread. Now I don't know if I have
> done anything silly but .....
>
> Yesterday I couldn't print anything. Research tracked down the problem
> to the permissions on dev/lp0. They were *rw-rw---- with user = root and
> group = lp. So others had no permissions.

You shouldn't need to change permissions on devices in /dev. Perhaps
you need to add yourself to a group? On my Kubuntu 9.10 I am in the
lpadmin group (don't know if Hardy using this group).

> I used chmod (with sudo) to change the permissions to rw-rw-rw- and I
> was then able to print. Fine.
>
> Today same problem. The permissions had reverted to rw-rw----. I have
> changed them again. Now I don't want to have to keep running chmod every
> session, that is just silly and anyway it has only just started to happen.
>
> Can anyone help here please? For a start I don't understand why the new
> set of permissions changed back. Shouldn't my change remain fixed?

No they are not permanent. All devices in /dev is dynamically created
at boot or when attaching a new "hot-plug" device like USB devices.

/ Jonas

--
kubuntu-users mailing list
kubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users
 
Old 04-15-2010, 07:00 AM
NW
 
Default Permissions problem

Jonas Norlander wrote:
> 2010/4/14 NW <barnaby@drofle.com>:
>> I have been looking at the possibility of using my one printer for all
>> three computers at home, see other thread. Now I don't know if I have
>> done anything silly but .....
>>
>> Yesterday I couldn't print anything. Research tracked down the problem
>> to the permissions on dev/lp0. They were rw-rw---- with user = root and
>> group = lp. So others had no permissions.
>
> You shouldn't need to change permissions on devices in /dev. Perhaps
> you need to add yourself to a group? On my Kubuntu 9.10 I am in the
> lpadmin group (don't know if Hardy using this group).
>
>> I used chmod (with sudo) to change the permissions to rw-rw-rw- and I
>> was then able to print. Fine.
>>
>> Today same problem. The permissions had reverted to rw-rw----. I have
>> changed them again. Now I don't want to have to keep running chmod every
>> session, that is just silly and anyway it has only just started to happen.
>>
>> Can anyone help here please? For a start I don't understand why the new
>> set of permissions changed back. Shouldn't my change remain fixed?
>
> No they are not permanent. All devices in /dev is dynamically created
> at boot or when attaching a new "hot-plug" device like USB devices.
>
> / Jonas
>
Re the above problem

I run kubuntu Hardy and get regular updates as is normal. I remember now
that the last update included cups which is now at version 1.3.7. My
problems started after that. So, not my fault.

I think that my easiest way out of this is to get the permissions on lp0
to be set to 666. I have searched hard but cannot find where they are
set by udev on logging on. Can anyone help please?

Neil

--
kubuntu-users mailing list
kubuntu-users@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users
 

Thread Tools




All times are GMT. The time now is 01:29 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org