FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > CentOS > CentOS

 
 
LinkBack Thread Tools
 
Old 03-04-2010, 01:01 AM
John R Pierce
 
Default Recover RAID

Jeff Sadino wrote:
> Hello Everyone,
>
> First time CentOS poster I have CentOS 4 installed on the head
> node of a Sun Gridengine cluster set up in a RAID. The head node has
> four hard drives, and I assume that drives 1 and 2 are in a raid and
> then drives 3 and 4 are in another raid. I was trying to expand the
> OS partition on drive 1 because it was full. I took drive 1 out, put
> it in my Fedora 8 box as a secondary drive, booted up into Fedora, and
> saw it had the partition structure:
> / 8GB
> /var 4GB
> /swap 1GB
> and an "unknown" partition 101.4GB
...


probably LVM.

wow, you made a nice mess.


_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 03-04-2010, 01:03 AM
Jeff Sadino
 
Default Recover RAID

Do you think I can copy the unknown partition from the second drive onto the first drive and have everything work again?

On Wed, Mar 3, 2010 at 4:01 PM, John R Pierce <pierce@hogranch.com> wrote:


Jeff Sadino wrote:

> Hello Everyone,

>

> First time CentOS poster *I have CentOS 4 installed on the head

> node of a Sun Gridengine cluster set up in a RAID. *The head node has

> four hard drives, and I assume that drives 1 and 2 are in a raid and

> then drives 3 and 4 are in another raid. *I was trying to expand the

> OS partition on drive 1 because it was full. *I took drive 1 out, put

> it in my Fedora 8 box as a secondary drive, booted up into Fedora, and

> saw it had the partition structure:

> / 8GB

> /var 4GB

> /swap 1GB

> and an "unknown" partition 101.4GB

...





probably LVM.



wow, you made a nice mess.





_______________________________________________

CentOS mailing list

CentOS@centos.org

http://lists.centos.org/mailman/listinfo/centos



_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 03-04-2010, 01:09 AM
John R Pierce
 
Default Recover RAID

Jeff Sadino wrote:
> Do you think I can copy the unknown partition from the second drive
> onto the first drive and have everything work again?

if there's a md mirror, god knows what will happen when you boot it up
with both drives present, it oculd decide to mirror the unformatted
partition to the original, I've seen worse happen when the juju is
messed with.

I think I'd totally wipe the drive you messed with, like zero it. Then
boot up the system in single user with just the one drive you didn't
hose, and BACK UP EVERYTHING ON IT TO EXTERNAL SAFE MEDIA. use dump or
something to do the backup that does a proper inode level backup of each
volume. then add the wiped/blank drive, and remirror it with the mdadm
commands to repair the raid, then reboot to normal mode and see if its
all safe.






_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 03-04-2010, 01:10 AM
Christopher Chan
 
Default Recover RAID

> raiddev /dev/md1
> raid-level 0
> nr-raid-disks 2
> persistent-superblock 1
> chunk-size 4
> device /dev/sda4
> raid-disk 0
> device /dev/sdb2
> raid-disk 1
>
> It says it can bring up md0 ok, but not md1. Right now, I am going to
> try to restore the "unknown" partition that I deleted from drive 1 using
> the "unknown" partition from drive 2.
>
> Any ideas on how to get myself out of this mess? I feel like I really
> messed it up good. This is a server for our work, and we have a couple
> years worth of data on it, so I would really like to fix it rather than
> reinstall.

Sorry, recovery is impossible at this point. md1 is a raid0 device.
Since you have toasted one member partition, the whole thing it toast. I
recommend clubbing whoever set it up in the first place with a clueby4
and then yourself.
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 03-04-2010, 01:12 AM
Christopher Chan
 
Default Recover RAID

On Thursday, March 04, 2010 10:09 AM, John R Pierce wrote:
> Jeff Sadino wrote:
>> Do you think I can copy the unknown partition from the second drive
>> onto the first drive and have everything work again?
>
> if there's a md mirror, god knows what will happen when you boot it up
> with both drives present, it oculd decide to mirror the unformatted
> partition to the original, I've seen worse happen when the juju is
> messed with.

Well, he messed up a stripe. Zero chance of recovery.


>
> I think I'd totally wipe the drive you messed with, like zero it. Then
> boot up the system in single user with just the one drive you didn't
> hose, and BACK UP EVERYTHING ON IT TO EXTERNAL SAFE MEDIA. use dump or
> something to do the backup that does a proper inode level backup of each
> volume. then add the wiped/blank drive, and remirror it with the mdadm
> commands to repair the raid, then reboot to normal mode and see if its
> all safe.
>

Won't apply. He can kiss md1 good bye.
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 03-04-2010, 01:36 AM
Jeff Sadino
 
Default Recover RAID

Thanks for the insight.* Is there any way to bring it back to life not necessarily as a raid, but just back up so I can get to the data and have my license managers working?* What if I edit md1 out of the raidtab file?



Thanks,
Jeff

On Wed, Mar 3, 2010 at 4:12 PM, Christopher Chan <christopher.chan@bradbury.edu.hk> wrote:


On Thursday, March 04, 2010 10:09 AM, John R Pierce wrote:

> Jeff Sadino wrote:

>> Do you think I can copy the unknown partition from the second drive

>> onto the first drive and have everything work again?

>

> if there's a md mirror, god knows what will happen when you boot it up

> with both drives present, it oculd decide to mirror the unformatted

> partition to the original, I've seen worse happen when the juju is

> messed with.



Well, he messed up a stripe. Zero chance of recovery.





>

> I think I'd totally wipe the drive you messed with, like zero it. * Then

> boot up the system in single user with just the one drive you didn't

> hose, and BACK UP EVERYTHING ON IT TO EXTERNAL SAFE MEDIA. *use dump or

> something to do the backup that does a proper inode level backup of each

> volume. * then add the wiped/blank drive, and remirror it with the mdadm

> commands to repair the raid, then reboot to normal mode and see if its

> all safe.

>



Won't apply. He can kiss md1 good bye.

_______________________________________________

CentOS mailing list

CentOS@centos.org

http://lists.centos.org/mailman/listinfo/centos



_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 03-04-2010, 01:55 AM
Les Mikesell
 
Default Recover RAID

Jeff Sadino wrote:
> Thanks for the insight. Is there any way to bring it back to life not
> necessarily as a raid, but just back up so I can get to the data and
> have my license managers working? What if I edit md1 out of the raidtab
> file?
>

The data on a raid0 stripes across both drives as though it were one big
cylinder. You aren't going to make md1 work work with one missing. You should
be able to recover what was on md0 (a raid1) from either of its members.

--
Les Mikesell
lesmikesell@gmail.com
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 

Thread Tools




All times are GMT. The time now is 03:30 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org