FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > CentOS > CentOS

 
 
LinkBack Thread Tools
 
Old 02-10-2010, 04:28 AM
hersh parikh
 
Default R package on centos 5.1

Hi
*
** I want to install R package on centos 5.1, however I am not able to install it . Can anyone please tell me how can I install R on centos 5.1?
*
Thank you
Hersh


Your Mail works best with the New Yahoo Optimized IE8. Get it NOW!._____________________________________________ __
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 02-10-2010, 04:43 AM
"Les Bell"
 
Default R package on centos 5.1

hersh parikh <hershparikh12@yahoo.com> wrote:

>>
I want to install R package on centos 5.1, however I am not able to install
it
<<

I'm running it here on Centos 5.4. What problem are you having? Error
messages?

Best,

--- Les Bell
[http://www.lesbell.com.au]
Tel: +61 2 9451 1144


_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 02-10-2010, 05:35 AM
Rajagopal Swaminathan
 
Default R package on centos 5.1

Greetings,


On Wed, Feb 10, 2010 at 10:58 AM, hersh parikh <hershparikh12@yahoo.com> wrote:
> Hi
>
> ** I want to install R package on centos 5.1, however I am not able to
> install it . Can anyone please tell me how can I install R on centos 5.1?


I am able to install it after enabling epel and rpmforge repo:

yum install R

Yes it is a capital letter R.

I have earlier installed it on Centos 5.0 (circa 2005-6).

What is the messages if any?

Regards,

Rajagopal
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 02-10-2010, 05:37 AM
Rajagopal Swaminathan
 
Default R package on centos 5.1

Greetings,

On Wed, Feb 10, 2010 at 10:58 AM, hersh parikh <hershparikh12@yahoo.com> wrote:
> ** I want to install R package on centos 5.1, however I am not able to
> install it . Can anyone please tell me how can I install R on centos 5.1?



yum -y install R
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* addons: mirrors.hns.net.in
* base: mirrors.hns.net.in
* epel: ftp.kddilabs.jp
* extras: mirrors.hns.net.in
* rpmforge: fr2.rpmfind.net
* updates: mirrors.hns.net.in
addons | 951 B 00:00
andrewfarley | 951 B 00:00
base | 2.1 kB 00:00
epel | 3.4 kB 00:00
extras | 1.1 kB 00:00
rpmforge | 1.1 kB 00:00
updates | 1.9 kB 00:00
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package R.i386 0:2.10.0-2.el5 set to be updated
--> Processing Dependency: R-devel = 2.10.0-2.el5 for package: R
--> Processing Dependency: libRmath-devel = 2.10.0-2.el5 for package: R
--> Running transaction check
---> Package R-devel.i386 0:2.10.0-2.el5 set to be updated
--> Processing Dependency: R-core = 2.10.0-2.el5 for package: R-devel
--> Processing Dependency: tcl-devel for package: R-devel
--> Processing Dependency: bzip2-devel for package: R-devel
--> Processing Dependency: libX11-devel for package: R-devel
--> Processing Dependency: gcc-gfortran for package: R-devel
--> Processing Dependency: tk-devel for package: R-devel
--> Processing Dependency: pcre-devel for package: R-devel
--> Processing Dependency: tetex-latex for package: R-devel
---> Package libRmath-devel.i386 0:2.10.0-2.el5 set to be updated
--> Processing Dependency: libRmath = 2.10.0-2.el5 for package: libRmath-devel
--> Running transaction check
---> Package R-core.i386 0:2.10.0-2.el5 set to be updated
--> Processing Dependency: xdg-utils for package: R-core
--> Processing Dependency: perl(File::Copy::Recursive) for package: R-core
---> Package bzip2-devel.i386 0:1.0.3-4.el5_2 set to be updated
---> Package gcc-gfortran.i386 0:4.1.2-46.el5_4.2 set to be updated
---> Package libRmath.i386 0:2.10.0-2.el5 set to be updated
---> Package libX11-devel.i386 0:1.0.3-11.el5 set to be updated
--> Processing Dependency: xorg-x11-proto-devel >= 7.1-2 for package:
libX11-devel
--> Processing Dependency: libXau-devel for package: libX11-devel
--> Processing Dependency: libXdmcp-devel for package: libX11-devel
---> Package pcre-devel.i386 0:6.6-2.el5_1.7 set to be updated
---> Package tcl-devel.i386 0:8.4.13-4.el5 set to be updated
---> Package tetex-latex.i386 0:3.0-33.8.el5 set to be updated
--> Processing Dependency: tetex-dvips = 3.0 for package: tetex-latex
--> Processing Dependency: tetex = 3.0 for package: tetex-latex
---> Package tk-devel.i386 0:8.4.13-5.el5_1.1 set to be updated
--> Running transaction check
---> Package libXau-devel.i386 0:1.0.1-3.1 set to be updated
---> Package libXdmcp-devel.i386 0:1.0.1-2.1 set to be updated
---> Package perl-File-Copy-Recursive.noarch 0:0.38-1.el5.rf set to be updated
---> Package tetex.i386 0:3.0-33.8.el5 set to be updated
--> Processing Dependency: tetex-fonts = 3.0 for package: tetex
---> Package tetex-dvips.i386 0:3.0-33.8.el5 set to be updated
---> Package xdg-utils.noarch 0:1.0.2-4.el5 set to be updated
---> Package xorg-x11-proto-devel.i386 0:7.1-13.el5 set to be updated
--> Processing Dependency: mesa-libGL-devel for package: xorg-x11-proto-devel
--> Running transaction check
---> Package mesa-libGL-devel.i386 0:6.5.1-7.7.el5 set to be updated
---> Package tetex-fonts.i386 0:3.0-33.8.el5 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================== ==============================
Package Arch Version Repository Size
================================================== ==============================
Installing:
R i386 2.10.0-2.el5 epel 14 k
Installing for dependencies:
R-core i386 2.10.0-2.el5 epel 31 M
R-devel i386 2.10.0-2.el5 epel 87 k
bzip2-devel i386 1.0.3-4.el5_2 base 38 k
gcc-gfortran i386 4.1.2-46.el5_4.2 updates 3.1 M
libRmath i386 2.10.0-2.el5 epel 93 k
libRmath-devel i386 2.10.0-2.el5 epel 120 k
libX11-devel i386 1.0.3-11.el5 base 661 k
libXau-devel i386 1.0.1-3.1 base 11 k
libXdmcp-devel i386 1.0.1-2.1 base 7.5 k
mesa-libGL-devel i386 6.5.1-7.7.el5 base 466 k
pcre-devel i386 6.6-2.el5_1.7 base 176 k
perl-File-Copy-Recursive noarch 0.38-1.el5.rf rpmforge 22 k
tcl-devel i386 8.4.13-4.el5 base 1.0 M
tetex i386 3.0-33.8.el5 base 8.4 M
tetex-dvips i386 3.0-33.8.el5 base 550 k
tetex-fonts i386 3.0-33.8.el5 base 29 M
tetex-latex i386 3.0-33.8.el5 base 4.1 M
tk-devel i386 8.4.13-5.el5_1.1 base 809 k
xdg-utils noarch 1.0.2-4.el5 epel 52 k
xorg-x11-proto-devel i386 7.1-13.el5 base 247 k

Transaction Summary
================================================== ==============================
Install 21 Package(s)
Update 0 Package(s)
Remove 0 Package(s)

Total download size: 80 M

etc..

regards,

Rajagopal
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 02-16-2010, 05:50 AM
Hersh
 
Default R package on centos 5.1

Hi

I tried to install with command you mentioned but it says ..


[root@bithorax etc]# yum -y install R

Loading "fastestmirror" pluginLoading mirror speeds from cached hostfile

** base: ftp.oss.eznetsols.org** updates: ftp.oss.eznetsols.org

** addons: ftp.oss.eznetsols.org** extras: ftp.oss.eznetsols.org

Setting up Install ProcessParsing package install arguments

No package R available.Nothing to do

Do I need to update repo for this?



Regards
Hersh

On 10 February 2010 12:07, Rajagopal Swaminathan <raju.rajsand@gmail.com> wrote:


Greetings,



On Wed, Feb 10, 2010 at 10:58 AM, hersh parikh <hershparikh12@yahoo.com> wrote:

> ** I want to install R package on centos 5.1, however I am not able to

> install it . Can anyone please tell me how can I install R on centos 5.1?







*yum -y install R

Loaded plugins: fastestmirror

Loading mirror speeds from cached hostfile

** addons: mirrors.hns.net.in

** base: mirrors.hns.net.in

** epel: ftp.kddilabs.jp

** extras: mirrors.hns.net.in

** rpmforge: fr2.rpmfind.net

** updates: mirrors.hns.net.in

addons * * * * * * * * * * * * * * * * * * * * * * * * * | *951 B * * 00:00

andrewfarley * * * * * * * * * * * * * * * * * * * * * * | *951 B * * 00:00

base * * * * * * * * * * * * * * * * * * * * * * * * * * | 2.1 kB * * 00:00

epel * * * * * * * * * * * * * * * * * * * * * * * * * * | 3.4 kB * * 00:00

extras * * * * * * * * * * * * * * * * * * * * * * * * * | 1.1 kB * * 00:00

rpmforge * * * * * * * * * * * * * * * * * * * * * * * * | 1.1 kB * * 00:00

updates * * * * * * * * * * * * * * * * * * * * * * * * *| 1.9 kB * * 00:00

Setting up Install Process

Resolving Dependencies

--> Running transaction check

---> Package R.i386 0:2.10.0-2.el5 set to be updated

--> Processing Dependency: R-devel = 2.10.0-2.el5 for package: R

--> Processing Dependency: libRmath-devel = 2.10.0-2.el5 for package: R

--> Running transaction check

---> Package R-devel.i386 0:2.10.0-2.el5 set to be updated

--> Processing Dependency: R-core = 2.10.0-2.el5 for package: R-devel

--> Processing Dependency: tcl-devel for package: R-devel

--> Processing Dependency: bzip2-devel for package: R-devel

--> Processing Dependency: libX11-devel for package: R-devel

--> Processing Dependency: gcc-gfortran for package: R-devel

--> Processing Dependency: tk-devel for package: R-devel

--> Processing Dependency: pcre-devel for package: R-devel

--> Processing Dependency: tetex-latex for package: R-devel

---> Package libRmath-devel.i386 0:2.10.0-2.el5 set to be updated

--> Processing Dependency: libRmath = 2.10.0-2.el5 for package: libRmath-devel

--> Running transaction check

---> Package R-core.i386 0:2.10.0-2.el5 set to be updated

--> Processing Dependency: xdg-utils for package: R-core

--> Processing Dependency: perl(File::Copy::Recursive) for package: R-core

---> Package bzip2-devel.i386 0:1.0.3-4.el5_2 set to be updated

---> Package gcc-gfortran.i386 0:4.1.2-46.el5_4.2 set to be updated

---> Package libRmath.i386 0:2.10.0-2.el5 set to be updated

---> Package libX11-devel.i386 0:1.0.3-11.el5 set to be updated

--> Processing Dependency: xorg-x11-proto-devel >= 7.1-2 for package:

libX11-devel

--> Processing Dependency: libXau-devel for package: libX11-devel

--> Processing Dependency: libXdmcp-devel for package: libX11-devel

---> Package pcre-devel.i386 0:6.6-2.el5_1.7 set to be updated

---> Package tcl-devel.i386 0:8.4.13-4.el5 set to be updated

---> Package tetex-latex.i386 0:3.0-33.8.el5 set to be updated

--> Processing Dependency: tetex-dvips = 3.0 for package: tetex-latex

--> Processing Dependency: tetex = 3.0 for package: tetex-latex

---> Package tk-devel.i386 0:8.4.13-5.el5_1.1 set to be updated

--> Running transaction check

---> Package libXau-devel.i386 0:1.0.1-3.1 set to be updated

---> Package libXdmcp-devel.i386 0:1.0.1-2.1 set to be updated

---> Package perl-File-Copy-Recursive.noarch 0:0.38-1.el5.rf set to be updated

---> Package tetex.i386 0:3.0-33.8.el5 set to be updated

--> Processing Dependency: tetex-fonts = 3.0 for package: tetex

---> Package tetex-dvips.i386 0:3.0-33.8.el5 set to be updated

---> Package xdg-utils.noarch 0:1.0.2-4.el5 set to be updated

---> Package xorg-x11-proto-devel.i386 0:7.1-13.el5 set to be updated

--> Processing Dependency: mesa-libGL-devel for package: xorg-x11-proto-devel

--> Running transaction check

---> Package mesa-libGL-devel.i386 0:6.5.1-7.7.el5 set to be updated

---> Package tetex-fonts.i386 0:3.0-33.8.el5 set to be updated

--> Finished Dependency Resolution



Dependencies Resolved



================================================== ==============================

*Package * * * * * * * * * * Arch * * *Version * * * * * * * *Repository * Size

================================================== ==============================

Installing:

*R * * * * * * * * * * * * * i386 * * *2.10.0-2.el5 * * * * * epel * * * * 14 k

Installing for dependencies:

*R-core * * * * * * * * * * *i386 * * *2.10.0-2.el5 * * * * * epel * * * * 31 M

*R-devel * * * * * * * * * * i386 * * *2.10.0-2.el5 * * * * * epel * * * * 87 k

*bzip2-devel * * * * * * * * i386 * * *1.0.3-4.el5_2 * * * * *base * * * * 38 k

*gcc-gfortran * * * * * * * *i386 * * *4.1.2-46.el5_4.2 * * * updates * * 3.1 M

*libRmath * * * * * * * * * *i386 * * *2.10.0-2.el5 * * * * * epel * * * * 93 k

*libRmath-devel * * * * * * *i386 * * *2.10.0-2.el5 * * * * * epel * * * *120 k

*libX11-devel * * * * * * * *i386 * * *1.0.3-11.el5 * * * * * base * * * *661 k

*libXau-devel * * * * * * * *i386 * * *1.0.1-3.1 * * * * * * *base * * * * 11 k

*libXdmcp-devel * * * * * * *i386 * * *1.0.1-2.1 * * * * * * *base * * * *7.5 k

*mesa-libGL-devel * * * * * *i386 * * *6.5.1-7.7.el5 * * * * *base * * * *466 k

*pcre-devel * * * * * * * * *i386 * * *6.6-2.el5_1.7 * * * * *base * * * *176 k

*perl-File-Copy-Recursive * *noarch * *0.38-1.el5.rf * * * * *rpmforge * * 22 k

*tcl-devel * * * * * * * * * i386 * * *8.4.13-4.el5 * * * * * base * * * *1.0 M

*tetex * * * * * * * * * * * i386 * * *3.0-33.8.el5 * * * * * base * * * *8.4 M

*tetex-dvips * * * * * * * * i386 * * *3.0-33.8.el5 * * * * * base * * * *550 k

*tetex-fonts * * * * * * * * i386 * * *3.0-33.8.el5 * * * * * base * * * * 29 M

*tetex-latex * * * * * * * * i386 * * *3.0-33.8.el5 * * * * * base * * * *4.1 M

*tk-devel * * * * * * * * * *i386 * * *8.4.13-5.el5_1.1 * * * base * * * *809 k

*xdg-utils * * * * * * * * * noarch * *1.0.2-4.el5 * * * * * *epel * * * * 52 k

*xorg-x11-proto-devel * * * *i386 * * *7.1-13.el5 * * * * * * base * * * *247 k



Transaction Summary

================================================== ==============================

Install * * 21 Package(s)

Update * * * 0 Package(s)

Remove * * * 0 Package(s)



Total download size: 80 M



etc..



regards,



Rajagopal

_______________________________________________

CentOS mailing list

CentOS@centos.org

http://lists.centos.org/mailman/listinfo/centos



_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 02-16-2010, 08:39 AM
John Doe
 
Default R package on centos 5.1

From: Hersh <hershparikh12@yahoo.com>
>>>>Installing:
>>>> R i386 2.10.0-2.el5 epel 14 k
> I tried to install with command you mentioned but it says ..
>No package R available.
>Nothing to do

Notice the epel (repository).

JD



_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 

Thread Tools




All times are GMT. The time now is 04:42 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org