FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > CentOS > CentOS

 
 
LinkBack Thread Tools
 
Old 01-29-2010, 05:14 PM
"Jason Pyeron"
 
Default Lockup using stock r8169 on 4.8 in gigabit mode during heavy transfer on lan

I have no output in the logs, but /etc/init.d/network restart fixes the issue.
I am rsync/scp (10GB) data from one 100MB Full duplex host to an ASUS M3A78-EM
(RTL8111B/C). It locks up around the 1.5GB Tx mark.
If I ethtool -s eth0 autoneg off speed 100 duplex full it does not happen again.

Ideas?

--
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
- -
- Jason Pyeron PD Inc. http://www.pdinc.us -
- Principal Consultant 10 West 24th Street #100 -
- +1 (443) 269-1555 x333 Baltimore, Maryland 21218 -
- -
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
This message is copyright PD Inc, subject to license 20080407P00.


_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 01-29-2010, 06:29 PM
"Jason Pyeron"
 
Default Lockup using stock r8169 on 4.8 in gigabit mode during heavy transfer on lan

> -----Original Message-----
> From: centos-bounces@centos.org
> [mailto:centos-bounces@centos.org] On Behalf Of Tim Nelson
> Sent: Friday, January 29, 2010 14:05
> To: CentOS mailing list
> Subject: Re: [CentOS] Lockup using stock r8169 on 4.8 in
> gigabit mode during heavy transfer on lan
>
> ----- "Jason Pyeron" <jpyeron@pdinc.us> wrote:
> > I have no output in the logs, but /etc/init.d/network restart fixes
> > the issue.
> > I am rsync/scp (10GB) data from one 100MB Full duplex host
> to an ASUS
> > M3A78-EM (RTL8111B/C). It locks up around the 1.5GB Tx mark.
> > If I ethtool -s eth0 autoneg off speed 100 duplex full it does not
> > happen again.
> >
> > Ideas?
>
> Part of the problem is that you mention r8169 kernel module
> in your subject but your hardware is RTL8111B. Realtek
> drivers are notorious for loading on improper hardware and
> appearing to work properly. You need to get the proper driver
> for your NIC. I've run into this countless times with the
> r8169 driver and non-r8169 Realtek NICs.

Good to know. Thanks.

>
> And, on a side note, Realtek may possibly be the worst NIC
> out there, especially for server use. It may link at gigabit
> speed, but I bet a trusty old 3Com or Intel Pro 100 will get
> better throughput. Install a different NIC as fast as you can
> and never look back.
>

The system was not purchased for 1000MB use, but all of the switches are. We
just took the mobo that was cheapest/fastest to get a non-production up ASAP.

> --Tim
> _______________________________________________
> CentOS mailing list
> CentOS@centos.org
> http://lists.centos.org/mailman/listinfo/centos
>




--
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
- -
- Jason Pyeron PD Inc. http://www.pdinc.us -
- Principal Consultant 10 West 24th Street #100 -
- +1 (443) 269-1555 x333 Baltimore, Maryland 21218 -
- -
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
This message is copyright PD Inc, subject to license 20080407P00.

_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 

Thread Tools




All times are GMT. The time now is 01:35 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org