FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > CentOS > CentOS

 
 
LinkBack Thread Tools
 
Old 03-20-2009, 11:20 AM
Tom Brown
 
Default minimal installation - kickstart error

Hi

I have inherited some kickstarts that attempt to remove some packages
that at some point its been deemed they are not required.
I am migrating all this over to cobbler but trying to get to the bottom
of this error that although the kickstart completes sshd cant start as
the package nss is not installed.

It fails with this

Installing nss - 3.11.99.5-2.el5.centos.x86_64
error: %pre(nss-3.11.99.5-2.el5.centos.x86_64) scriptlet failed, exit
status 255
error: install: %pre scriptlet failed (2), skipping
nss-3.11.99.5-2.el5.centos

Which seems to happen due to this

error while loading shared libraries: libssl3.so

yum tells me

# yum provides libssl3.so
nss.i386 : Network Security Services
nss.i386 : Network Security Services

so

# yum search "Network Security Services"
nss.i386 : Network Security Services
nss-tools.x86_64 : Tools for the Network Security Services
nss-devel.x86_64 : Development libraries for Network Security Services
nss.x86_64 : Network Security Services
nss-devel.i386 : Development libraries for Network Security Services
nss-tools.x86_64 : Tools for the Network Security Services
mod_nss.x86_64 : SSL/TLS module for the Apache HTTP server
nss.i386 : Network Security Services

But anyone know what package messing this up as from what i can see
nothing there is being 'removed' in the kickstart - below is a full list
of packages removed in the kickstart

thanks for any tips

tom

# individual packages to remove
-acpid
-apmd
-aspell
-aspell-en
-at
-autofs
-bc
-beecrypt
-binutils
-bluez-bluefw
-bluez-hcidump
-bluez-libs
-bluez-utils
-cpio
-crash
-cryptsetup
-cups
-cups-libs
-cyrus-sasl
-cyrus-sasl-md5
-cyrus-sasl-plain
-dhclient
-dhcpv6_client
-dmraid
-dosfstools
-dump
-ed
-eject
-fbset
-finger
-ftp
-gpm
-hesiod
-irda-utils
-isdn4k-utils
-lftp
-lha
-logwatch
-lrzsz
-mailcap
-minicom
-mtools
-mtr
-mt-st
-nano
-nc
-netconfig
-NetworkManager
-ntsysv
-pam_smb
-parted
-pax
-pcmcia-cs
-pinfo
-quota
-rdate
-rdist
-redhat-logos
-rmt
-rp-pppoe
-rsh
-sendmail
-slang
-stunnel
-system-config-mouse
-system-config-network-tui
-system-config-securitylevel-tui
-talk
-tcsh
-up2date
-vconfig
-wireless-tools
-wvdial
-xinetd
-ypbind
-yp-tools

_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 03-20-2009, 03:54 PM
Tom Brown
 
Default minimal installation - kickstart error

> -logwatch
>

strangely it was the removal of logwatch that was causing this issue
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 

Thread Tools




All times are GMT. The time now is 05:19 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org