Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   CentOS (http://www.linux-archive.org/centos/)
-   -   Problem building Perl net-snmp (http://www.linux-archive.org/centos/176713-problem-building-perl-net-snmp.html)

"Marcelo M. Garcia" 10-15-2008 12:31 PM

Problem building Perl net-snmp
 
Hi

I'm trying to build the perl modules of net-snmp-5.4.2. Everything seems
to work fine until "make test"[1]. The problem with "DynaLoader.pm"
seems to be an old one.


The machine is Centos 5.2 i386

I'm trying to build instead of using the one available in the repos
because I'll build in other platforms and also in nagios-plugins.


Thanks

Marcelo




[1]

Failed 17/17 tests, 0.00% okay
t/getnext.....Can't load
'/users/newt2/mgarcia/Downloads/Nagios-3.0.3/net-snmp-5.4.2/perl/SNMP/../blib/arch/auto/NetSNMP/default_store/default_store.so'
for module NetSNMP::default_store: libnetsnmp.so.15: cannot open shared
object file: No such file or directory at
/usr/lib/perl5/5.8.8/i386-linux-thread-multi/DynaLoader.pm line 230.
at
/users/newt2/mgarcia/Downloads/Nagios-3.0.3/net-snmp-5.4.2/perl/SNMP/../blib/lib/SNMP.pm
line 16
Compilation failed in require at
/users/newt2/mgarcia/Downloads/Nagios-3.0.3/net-snmp-5.4.2/perl/SNMP/../blib/lib/SNMP.pm
line 16.
BEGIN failed--compilation aborted at
/users/newt2/mgarcia/Downloads/Nagios-3.0.3/net-snmp-5.4.2/perl/SNMP/../blib/lib/SNMP.pm
line 16.

Compilation failed in require at t/getnext.t line 15.
BEGIN failed--compilation aborted at t/getnext.t line 15.
t/getnext.....dubious


Test returned status 2 (wstat 512, 0x200)
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos

"nate" 10-15-2008 04:02 PM

Problem building Perl net-snmp
 
Marcelo M. Garcia wrote:

> '/users/newt2/mgarcia/Downloads/Nagios-3.0.3/net-snmp-5.4.2/perl/SNMP/../blib/arch/auto/NetSNMP/default_store/default_store.so'
> for module NetSNMP::default_store: libnetsnmp.so.15: cannot open shared
> object file: No such file or directory at

You don't have the snmp library installed that the program is
looking for. I don't see libnetsnmp.so.15 on either of my CentOS 4.6
or CentOS 5.1 systems so it seems like you may of installed net-snmp
from source..in which case you need to point the program at the location
of your net-snmp installation so it can find the library.

rpm -qa | grep -i net-snmp

nate


_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos


All times are GMT. The time now is 01:02 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.