FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > CentOS > CentOS

 
 
LinkBack Thread Tools
 
Old 07-18-2008, 01:06 PM
Sam Drinkard
 
Default Yum strangeness

Hi all,

I was about to do an update on my server, but looking at what the
output was and here's the output from the beginning with other parts
left off. I currently don't even have the clamav server installed, but
am using the 0.93 version of clamav-milter.
I've never seen yum throw in so many packages that aren't even
installed. I understand the dependencies has to be met, and such, but
why is yum trying to install older version of clamav? Perhaps I missed
something, but don't think so.


Many thanks,

Sam

Here is the output from yum update


================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Installing:
clamav-data i386 0.88.2-2.el4.kb kbs-CentOS-Extras
4.1 M

replacing clamav-db.i386 0.93.1-1.el4.rf

clamav-server i386 0.88.2-2.el4.kb kbs-CentOS-Extras
48 k

replacing clamd.i386 0.93.1-1.el4.rf

kernel i686 2.6.9-67.0.20.EL update
12 M
kernel-devel i686 2.6.9-67.0.20.EL update
3.9 M

Updating:
autofs i386 1:4.1.3-231.el4_6.2
update 264 k
bind i386 20:9.2.4-28.0.1.el4
update 581 k
bind-chroot i386 20:9.2.4-28.0.1.el4
update 35 k
bind-libs i386 20:9.2.4-28.0.1.el4
update 567 k
bind-utils i386 20:9.2.4-28.0.1.el4
update 141 k

bluez-libs i386 2.10-3 update 39 k
bluez-utils i386 2.10-2.4 update 150 k
caching-nameserver noarch 7.3-3.0.1.el4_6 update 22 k
clamav i386 0.93.3-1.el4.rf rpmforge 1.3 M
clamav-milter i386 0.93.3-1.el4.rf rpmforge 76 k
firefox i386 1.5.0.12-0.21.el4.centos
update 15 M

freetype i386 2.1.9-8.el4.6 update 764 k
freetype-devel i386 2.1.9-8.el4.6 update 533 k
kernel-hugemem-devel i686 2.6.9-67.0.20.EL update
3.9 M
kernel-smp-devel i686 2.6.9-67.0.20.EL update
3.9 M
openldap i386 2.2.13-8.el4_6.5 update
237 k
openldap-clients i386 2.2.13-8.el4_6.5 update
121 k
openldap-devel i386 2.2.13-8.el4_6.5 update
1.3 M

perl-Compress-Raw-Zlib i386 2.011-1.el4.rf rpmforge 158 k
perl-IO-Compress-Base noarch 2.011-1.el4.rf rpmforge 55 k
perl-IO-Compress-Zlib noarch 2.011-1.el4.rf rpmforge 140 k
php i386 4.3.9-3.22.12 update 1.3 M
php-ldap i386 4.3.9-3.22.12 update 36 k
php-mysql i386 4.3.9-3.22.12 update 37 k
php-pear i386 4.3.9-3.22.12 update 481 k
procps i386 3.2.3-8.9.el4_6.1 update
189 k
seamonkey i386 1.0.9-16.4.el4.centos
update 8.7 M
seamonkey-nspr i386 1.0.9-16.4.el4.centos
update 101 k
seamonkey-nss i386 1.0.9-16.4.el4.centos
update 745 k
selinux-policy-targeted noarch 1.17.30-2.150.el4
update 125 k

Installing for dependencies:
clamav-lib i386 0.88.2-2.el4.kb kbs-CentOS-Extras
144 k

Updating for dependencies:
clamav-db i386 0.93.3-1.el4.rf rpmforge 15 M
clamd i386 0.93.3-1.el4.rf rpmforge 82 k

Transaction Summary
================================================== ===========================
Install 5 Package(s)
Update 32 Package(s)
Remove 0 Package(s)
Total download size: 76 M
Is this ok [y/N]: n
Exiting on user Command
Complete!



_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 07-18-2008, 02:17 PM
Jeff
 
Default Yum strangeness

On Fri, Jul 18, 2008 at 8:06 AM, Sam Drinkard <sam@wa4phy.net> wrote:
> Hi all,
>
> I was about to do an update on my server, but looking at what the output
> was and here's the output from the beginning with other parts left off. I
> currently don't even have the clamav server installed, but am using the 0.93
> version of clamav-milter.
> I've never seen yum throw in so many packages that aren't even installed. I
> understand the dependencies has to be met, and such, but why is yum trying
> to install older version of clamav? Perhaps I missed something, but don't
> think so.
>

Appears to be yet another instance of mixing repositories. You have
both kb and rpmforge, each of which has clamav packages. Disable one
of the repos.

--
Jeff
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 07-18-2008, 02:59 PM
Johnny Hughes
 
Default Yum strangeness

Jeff wrote:

On Fri, Jul 18, 2008 at 8:06 AM, Sam Drinkard <sam@wa4phy.net> wrote:

Hi all,

I was about to do an update on my server, but looking at what the output
was and here's the output from the beginning with other parts left off. I
currently don't even have the clamav server installed, but am using the 0.93
version of clamav-milter.
I've never seen yum throw in so many packages that aren't even installed. I
understand the dependencies has to be met, and such, but why is yum trying
to install older version of clamav? Perhaps I missed something, but don't
think so.



Appears to be yet another instance of mixing repositories. You have
both kb and rpmforge, each of which has clamav packages. Disable one
of the repos.

Of use yum-priorities and set one of the repos to a higher priority ...
or add exclude=clamav* in the kbs repo file as you currently have clamav
from rpmforge installed.


_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 07-18-2008, 02:59 PM
"William L. Maltby"
 
Default Yum strangeness

On Fri, 2008-07-18 at 09:17 -0500, Jeff wrote:
> On Fri, Jul 18, 2008 at 8:06 AM, Sam Drinkard <sam@wa4phy.net> wrote:
> > Hi all,
> >
> > I was about to do an update on my server, but looking at what the output
> > was and here's the output from the beginning with other parts left off. I
> > currently don't even have the clamav server installed, but am using the 0.93
> > version of clamav-milter.
> > I've never seen yum throw in so many packages that aren't even installed. I
> > understand the dependencies has to be met, and such, but why is yum trying
> > to install older version of clamav? Perhaps I missed something, but don't
> > think so.
> >
>
> Appears to be yet another instance of mixing repositories. You have
> both kb and rpmforge, each of which has clamav packages. Disable one
> of the repos.

And look at using the yum priorities plugin so you can safely mix repos.

>

--
Bill

_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 07-18-2008, 03:29 PM
Lorenzo Quatrini
 
Default Yum strangeness

William L. Maltby ha scritto:


And look at using the yum priorities plugin so you can safely mix repos.



I have one question about this:

Which is the "safest" setup for priorities?

base, update and extras: priority=1
ATrpms (which should not replace _any_ base package): priority=10
rpmforge (which could have some base package updated): priority=20
EPEL: priority=30

and so on with other repos...

Does this look reasonable?

TIA

Lorenzo

_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 

Thread Tools




All times are GMT. The time now is 05:13 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org