FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > CentOS > CentOS

 
 
LinkBack Thread Tools
 
Old 07-07-2008, 01:35 PM
"Jim Perrin"
 
Default Best Java code for Centos 5.2s Firefox 3

On Mon, Jul 7, 2008 at 9:29 AM, Robert Moskowitz <rgm@htt-consult.com> wrote:
> OK. I just upgraded a test system from 5.1 to 5.2 and there went all of my
> efforts to get Java working. All those alternative commands that I lost
> track of what really worked....
>
> So I need the JDK. I have that installed on my main system with some
> alternatives commands that I do not remember. I do remember (and can find)
> a thread here to help me on it, and I tried a number of different
> recommendations until things started working. Was it the last command or a
> combination of them?
>
> Anyway, so here comes the upgrade to firefox 3. On my test system, Java was
> working with 1.5, and now it is not. So I anticipate the same event here.
> I need these Java apps working, so before I upgrade, I would like to know
> what others have found out and recommend.


The openjdk rpms from epel are somewhat functional, but for me it's
just easier to get the jdk rpm from java.sun.com, and then grab the
java-sun-compat rpm from jpackage.org. It sets up the alternatives
framework and plugins for mozilla/ff. After that it all 'Just Works'
here.

--
During times of universal deceit, telling the truth becomes a revolutionary act.
George Orwell
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 07-07-2008, 03:04 PM
"William L. Maltby"
 
Default Best Java code for Centos 5.2s Firefox 3

On Mon, 2008-07-07 at 09:29 -0400, Robert Moskowitz wrote:
> <snip>

> Anyway, so here comes the upgrade to firefox 3. On my test system, Java
> was working with 1.5, and now it is not. So I anticipate the same event
> here. I need these Java apps working, so before I upgrade, I would like
> to know what others have found out and recommend.

Early on I installed firefox-3.0rc2.tar.bz2 (after having discarded the
3b5 beta now included in the RH/CentOS 5.2 my home directory and started
successfully running with it. I have not yet replaced the 3b5
system-wide (not broken, don't fix).

I run a java application. The java console show warnings and 8 errors,
but it WFM.

# rpm -qa|grep jre
jre-1.6.0_05-fcs

# rpm -qa|grep java
java-1.4.2-gcj-compat-1.4.2.0-40jpp.115
tzdata-java-2007k-2.el5.centos

I had tried the openjdk CentOS posted a couple months back, reported it
did not WFM, never heard anything about it, so I abandoned testing it.
Got the real jre from Sun's site.

With this combination, my apps are working good enough, although I would
prefer no warnings or errors in the java console.

I would suggest getting the released FF from the mozilla site, install
alongside the CentOS released one (allowing an upgrade to prod FF when
RH releases it) and test that setup.

I would like to use all the CentOS released, but the beta FF has too
many warts, the test of the openjdk I did not only failed but also got
no activity when I reported it did not work for me and I had no
time/interest in pushing hard since I'm really ignorant on all that
stuff.

> <snip sig stuff>

HTH
--
Bill

_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 07-14-2008, 07:51 AM
Peter Kjellstrom
 
Default Best Java code for Centos 5.2s Firefox 3

On Monday 07 July 2008, William L. Maltby wrote:
> On Mon, 2008-07-07 at 09:29 -0400, Robert Moskowitz wrote:
> > <snip>
> >
> > Anyway, so here comes the upgrade to firefox 3. On my test system, Java
> > was working with 1.5, and now it is not. So I anticipate the same event
> > here. I need these Java apps working, so before I upgrade, I would like
> > to know what others have found out and recommend.
>
> Early on I installed firefox-3.0rc2.tar.bz2 (after having discarded the
> 3b5 beta now included in the RH/CentOS 5.2 my home directory and started
> successfully running with it. I have not yet replaced the 3b5
> system-wide (not broken, don't fix).

As it happens 3b5 is broken (security wise).

/Peter
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 

Thread Tools




All times are GMT. The time now is 09:35 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org