FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > CentOS > CentOS

 
 
LinkBack Thread Tools
 
Old 07-03-2008, 12:46 PM
Robert Moskowitz
 
Default Centos 5.2 upgrade - urlopen error unknown url type: media

My first notebook upgrade:

I repaired my old HP nc4010 (bought a new hinge on ebay) and realized
this was the perfect way to test out the upgrade to 5.2 before doing it
on my production notebook.


First I updated to 'current' 5.1 (by current I mean I have not synced my
5.1 local repo since building my 5.2 repo). I had not used my nc4010
for a while and the kernel was at 2.6.18-53.1.13 (update took it to
1.21). Rebooted and system still working.


I then pointed my CentOS-Base.repo to my 5.2 repo. I did a yum clean
all then a yum update yum* rpm and below is what happened:


================================================== =====
[root@nc4010 yum.repos.d]# yum clean all
Loading "installonlyn" plugin
Cleaning up Everything

[root@nc4010 yum.repos.d]# yum update yum* rpm
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
http://linuxdownload.adobe.com/linux/i386/repodata/repomd.xml: [Errno 4]
IOError: <urlopen error (-3, 'Temporary failure in name resolution')>

Trying other mirror.
Error: Cannot open/read repomd.xml file for repository: adobe-linux-i386
[root@nc4010 yum.repos.d]# /etc/sysconfig/network-scripts/ifup-eth eth0
[root@nc4010 yum.repos.d]# yum update yum* rpm
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
adobe-linux-i386 100% |=========================| 951 B
00:00
kbs-CentOS-Extras 100% |=========================| 951 B
00:00
base 100% |=========================| 1.3 kB
00:00
updates 100% |=========================| 951 B
00:00
addons 100% |=========================| 951 B
00:00
extras 100% |=========================| 1.1 kB
00:00
Reading repository metadata in from local files
primary.xml.gz 100% |=========================| 10 kB
00:00
################################################## 17/17
primary.xml.gz 100% |=========================| 157 B
00:00
primary.xml.gz 100% |=========================| 821 kB
00:00
################################################## 2453/2453
primary.xml.gz 100% |=========================| 91 kB
00:00
################################################## 165/165
primary.xml.gz 100% |=========================| 157 B
00:00
primary.xml.gz 100% |=========================| 74 kB
00:00
################################################## 244/244

Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for yum-metadata-parser to pack into transaction
set.
media://1213888991.267240%231/CentOS/yum-metadata-parser-1.1.2-2.el5.i386.rpm:
[Errno 4] IOError: <urlopen error unknown url type: media>

Trying other mirror.
Error: failed to retrieve
CentOS/yum-metadata-parser-1.1.2-2.el5.i386.rpm from base

error was [Errno 4] IOError: <urlopen error unknown url type: media>
================================================== =====

I rebooted my local repo server. No change.

I downloaded a new copy of yum-metadata-parser-1.1.2-2.el5.i386.rpm from
mirror.centos.org/centos/5.2/os/i386/CentOS/. No change. (dated Jun 14,
mine was dated Jun 24, the day I built my repo. but file sizes are
identical).


What am I missing here?


_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 

Thread Tools




All times are GMT. The time now is 01:21 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org