FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > CentOS > CentOS

 
 
LinkBack Thread Tools
 
Old 06-26-2008, 06:55 AM
 
Default Upgrade perl; package conflict

Hi!

I'm working on upgrading my Xen Domain0 to CentOs 5.2. However, yum update gives me a package conflict on perl:

Running Transaction Test
Finished Transaction Test


Transaction Check Error:
file /usr/lib/perl5/5.8.8/pod/perldiag.pod from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
file /usr/share/man/man1/c2ph.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
file /usr/share/man/man1/cpan.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
file /usr/share/man/man1/dprofpp.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
file /usr/share/man/man1/enc2xs.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
file /usr/share/man/man1/find2perl.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
file /usr/share/man/man1/h2ph.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
file /usr/share/man/man1/h2xs.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
file /usr/share/man/man1/instmodsh.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
file /usr/share/man/man1/libnetcfg.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
file /usr/share/man/man1/perlbug.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
file /usr/share/man/man1/perlcc.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
file /usr/share/man/man1/perldiag.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
file /usr/share/man/man1/perlivp.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
file /usr/share/man/man1/piconv.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
file /usr/share/man/man1/pl2pm.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
file /usr/share/man/man1/pod2html.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
file /usr/share/man/man1/pod2latex.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
file /usr/share/man/man1/pod2man.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
file /usr/share/man/man1/pod2text.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
file /usr/share/man/man1/pod2usage.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
file /usr/share/man/man1/podchecker.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
file /usr/share/man/man1/podselect.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
file /usr/share/man/man1/prove.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
file /usr/share/man/man1/psed.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
file /usr/share/man/man1/pstruct.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
file /usr/share/man/man1/s2p.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
file /usr/share/man/man1/splain.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
file /usr/share/man/man1/xsubpp.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2

Error Summary
-------------

Using a x86_64 install btw.

Anyone seen this one??

Cheers,

Bart
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 06-26-2008, 07:42 AM
"Tim Verhoeven"
 
Default Upgrade perl; package conflict

On Thu, Jun 26, 2008 at 8:55 AM, <centos@bartbaars.nl> wrote:
>
> Transaction Check Error:
> file /usr/lib/perl5/5.8.8/pod/perldiag.pod from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
> file /usr/share/man/man1/c2ph.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
> file /usr/share/man/man1/cpan.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
> file /usr/share/man/man1/dprofpp.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
> file /usr/share/man/man1/enc2xs.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
> file /usr/share/man/man1/find2perl.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
> file /usr/share/man/man1/h2ph.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
> file /usr/share/man/man1/h2xs.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
> file /usr/share/man/man1/instmodsh.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
> file /usr/share/man/man1/libnetcfg.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
> file /usr/share/man/man1/perlbug.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
> file /usr/share/man/man1/perlcc.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
> file /usr/share/man/man1/perldiag.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
> file /usr/share/man/man1/perlivp.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
> file /usr/share/man/man1/piconv.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
> file /usr/share/man/man1/pl2pm.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
> file /usr/share/man/man1/pod2html.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
> file /usr/share/man/man1/pod2latex.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
> file /usr/share/man/man1/pod2man.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
> file /usr/share/man/man1/pod2text.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
> file /usr/share/man/man1/pod2usage.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
> file /usr/share/man/man1/podchecker.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
> file /usr/share/man/man1/podselect.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
> file /usr/share/man/man1/prove.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
> file /usr/share/man/man1/psed.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
> file /usr/share/man/man1/pstruct.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
> file /usr/share/man/man1/s2p.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
> file /usr/share/man/man1/splain.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2
> file /usr/share/man/man1/xsubpp.1.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-5.8.8-10.el5_0.2

This probably means that there is some other none-CentOS package that
has a dependency on the old perl package. Do you have any special perl
packages installed ?

Regards,
Tim

--
Tim Verhoeven - tim.verhoeven.be@gmail.com - 0479 / 88 11 83

Hoping the problem magically goes away by ignoring it is the
"microsoft approach to programming" and should never be allowed.
(Linus Torvalds)
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 06-26-2008, 05:15 PM
Tony Schreiner
 
Default Upgrade perl; package conflict

On Jun 26, 2008, at 2:55 AM, centos@bartbaars.nl wrote:


Hi!

I'm working on upgrading my Xen Domain0 to CentOs 5.2. However, yum
update gives me a package conflict on perl:


Running Transaction Test
Finished Transaction Test


Transaction Check Error:
file /usr/lib/perl5/5.8.8/pod/perldiag.pod from install of
perl-5.8.8-10.el5_2.3 conflicts with file from package
perl-5.8.8-10.el5_0.2
file /usr/share/man/man1/c2ph.1.gz from install of
perl-5.8.8-10.el5_2.3 conflicts with file from package
perl-5.8.8-10.el5_0.2





This can also happen if you have both i386 and x86_64 version of perl
installed. Only the x86_64 version gets updated, and this leads to
the conflict.


Tony Schreiner
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 06-26-2008, 06:31 PM
Phil Schaffner
 
Default Upgrade perl; package conflict

On Thu, 2008-06-26 at 08:55 +0200, centos@bartbaars.nl wrote:
> Hi!
>
> I'm working on upgrading my Xen Domain0 to CentOs 5.2. However, yum update gives me a package conflict on perl:
...
> Using a x86_64 install btw.
>
> Anyone seen this one??

Please don't hijack threads with a "Reply" when starting a new topic.

This problem is due to the lack of an i386 RPM in x86_64 repos. See
http://bugs.centos.org/view.php?id=2918

Phil


_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 06-26-2008, 06:34 PM
Ralph Angenendt
 
Default Upgrade perl; package conflict

Phil Schaffner wrote:
> On Thu, 2008-06-26 at 08:55 +0200, centos@bartbaars.nl wrote:
>> I'm working on upgrading my Xen Domain0 to CentOs 5.2. However, yum
>> update gives me a package conflict on perl:
> ...
> > Using a x86_64 install btw.
> >
> > Anyone seen this one??
>
> Please don't hijack threads with a "Reply" when starting a new topic.
>
> This problem is due to the lack of an i386 RPM in x86_64 repos. See
> http://bugs.centos.org/view.php?id=2918

perl.i386 is *now* in the extras repository (as stated by the Release
Notes) which is enabled by default. As it is not in upstream's x86_64
tree, it's not going into the CentOS os/ or updates/ tree either.

That's why I closed that bug again.

Ralph
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 06-27-2008, 07:24 AM
 
Default Upgrade perl; package conflict

Removing perl.i386 fixed this...

Thanks!

----- Original Message -----
From: "Ralph Angenendt" <ra+centos@br-online.de>
To: centos@centos.org
Sent: Thursday, June 26, 2008 8:34:11 PM GMT +01:00 Amsterdam / Berlin / Bern / Rome / Stockholm / Vienna
Subject: Re: [CentOS] Upgrade perl; package conflict

Phil Schaffner wrote:
> On Thu, 2008-06-26 at 08:55 +0200, centos@bartbaars.nl wrote:
>> I'm working on upgrading my Xen Domain0 to CentOs 5.2. However, yum
>> update gives me a package conflict on perl:
> ...
> > Using a x86_64 install btw.
> >
> > Anyone seen this one??
>
> Please don't hijack threads with a "Reply" when starting a new topic.
>
> This problem is due to the lack of an i386 RPM in x86_64 repos. See
> http://bugs.centos.org/view.php?id=2918

perl.i386 is *now* in the extras repository (as stated by the Release
Notes) which is enabled by default. As it is not in upstream's x86_64
tree, it's not going into the CentOS os/ or updates/ tree either.

That's why I closed that bug again.

Ralph

_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 06-29-2008, 03:19 PM
"Gregory P. Ennis"
 
Default Upgrade perl; package conflict

On Fri, 2008-06-27 at 09:24 +0200, centos@bartbaars.nl wrote:
> Removing perl.i386 fixed this...
>
> Thanks!
>
> ----- Original Message -----
> From: "Ralph Angenendt" <ra+centos@br-online.de>
> To: centos@centos.org
> Sent: Thursday, June 26, 2008 8:34:11 PM GMT +01:00 Amsterdam / Berlin / Bern / Rome / Stockholm / Vienna
> Subject: Re: [CentOS] Upgrade perl; package conflict
>
> Phil Schaffner wrote:
> > On Thu, 2008-06-26 at 08:55 +0200, centos@bartbaars.nl wrote:
> >> I'm working on upgrading my Xen Domain0 to CentOs 5.2. However, yum
> >> update gives me a package conflict on perl:
> > ...
> > > Using a x86_64 install btw.
> > >
> > > Anyone seen this one??
> >
> > Please don't hijack threads with a "Reply" when starting a new topic.
> >
> > This problem is due to the lack of an i386 RPM in x86_64 repos. See
> > http://bugs.centos.org/view.php?id=2918
>
> perl.i386 is *now* in the extras repository (as stated by the Release
> Notes) which is enabled by default. As it is not in upstream's x86_64
> tree, it's not going into the CentOS os/ or updates/ tree either.
>
> That's why I closed that bug again.
>
> Ralph
>

Ralph,

I am still having this same problem. The only non-CentOS package I have
installed is Astro::Time via cpan. I have looked at the bug report but
am not sure what to do next. I have two x86_64 units that still have
the problem.

Any ideas?

Greg
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 06-29-2008, 03:45 PM
Johnny Hughes
 
Default Upgrade perl; package conflict

Gregory P. Ennis wrote:

On Fri, 2008-06-27 at 09:24 +0200, centos@bartbaars.nl wrote:

Removing perl.i386 fixed this...

Thanks!

----- Original Message -----
From: "Ralph Angenendt" <ra+centos@br-online.de>
To: centos@centos.org
Sent: Thursday, June 26, 2008 8:34:11 PM GMT +01:00 Amsterdam / Berlin / Bern / Rome / Stockholm / Vienna
Subject: Re: [CentOS] Upgrade perl; package conflict

Phil Schaffner wrote:

On Thu, 2008-06-26 at 08:55 +0200, centos@bartbaars.nl wrote:

I'm working on upgrading my Xen Domain0 to CentOs 5.2. However, yum
update gives me a package conflict on perl:

...

Using a x86_64 install btw.

Anyone seen this one??

Please don't hijack threads with a "Reply" when starting a new topic.

This problem is due to the lack of an i386 RPM in x86_64 repos. See
http://bugs.centos.org/view.php?id=2918

perl.i386 is *now* in the extras repository (as stated by the Release
Notes) which is enabled by default. As it is not in upstream's x86_64
tree, it's not going into the CentOS os/ or updates/ tree either.

That's why I closed that bug again.

Ralph



Ralph,

I am still having this same problem. The only non-CentOS package I have
installed is Astro::Time via cpan. I have looked at the bug report but
am not sure what to do next. I have two x86_64 units that still have
the problem.

Any ideas?

Greg


Do you not have extras enabled on this machine?

_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 06-29-2008, 03:46 PM
Karanbir Singh
 
Default Upgrade perl; package conflict

Gregory P. Ennis wrote:

I am still having this same problem. The only non-CentOS package I have
installed is Astro::Time via cpan. I have looked at the bug report but
am not sure what to do next. I have two x86_64 units that still have
the problem.


Make sure the Extras repo is enabled on the machine, the upgrade should
go through fine.



--
Karanbir Singh : http://www.karan.org/ : 2522219@icq
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 06-29-2008, 04:01 PM
"Gregory P. Ennis"
 
Default Upgrade perl; package conflict

On Sun, 2008-06-29 at 10:45 -0500, Johnny Hughes wrote:
> Gregory P. Ennis wrote:
> > On Fri, 2008-06-27 at 09:24 +0200, centos@bartbaars.nl wrote:
> >> Removing perl.i386 fixed this...
> >>
> >> Thanks!
> >>
> >> ----- Original Message -----
> >> From: "Ralph Angenendt" <ra+centos@br-online.de>
> >> To: centos@centos.org
> >> Sent: Thursday, June 26, 2008 8:34:11 PM GMT +01:00 Amsterdam / Berlin / Bern / Rome / Stockholm / Vienna
> >> Subject: Re: [CentOS] Upgrade perl; package conflict
> >>
> >> Phil Schaffner wrote:
> >>> On Thu, 2008-06-26 at 08:55 +0200, centos@bartbaars.nl wrote:
> >>>> I'm working on upgrading my Xen Domain0 to CentOs 5.2. However, yum
> >>>> update gives me a package conflict on perl:
> >>> ...
> >>>> Using a x86_64 install btw.
> >>>>
> >>>> Anyone seen this one??
> >>> Please don't hijack threads with a "Reply" when starting a new topic.
> >>>
> >>> This problem is due to the lack of an i386 RPM in x86_64 repos. See
> >>> http://bugs.centos.org/view.php?id=2918
> >> perl.i386 is *now* in the extras repository (as stated by the Release
> >> Notes) which is enabled by default. As it is not in upstream's x86_64
> >> tree, it's not going into the CentOS os/ or updates/ tree either.
> >>
> >> That's why I closed that bug again.
> >>
> >> Ralph
> >>
> >
> > Ralph,
> >
> > I am still having this same problem. The only non-CentOS package I have
> > installed is Astro::Time via cpan. I have looked at the bug report but
> > am not sure what to do next. I have two x86_64 units that still have
> > the problem.
> >
> > Any ideas?
> >
> > Greg
>
> Do you not have extras enabled on this machine?
>
> _______________________________________________

Yes I do have extra's enabled.
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 

Thread Tools




All times are GMT. The time now is 03:16 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org