Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   CentOS (http://www.linux-archive.org/centos/)
-   -   wpa_supplicant and machine freezes (http://www.linux-archive.org/centos/102901-wpa_supplicant-machine-freezes.html)

Timothy Kesten 06-08-2008 04:55 PM

wpa_supplicant and machine freezes
 
Hi Folks,

I'd like to install my USB-WLAN-Stick Netgear WG111v3.
Ndiswrapper works correct after installing Kernel-Modules from atrpm

ndiswrapper-kmdl-2.6.18-53.1.19.el5.centos.plus-1.52-16.el5.i686.rpm.

But by calling wpa_supplicant with

wpa_supplicant -i wlan0 -D wext -c /etc/wpa_supplicant/wpa_supplicant.conf -d

machine freezes.

My wpa_supplicant.conf:

ctrl_interface=/var/run/wpa_supplicant
eapol_version=1
ap_scan=1
network={
ssid="MyNet"
scan_ssid=1
proto=WPA
key_mgmt=WPA-PSK
pairwise=TKIP
group=TKIP
#psk="MyPSK"
psk=9050ec6fe020b1738fce16c93c33b3809b9e62d5e6bf95 5518076eb2d7263
}

With this configuration it works correct with Sidux (a debian clone).

But with CentOS 5.1 ....???

No hints in /var/log/messages or dmesg available.

Has somebody an advice/ a solution for me?
More information needed?

Thx
Timothy
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos

Johnny Hughes 06-09-2008 11:56 AM

wpa_supplicant and machine freezes
 
Timothy Kesten wrote:

Hi Folks,

I'd like to install my USB-WLAN-Stick Netgear WG111v3.
Ndiswrapper works correct after installing Kernel-Modules from atrpm

ndiswrapper-kmdl-2.6.18-53.1.19.el5.centos.plus-1.52-16.el5.i686.rpm.

But by calling wpa_supplicant with

wpa_supplicant -i wlan0 -D wext -c /etc/wpa_supplicant/wpa_supplicant.conf -d

machine freezes.

My wpa_supplicant.conf:

ctrl_interface=/var/run/wpa_supplicant
eapol_version=1
ap_scan=1
network={
ssid="MyNet"
scan_ssid=1
proto=WPA
key_mgmt=WPA-PSK
pairwise=TKIP
group=TKIP
#psk="MyPSK"
psk=9050ec6fe020b1738fce16c93c33b3809b9e62d5e6bf95 5518076eb2d7263
}



Nothing about that file stands out as wrong to me.

I have not used the ndiswrapper from atrpms, so I can't comment on that.

Have you tried NetworkManager?

https://fedoraproject.org/wiki/Tools/NetworkManager

We will have a newer version of Network Manager and wpa_supplicant in
the soon to be released CentOS-5.2 (as well as more hardware supported
in the 5.2 kernel), so maybe that will help.



With this configuration it works correct with Sidux (a debian clone).

But with CentOS 5.1 ....???

No hints in /var/log/messages or dmesg available.

Has somebody an advice/ a solution for me?
More information needed?


_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos


All times are GMT. The time now is 10:14 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.