FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > CentOS > CentOS

 
 
LinkBack Thread Tools
 
Old 06-04-2008, 09:03 PM
"Dongyoon Lee"
 
Default Installing GLIBC for CentOS 4.6

I'd like to modify pthread library ( e.g.*manipulating*some functions ) in*glibc,*so I want to compile and install modified glibc.
However, I failed to compile glibc and need some help. How can I fix the problem?
*

Here*is the process*that I've tried.
1.*download glibc-2.3.4.tar.tar from http://ftp.gnu.org/gnu/glibc/
2. unzip glibc-2.3.4.tar.tar
3. make build-folder
[root@localhost /]# mkdir glibc-2.3.4-build
[root@localhost /]# cd glibc-2.3.4-build
4. configure (in the build-folder)
[root@localhost /]# ../glibc-2.3.4/configure --prefix=/usr --enable-add-ons5. make (in the build-folder)
[root@localhost /]# make
.....
make* -C csu subdir_lib
make[2]: Entering directory `/mnt/hgfs/CentOS-4.6-i386_Shared/glibc-2.3.4/csu'
/mnt/hgfs/CentOS-4.6-i386_Shared/glibc-2.3.4-build/bits/stdio_lim.d:1: warning: NUL character seen; rest of line ignored

/mnt/hgfs/CentOS-4.6-i386_Shared/glibc-2.3.4-build/bits/stdio_lim.d:1: *** missing separator.* Stop.
make[2]: Leaving directory `/mnt/hgfs/CentOS-4.6-i386_Shared/glibc-2.3.4/csu'
make[1]: *** [csu/subdir_lib] Error 2

make[1]: Leaving directory `/mnt/hgfs/CentOS-4.6-i386_Shared/glibc-2.3.4'
make: *** [all] Error 2
*
FYI, Here is my current information.
*
[root@localhost /]# cat /proc/version
Linux version 2.6.9-67.ELsmp (mockbuild@builder10.centos.org) (gcc version 3.4.6 20060404 (Red Hat 3.4.6-9)) #1 SMP Fri Nov 16 12:48:03 EST 2007


[root@localhost /]# rpm -qa | grep gcc
gcc-3.4.6-9
gcc4-gfortran-4.1.2-14.EL4
gcc4-java-4.1.2-14.EL4
gcc-objc-3.4.6-9
gcc-g77-3.4.6-9
gcc4-4.1.2-14.EL4
compat-gcc-32-c++-3.2.3-47.3
gcc-gnat-3.4.6-9

gcc4-c++-4.1.2-14.EL4
compat-gcc-32-3.2.3-47.3
libgcc-3.4.6-9
gcc-java-3.4.6-9
gcc-c++-3.4.6-9
compat-libgcc-296-2.96-132.7.2

[root@localhost /]# rpm -qa | grep glibc
glibc-kernheaders-2.4-9.1.100.EL
glibc-2.3.4-2.39
glibc-headers-2.3.4-2.39
glibc-common-2.3.4-2.39
glibc-devel-2.3.4-2.39
compat-glibc-headers-2.3.2-95.30

glibc-utils-2.3.4-2.39
compat-glibc-2.3.2-95.30
glibc-profile-2.3.4-2.39

*
*
*
*
*
*
*
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 
Old 06-04-2008, 09:11 PM
"Jim Perrin"
 
Default Installing GLIBC for CentOS 4.6

On Wed, Jun 4, 2008 at 5:03 PM, Dongyoon Lee <dongyoon@gmail.com> wrote:
> I'd like to modify pthread library ( e.g. manipulating some functions )
> in glibc, so I want to compile and install modified glibc.
> However, I failed to compile glibc and need some help. How can I fix the
> problem?

Messing with glibc must be done very carefully since the entire distro
depends on it. Also, updating glibc via source, when the system
expects an rpm is REALLY going to screw things up.

If you absolutely, positively have to mess with glibc, get the src.rpm
and rebuild with your own options.

--
During times of universal deceit, telling the truth becomes a revolutionary act.
George Orwell
_______________________________________________
CentOS mailing list
CentOS@centos.org
http://lists.centos.org/mailman/listinfo/centos
 

Thread Tools




All times are GMT. The time now is 09:37 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org