Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   CentOS Development (http://www.linux-archive.org/centos-development/)
-   -   Incorrect info in .treeinfo file (http://www.linux-archive.org/centos-development/605088-incorrect-info-treeinfo-file.html)

James Hogarth 12-01-2011 01:08 PM

Incorrect info in .treeinfo file
 
As per http://bugs.centos.org/view.php?id=5237 the .treeinfo file
still has a reference to boot.iso although it doesn't exist.

This breaks 'smart mirror' stuff like pulp from syncing properly as it
exits on the non-existent file when setting up a distribution tree for
kickstart purposes.

Any one with access able to remove/correct the errant line?

Regards,

James
_______________________________________________
CentOS-devel mailing list
CentOS-devel@centos.org
http://lists.centos.org/mailman/listinfo/centos-devel

Johnny Hughes 12-01-2011 01:16 PM

Incorrect info in .treeinfo file
 
On 12/01/2011 08:08 AM, James Hogarth wrote:
> As per http://bugs.centos.org/view.php?id=5237 the .treeinfo file
> still has a reference to boot.iso although it doesn't exist.
>
> This breaks 'smart mirror' stuff like pulp from syncing properly as it
> exits on the non-existent file when setting up a distribution tree for
> kickstart purposes.
>
> Any one with access able to remove/correct the errant line?

Yes ... we are looking at that issue in 6.1 right now.

_______________________________________________
CentOS-devel mailing list
CentOS-devel@centos.org
http://lists.centos.org/mailman/listinfo/centos-devel

Karanbir Singh 12-01-2011 02:22 PM

Incorrect info in .treeinfo file
 
On 12/01/2011 02:08 PM, James Hogarth wrote:
> As per http://bugs.centos.org/view.php?id=5237 the .treeinfo file
> still has a reference to boot.iso although it doesn't exist.
>
> This breaks 'smart mirror' stuff like pulp from syncing properly as it
> exits on the non-existent file when setting up a distribution tree for
> kickstart purposes.

this is fixed in the 6.1 media, I can change this in the
mirror.centos.org http mirrors, but ofcourse its not going to get fixed
in the 6.0 media out there :)

- KB
_______________________________________________
CentOS-devel mailing list
CentOS-devel@centos.org
http://lists.centos.org/mailman/listinfo/centos-devel

James Hogarth 12-01-2011 02:29 PM

Incorrect info in .treeinfo file
 
>
> Yes ... we are looking at that issue in 6.1 right now.
>
>

Great to hear - thanks for the update Johnny.
_______________________________________________
CentOS-devel mailing list
CentOS-devel@centos.org
http://lists.centos.org/mailman/listinfo/centos-devel

James Hogarth 12-01-2011 02:30 PM

Incorrect info in .treeinfo file
 
>
> this is fixed in the 6.1 media, I can change this in the
> mirror.centos.org http mirrors, but ofcourse its not going to get fixed
> in the 6.0 media out there :)
>
> - KB

No worries on the media KB - I can fix my own media - it's just about
syncing with upstream ;)
_______________________________________________
CentOS-devel mailing list
CentOS-devel@centos.org
http://lists.centos.org/mailman/listinfo/centos-devel

Karanbir Singh 12-01-2011 02:53 PM

Incorrect info in .treeinfo file
 
On 12/01/2011 03:30 PM, James Hogarth wrote:
>> this is fixed in the 6.1 media, I can change this in the
>> mirror.centos.org http mirrors, but ofcourse its not going to get fixed
>> in the 6.0 media out there :)
> No worries on the media KB - I can fix my own media - it's just about
> syncing with upstream ;)

Have you test with that line gone from .treeinfo ? Does the key still
need to exist ? I suspect were going to break other apps by completely
removing the key

- KB
_______________________________________________
CentOS-devel mailing list
CentOS-devel@centos.org
http://lists.centos.org/mailman/listinfo/centos-devel

James Hogarth 12-01-2011 03:17 PM

Incorrect info in .treeinfo file
 
>
> Have you test with that line gone from .treeinfo ? Does the key still
> need to exist ? I suspect were going to break other apps by completely
> removing the key
>

Over this way things still appeared to work fine with that particular
line gone but honestly I haven't had time here to to exhaustive
multiple tests beyond pulp sync against a repo with that line gone and
some kickstart installs here with it gone.....

If you guys are already working through a similar issue in QA for 6.1
then let it be settled there and ignore the current mirrors for now -
I can work around it in my environment here so it isn't a significant
issue for me - just wanted to highlight it given that pointing to a
file that doesn't exist is naturally bad behaviour from general
perspective.....

Unfortunately I don't even have any upstream media here to confirm
what that says given that boot.iso was removed with 6.0 and is a 5.X
item...

I do wonder what other apps might be reading it and how they are
behaving given the file doesn't exist.

James
_______________________________________________
CentOS-devel mailing list
CentOS-devel@centos.org
http://lists.centos.org/mailman/listinfo/centos-devel


All times are GMT. The time now is 09:09 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.