FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > CentOS > CentOS Development

 
 
LinkBack Thread Tools
 
Old 05-04-2011, 07:31 AM
"Dmitry E. Mikhailov"
 
Default sata_via and WD drives incompatibility patch

Greetings,

I was hit by an infamous hardware incompatibility between VIA VT6420/1 sata
card (sata_via) and newer Western Digital drives.

The bug has been worked around in mainline kernel at 2.6.32.7,
* https://bugzilla.kernel.org/show_bug.cgi?id=15173
* http://article.gmane.org/gmane.linux.ide/46352
* http://thread.gmane.org/gmane.linux.kernel/1062139

The sata_via patch from bug#15173 applies cleanly to sata_via module of
2.6.18-238 and now I'm running using a 'fixed' module with no problem.

Unfortunately the patched module uses symbols not from kABI whitelist so
universal replacement kernel module could not be made, but the patch itself
could be integrated to upstream's tree or into the CentOS-Plus kernel. As I'm
not a RHEL subscriber, I can only ask for the latter.

Any ideas?


Best regards,
Dmitry Mikhailov
_______________________________________________
CentOS-devel mailing list
CentOS-devel@centos.org
http://lists.centos.org/mailman/listinfo/centos-devel
 
Old 05-04-2011, 08:53 AM
Akemi Yagi
 
Default sata_via and WD drives incompatibility patch

On Wed, May 4, 2011 at 12:31 AM, Dmitry E. Mikhailov
<d.mikhailov@infocommunications.ru> wrote:
> Greetings,
>
> I was hit by an infamous hardware incompatibility between VIA VT6420/1 sata
> card (sata_via) and newer Western Digital drives.
>
> The bug has been worked around in mainline kernel at 2.6.32.7,
> * * * * * https://bugzilla.kernel.org/show_bug.cgi?id=15173
> * * * * * http://article.gmane.org/gmane.linux.ide/46352
> * * * * * http://thread.gmane.org/gmane.linux.kernel/1062139
>
> The sata_via patch from bug#15173 applies cleanly to sata_via module of
> 2.6.18-238 and now I'm running using a 'fixed' module with no problem.
>
> Unfortunately the patched module uses symbols not from kABI whitelist so
> universal replacement kernel module could not be made, but the patch itself
> could be integrated to upstream's tree or into the CentOS-Plus kernel. As I'm
> not a RHEL subscriber, I can only ask for the latter.
>
> Any ideas?

Getting the patch into the centosplus kernel is as easy as filing a
request at http://bugs.centos.org .

Regarding the upstream kernel, you don't have to be a customer to
report a bug at http://bugzilla.redhat.com . In this case, because the
patch is already in mainline kernel, there is some good chance that it
is picked up by Red Hat.

Akemi
_______________________________________________
CentOS-devel mailing list
CentOS-devel@centos.org
http://lists.centos.org/mailman/listinfo/centos-devel
 
Old 05-04-2011, 04:17 PM
Ned Slider
 
Default sata_via and WD drives incompatibility patch

On 04/05/11 08:31, Dmitry E. Mikhailov wrote:
> Greetings,
>
> I was hit by an infamous hardware incompatibility between VIA VT6420/1 sata
> card (sata_via) and newer Western Digital drives.
>
> The bug has been worked around in mainline kernel at 2.6.32.7,
> * https://bugzilla.kernel.org/show_bug.cgi?id=15173
> * http://article.gmane.org/gmane.linux.ide/46352
> * http://thread.gmane.org/gmane.linux.kernel/1062139
>
> The sata_via patch from bug#15173 applies cleanly to sata_via module of
> 2.6.18-238 and now I'm running using a 'fixed' module with no problem.
>
> Unfortunately the patched module uses symbols not from kABI whitelist so
> universal replacement kernel module could not be made, but the patch itself
> could be integrated to upstream's tree or into the CentOS-Plus kernel. As I'm
> not a RHEL subscriber, I can only ask for the latter.
>
> Any ideas?
>
>
> Best regards,
> Dmitry Mikhailov

Hi Dmitry,

There are actually 3 relevant patches in the latest upstream kernel
(2.6.38.5) for this issue:

2010-11-19 Tejun Heo sata_via: apply magic FIFO fix to vt6420 too
2010-06-02 Tejun Heo sata_via: magic vt6421 fix for transmission
problems...
2010-06-07 Tejun Heo sata_via: explain the magic fix


ELRepo has updated drivers for sata_via available that fix this issue
for both EL5 and EL6:

http://elrepo.org
http://elrepo.org/tiki/kmod-sata_via
http://lists.elrepo.org/pipermail/elrepo/2011-May/000660.html

As this isn't really a CentOS Development issue, can I ask that we take
any discussion of the above to the elrepo mailing lists and/or bug tracker:

http://lists.elrepo.org/mailman/listinfo/elrepo
http://elrepo.org/bugs/

Thanks.

_______________________________________________
CentOS-devel mailing list
CentOS-devel@centos.org
http://lists.centos.org/mailman/listinfo/centos-devel
 

Thread Tools




All times are GMT. The time now is 01:10 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org