FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > CentOS > CentOS Development

 
 
LinkBack Thread Tools
 
Old 02-17-2011, 05:04 PM
Les Mikesell
 
Default php-5.2.x needs adopting

On 2/17/2011 11:45 AM, Remi Collet wrote:
>
>> We've had a php-5.2 in c5-testing which was based on the rhwas sources
>> from upstream. Quite a few people have that package in production at
>> various places however, this looks mostly unsupported upstream now.
>>
>> Would someone like to adopt the 5.2 packages, bring them upto 5.2.17 and
>> maintain it going forward for c5 ?
>>
>
> Sorry but I think this will be a terrible mistake
> (even if I'm going to hurt some people)
>
> AFAIK, CentOS is a RHEL clone.
>
> So, cloning package for RHEL is ok
> Cloning package from RHWAS is also ok (in a sub-repository, of course)
>
> RHWAS provides php-5.2.10-1.el5s2 as should CentOS
>
> I think that providing packages which are not RH's upstream introduce a
> terrible confusion for final users.
>
> I think this is definitively something for third party repositories.
>
>
> So, to resume, is CentOS a clone or a fork of RHEL ?

http://wiki.centos.org/AdditionalResources/Repositories
(note the extras/plus repos)

If you enable the non-default CentOSPlus repo, it might be reasonable to
consider it a fork. But, anything that can co-exist with a stock RHEL
distro probably belongs in EPEL or one of the other repos used by RHEL
and all clones.

--
Les Mikesell
lesmikesell@gmail.com
_______________________________________________
CentOS-devel mailing list
CentOS-devel@centos.org
http://lists.centos.org/mailman/listinfo/centos-devel
 
Old 02-18-2011, 10:27 AM
Karanbir Singh
 
Default php-5.2.x needs adopting

On 02/17/2011 05:45 PM, Remi Collet wrote:
> RHWAS provides php-5.2.10-1.el5s2 as should CentOS

isnt rhwas now abandoned ?

> So, to resume, is CentOS a clone or a fork of RHEL ?
>

The centos project != centos the distro, which of the two are you
talking about here ? ( Les already kinda cleared the air a bit but.. )

- KB
_______________________________________________
CentOS-devel mailing list
CentOS-devel@centos.org
http://lists.centos.org/mailman/listinfo/centos-devel
 
Old 02-19-2011, 10:46 AM
Johnny Hughes
 
Default php-5.2.x needs adopting

On 02/17/2011 11:45 AM, Remi Collet wrote:
> Le 17/02/2011 07:29, Karanbir Singh a écrit :
>> hi guys,
>>
>> We've had a php-5.2 in c5-testing which was based on the rhwas sources
>> from upstream. Quite a few people have that package in production at
>> various places however, this looks mostly unsupported upstream now.
>>
>> Would someone like to adopt the 5.2 packages, bring them upto 5.2.17 and
>> maintain it going forward for c5 ?
>>
>
> Sorry but I think this will be a terrible mistake
> (even if I'm going to hurt some people)
>
> AFAIK, CentOS is a RHEL clone.
>
> So, cloning package for RHEL is ok
> Cloning package from RHWAS is also ok (in a sub-repository, of course)
>
> RHWAS provides php-5.2.10-1.el5s2 as should CentOS
>
> I think that providing packages which are not RH's upstream introduce a
> terrible confusion for final users.
>
> I think this is definitively something for third party repositories.
>
>
> So, to resume, is CentOS a clone or a fork of RHEL ?
>

CentOSPlus is a fork of RHEL (or at least some added packages) ... the
CentOS Base is a clone of it.

_______________________________________________
CentOS-devel mailing list
CentOS-devel@centos.org
http://lists.centos.org/mailman/listinfo/centos-devel
 
Old 02-19-2011, 10:47 AM
Johnny Hughes
 
Default php-5.2.x needs adopting

On 02/18/2011 05:27 AM, Karanbir Singh wrote:
> On 02/17/2011 05:45 PM, Remi Collet wrote:
>> RHWAS provides php-5.2.10-1.el5s2 as should CentOS
>
> isnt rhwas now abandoned ?
>
>> So, to resume, is CentOS a clone or a fork of RHEL ?
>>
>
> The centos project != centos the distro, which of the two are you
> talking about here ? ( Les already kinda cleared the air a bit but.. )
>

I do believe in 5.6 there will now be a php53 along with the php.

I don't know what that means for rhwas.



_______________________________________________
CentOS-devel mailing list
CentOS-devel@centos.org
http://lists.centos.org/mailman/listinfo/centos-devel
 
Old 02-19-2011, 11:01 AM
js
 
Default php-5.2.x needs adopting

Hello,

The "main problem" with IUS repo for php5.2: too many deps.
If you need the same deps as RHWAS, simply download the srpm from RH:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/RHWAS/SRPMS/php-5.2.10-1.el5s2.src.rpm
replace the archive php-5.2.10.tar.gz when extracting srpm by the
php-5.2.17 from php.net
update the version number in the spec file
rebuild

And All done; no compilation problem, this version is working very well
(6 production servers actually running
glpi, groupoffice, zarafa, no problem at all):

http://www.interlug.net/sandbox/linux/centos5/SRPMS/php-5.2.17-1.src.rpm
binaries for i386: http://www.interlug.net/sandbox/linux/centos5/i386/


Regards,

js.


Le 17/02/11 10:49, Martin Kocourek a écrit :
> On 17.2.2011 07:29, Karanbir Singh wrote:
>> Would someone like to adopt the 5.2 packages, bring them upto 5.2.17 and
>> maintain it going forward for c5 ?
> Hi,
>
> it's not needed anymore I think.
>
> In IUS Community repo (http://iuscommunity.org/) are both PHP 5.2 and
> PHP 5.3 with plenty of modules and additional packages.
>
> It's maintained very well IMHO and both versions works rock solid (if
> it's possible at all for PHP ;-) )
>
>
> Martin Kocourek
>
> _______________________________________________
> CentOS-devel mailing list
> CentOS-devel@centos.org
> http://lists.centos.org/mailman/listinfo/centos-devel

_______________________________________________
CentOS-devel mailing list
CentOS-devel@centos.org
http://lists.centos.org/mailman/listinfo/centos-devel
 
Old 02-19-2011, 11:22 AM
"John R. Dennison"
 
Default php-5.2.x needs adopting

On Sat, Feb 19, 2011 at 04:01:17PM +0400, js wrote:
> Hello,
>
> The "main problem" with IUS repo for php5.2: too many deps.

Please don't top-post.

What "problem" are you seeing with IUS exactly? I've got their
5.2 running on a couple different server farms without any
issues at all; same for their 5.3 for what it's worth.




John
--
Human beings hardly ever learn from the experience of others. They learn;
when they do, which isn't often, on their own, the hard way.

-- Robert Heinlein (1907-1988), American science fiction writer, Time
Enough for Love (1973)
_______________________________________________
CentOS-devel mailing list
CentOS-devel@centos.org
http://lists.centos.org/mailman/listinfo/centos-devel
 
Old 02-19-2011, 11:33 AM
js
 
Default php-5.2.x needs adopting

Le 19/02/11 16:22, John R. Dennison a écrit :
> On Sat, Feb 19, 2011 at 04:01:17PM +0400, js wrote:
>> Hello,
>>
>> The "main problem" with IUS repo for php5.2: too many deps.
> Please don't top-post.
>
> What "problem" are you seeing with IUS exactly? I've got their
> 5.2 running on a couple different server farms without any
> issues at all; same for their 5.3 for what it's worth.
>
>
>
>
> John
Hello too,

When you try to rebuild srpm using IUS srpm, you need to have a lot of
extra dependencies (oracle libs, freetds ..)
that's why i rebuild from RHWAS srpms.

If the problem is to maintain php from RHWAS, the IUS srpm is maybe not
a good solution.
If you only want binaries, ok IUS is perfect

Regards,

js



_______________________________________________
CentOS-devel mailing list
CentOS-devel@centos.org
http://lists.centos.org/mailman/listinfo/centos-devel
 
Old 02-19-2011, 11:58 AM
"John R. Dennison"
 
Default php-5.2.x needs adopting

On Sat, Feb 19, 2011 at 04:33:14PM +0400, js wrote:
>
> If you only want binaries, ok IUS is perfect

I was indeed thinking only of the binary packages from IUS;
thanks for the clarification



John
--
Since when do we have to agree with people to defend them from injustice?

-- Lillian Hellman (1905-1984), American playwright
_______________________________________________
CentOS-devel mailing list
CentOS-devel@centos.org
http://lists.centos.org/mailman/listinfo/centos-devel
 
Old 02-21-2011, 01:41 PM
Karanbir Singh
 
Default php-5.2.x needs adopting

On 02/17/2011 06:49 AM, Martin Kocourek wrote:
> In IUS Community repo (http://iuscommunity.org/) are both PHP 5.2 and
> PHP 5.3 with plenty of modules and additional packages.

third party packaging setups are free to solve their own problems, that
does not mean we should leave people hanging if they decided to use a
package set that we put out.

- KB
_______________________________________________
CentOS-devel mailing list
CentOS-devel@centos.org
http://lists.centos.org/mailman/listinfo/centos-devel
 

Thread Tools




All times are GMT. The time now is 08:48 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org